You are not logged in.

#1 2013-03-02 08:41:01

axper
Member
Registered: 2013-01-25
Posts: 115

Pulseaudio rapidly automatically switches output ports

I have been having this issue for quite a long time now. When louder sound plays I hear choppy output. When that happens, I can see that in pavucontrol -> Output devices -> "Built-in Audio Analog Stereo" -> "Port:" selection rapidly switches between Headphones and Analog output. When output is loud, it selects Analog output and when it's more silent, it switches to Headphones. Since happens very fast and because "Analog output" and "Headphones" have different output levels, I get choppy sound. So how do I make pulseaudio not switch between ports? I am thankful that pulseaudio cares about my ears, but I'd prefer if it didn't.

One solution is to set both "Headphones" and "Analog Stereo" to same level, but I don't think it's an elegant solution. Another way to stop this is to set output less than ~80%, but this isn't acceptable either.

I use headphones btw, and default output device Port is "Headphones" in pavucontrol.

P.S. Issue also described here.

Last edited by axper (2013-03-02 13:05:46)

Offline

#2 2013-03-05 17:32:58

axper
Member
Registered: 2013-01-25
Posts: 115

Re: Pulseaudio rapidly automatically switches output ports

And also here, but solution doesn't work for me: when I mute "Headphone" channel in alsamixer (by selecting it and pressing M) it mutes everything.

Also cmon 60 views and no ones has any clue?

Offline

#3 2013-05-30 19:35:28

eeg
Member
From: Ooozetralia
Registered: 2009-03-11
Posts: 25

Re: Pulseaudio rapidly automatically switches output ports

Hi axper,

This is not a new problem. My belief is that this is a low-level issue originating from the drivers. Are you by chance using an onboard RealTek ALC892 audio chip?

This is likely an issue with the auto jack-sensing features in the hardware itself. That is, when you plug in your 3.5mm input, the chip can sense and feedback the event to the drivers. This is probably where the Linux/ALSA drivers are tripping up. I know it's not a hardware defect as I have a windows partition and everything is smooth sailing there.

I reported this in my own thread almost 10 months back, with no resolution. Don't hold your breath for a fix any time soon. This was reported as far back as 2011 and deemed "low priority". hmm

I side-stepped the issue by plugging my audio output to an AV receiver via optical. No issue with audio since. (yes, I know this is not a real solution... but hey, this is Linux we're talking about)

Sorry I couldn't be much more help.

Offline

#4 2013-05-31 20:50:34

chancho
Member
From: Hong Kong
Registered: 2006-07-14
Posts: 112

Re: Pulseaudio rapidly automatically switches output ports

instead of muting a port, can you disable the port in the pavucontrol->configuration->profile ?

Offline

#5 2013-06-02 17:10:39

eeg
Member
From: Ooozetralia
Registered: 2009-03-11
Posts: 25

Re: Pulseaudio rapidly automatically switches output ports

Saw chancho's post and was fiddling around with pavucontrol... and found a workaround.

Under pavucontrol->configuration->profile, instead of selecting Analog Stereo Output, use Analog Surround 4.0 Output.

That seemed to stop the choppiness and the constant switching between Analog Stereo and Headphones (which occurs in both pavucontrol and alsamixer) for me.

Audio is ok for me as 4.0 is "fake surround" (basic stereo channels copied to the rear). Don't use the 5.1 or 7.1 outputs as you'll probably lose the audio from the center and subwoofer channels.

Hope this helps.

Offline

#6 2013-06-02 19:55:21

axper
Member
Registered: 2013-01-25
Posts: 115

Re: Pulseaudio rapidly automatically switches output ports

eeg wrote:

Are you by chance using an onboard RealTek ALC892 audio chip?

My sound card is 5.1 channel by Realtek® ALC662 according to my motherboard's specs.

I plugged my headphones to back of the case, and this stopped happening. I really don't want to mess with sound now as it's finally working, and also front jack (which I used to use) is defected, sorry, can't test the suggestion.

Offline

#7 2013-07-01 20:12:27

axper
Member
Registered: 2013-01-25
Posts: 115

Re: Pulseaudio rapidly automatically switches output ports

OK I got this problem back, it happens with rear port as well.

In pavucontrol -> Configuration tab I have 2 controllers:

  1. "High Definition Audio Controller", which I guess is my nvidia card output which I don't use anyways, and It doesn't do anything when select it

  2. "Built-in Audio", which I guess is motherboard's ports, and it has the following profiles:

    • Analog Stereo Duplex

    • Analog Stereo Output

    • Analog Stereo Input

    • Off

    With these profiles happens exactly what I have described in original post.

    • Digital Stereo (IEC958) Output + Analog Stereo Input

    • Digital Stereo (IEC958) Output

    With these profiles, I still get exact same cracking audio, however in "Output Devices" tab a new "Built-in Audio Digital Stereo (IEC958)" appears, below normal "Built-in Audio Analog Stereo", AND the "Port" Selection does NOT change.

chancho wrote:

instead of muting a port, can you disable the port in the pavucontrol->configuration->profile ?

You mean set "Profile" to Off? I tried that, same result.

eeg wrote:

Under pavucontrol->configuration->profile, instead of selecting Analog Stereo Output, use Analog Surround 4.0 Output.

I have no Surround 4.0 Ouptput in the menu.

Any direction what to try next would be appreciated.

Last edited by axper (2013-07-01 20:16:49)

Offline

#8 2013-07-14 09:39:11

axper
Member
Registered: 2013-01-25
Posts: 115

Re: Pulseaudio rapidly automatically switches output ports

I managed to bypass the issue... sort of. Switched to ALSA, same problem there as well. In alsamixer I disabled the auto-mute option (by selecting it pressing -) and problem is gone.

Problem remains in pulseaudio though, does anyone know what's the equivalent of disabling auto-mute in pulseaudio?

Offline

#9 2013-10-04 23:30:39

stundrum
Member
Registered: 2013-09-17
Posts: 8

Re: Pulseaudio rapidly automatically switches output ports

hmmm try installing hda-verb from AUR and then run:

# hda-verb /dev/snd/hwC0D2 0x1b SET_PIN_WIDGET_CONTROL 0x82

i have ALC662 and this works for me

Offline

Board footer

Powered by FluxBB