You are not logged in.

#1 2013-03-04 01:40:42

vikyboss
Member
Registered: 2010-12-27
Posts: 22

[Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

XFCE audio mixer panel plugin used to show the correct volume when I change the volume either with my Laptop touchbuttons or keyboard volume buttons.

1.  To make sure if I am actually changing the volume, I opened alsamixer and tested pressing keys they work fine.
2.  I even opened properties option from the indicator and set it to "Master"(the one I use) of my speaker, still no luck.
3. The only problem is the indicator doesnt update when the volume is changed or muted.

But for unknow reason this problem started last week.

Thanks for the help.

Last edited by vikyboss (2013-06-23 16:27:36)

Offline

#2 2013-03-08 06:04:22

T.J.S.
Member
Registered: 2012-08-14
Posts: 83

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

I have the same issue.
You can actually change the volume from the indicator, but as you said it doesn't get "updated" when you do it with the keyboard.

edit. And it's not just the plugin/indicator, if you open audio mixer (menu->multimedia) the same thing happens. (though I'm not sure if this wasn't the case before)

Last edited by T.J.S. (2013-03-08 06:10:22)

Offline

#3 2013-03-13 13:18:29

vikyboss
Member
Registered: 2010-12-27
Posts: 22

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

T.J.S. wrote:

I have the same issue.
You can actually change the volume from the indicator, but as you said it doesn't get "updated" when you do it with the keyboard.

edit. And it's not just the plugin/indicator, if you open audio mixer (menu->multimedia) the same thing happens. (though I'm not sure if this wasn't the case before)


Thanks for the reply. For me changing in Audio Mixer(menu->multimedia) changes the volume as same as keyboard changing. But as I said the problem remains with the indicator that doesn't updated when audio volume is updated.
I think it might be a bug in the xfce audio mixer indicator or audio mixer itself.

Offline

#4 2013-03-13 13:26:48

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

I can confirm I have this same issue also.

Offline

#5 2013-04-12 17:09:54

indianahorst
Member
Registered: 2008-08-23
Posts: 72

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

Problem still exists... has anybody found a solution?

Offline

#6 2013-04-13 16:30:21

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

I have pulseaudio also.

What the keyboard key for VOL UP and VOL DOWN do now is: only update the PULSEAUDIO volume.

So if I change Properties/Sound Card: PLAYBACK(pulseaudio) in the AUDIO MIXER (on the TASKBAR), to PULSEAUDIO it will update the volume.
If I change the Properties/Sound Card:  ALSA, it will NOT update the volume.

THE VOL UP AND VOL DOWN keys do not change the volume for ALSA.

and I am using the following commands for the keys (in the keyboard config):

amixer set Master 5%+
amixer set Master 5%-
amixer set Master toggle

Last edited by Kilzool (2013-04-13 16:31:39)

Offline

#7 2013-05-08 16:44:23

emto
Member
Registered: 2013-05-08
Posts: 13

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

Same issue for me.

If I change any volume from xfce4-mixer it change at alsamixer too, but not from alsa to xfce4-mixer.

It happens since 2013 march, first days.

64 bits, totally update at 2013-05-08
Linux 3.8.11-1-ARCH

Offline

#8 2013-05-24 13:19:36

ravicious
Member
From: Poland
Registered: 2011-06-07
Posts: 69
Website

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

I have the same issue as emto, any progress on this?

Offline

#9 2013-05-25 22:38:28

Kopfweh
Member
Registered: 2011-08-06
Posts: 72

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

Hey guys, I'm following. I have the same issue, too. Since weeks or even months. After I didn't find a solution, I finally got up with it. Would be a great thing, if a solution could be found!

Offline

#10 2013-05-26 01:33:57

vikyboss
Member
Registered: 2010-12-27
Posts: 22

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

Actually the problem seems to be resolved. I have a fully updated system and installed xfce again few days ago. And it works miraculously..

Installed versions:
1. xfce4-mixer 4.10.0
2. Advanced Linux Sound Architecture Driver Version k3.9.3-1-ARCH

Offline

#11 2013-05-26 05:47:25

ravicious
Member
From: Poland
Registered: 2011-06-07
Posts: 69
Website

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

Oh, I actually fixed this myself yesterday. I installed pulseaudio, pulseaudio-alsa and xfce4-volumed-pulse (from AUR) and then removed volume shortcuts from xfce4-keyboard-settings. In xfce4-mixer, you just have to choose a proper playback as a sound card.

Offline

#12 2013-05-26 13:12:32

Kopfweh
Member
Registered: 2011-08-06
Posts: 72

Re: [Solvd]XFCE mixer panel plugin doesn't get updated when volume changed

vikyboss wrote:

Actually the problem seems to be resolved. I have a fully updated system and installed xfce again few days ago. And it works miraculously..

Installed versions:
1. xfce4-mixer 4.10.0
2. Advanced Linux Sound Architecture Driver Version k3.9.3-1-ARCH

ravicious wrote:

Oh, I actually fixed this myself yesterday. I installed pulseaudio, pulseaudio-alsa and xfce4-volumed-pulse (from AUR) and then removed volume shortcuts from xfce4-keyboard-settings. In xfce4-mixer, you just have to choose a proper playback as a sound card.

Wow, actually it now works for me, too! Amazing!

Offline

Board footer

Powered by FluxBB