You are not logged in.

#1 2013-03-07 17:39:09

Registered: 2011-08-19
Posts: 24

[SOLVED]nvidia-ck 313.26

While I upgrade nvidia-ck to 313.26, i can't play video with output driver - vdpau, vainfo messages:

libva info: VA-API version 0.33.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/
libva info: Found init function __vaDriverInit_0_33
Failed to open VDPAU backend cannot open shared object file: No such file or directory
Floating point exception (core dumped)

#ldd /usr/lib/dri/ (0x00007fc929472000) => /usr/lib/ (0x00007fc928f1a000) => /usr/lib/ (0x00007fc928d16000) => /usr/lib/ (0x00007fc9289dd000) => /usr/lib/ (0x00007fc9287d4000) => /usr/lib/ (0x00007fc9284d6000) => /usr/lib/ (0x00007fc9282ba000) => /usr/lib/ (0x00007fc9280b7000) => /usr/lib/ (0x00007fc927d0a000) => /usr/lib/ (0x00007fc927b07000) => /usr/lib/ (0x00007fc925603000) => /usr/lib/ (0x00007fc9253f0000)
    /usr/lib64/ (0x00007fc929474000) => /usr/lib/ (0x00007fc9251d1000) => /usr/lib/ (0x00007fc924fcc000) => /usr/lib/ (0x00007fc924dc6000)

#ldd /usr/lib/vdpau/ (0x00007fff629fa000) => /usr/lib/ (0x00007f9a9ce48000) => /usr/lib/ (0x00007f9a9cb0f000) => /usr/lib/ (0x00007f9a9c907000) => /usr/lib/ (0x00007f9a9c608000) => /usr/lib/ (0x00007f9a9c25b000) => /usr/lib/ (0x00007f9a9c057000) => /usr/lib/ (0x00007f9a9be37000) => /usr/lib/ (0x00007f9a9bc1b000)
    /usr/lib64/ (0x00007f9a9d435000) => /usr/lib/ (0x00007f9a9ba17000) => /usr/lib/ (0x00007f9a9b810000)

Last edited by jim1960 (2013-03-08 10:32:27)

Sorry for my poor english.


#2 2013-03-07 19:42:10

Registered: 2007-04-03
Posts: 3,456

Re: [SOLVED]nvidia-ck 313.26

My layout is slightly different (not Arch), but vdpau works in mplayer2:

$ ll /usr/lib/vdpau/
lrwxrwxrwx 1 root root      25 Mar  7 02:35 ->
-rwxr-xr-x 1 root root 1868664 Mar  7 02:35

Nvidia's README has this to say:

   o Three VDPAU (Video Decode and Presentation API for Unix-like systems)
     libraries: The top-level wrapper (/usr/X11R6/lib/, a
     debug trace library (/usr/X11R6/lib/, and the
     NVIDIA implementation (/usr/X11R6/lib/ See
     Appendix G for details.

Which is old-fashioned, but doesn't mention having a plain .so file without the version number on the end of the filename.

Last edited by brebs (2013-03-07 19:42:33)


#3 2013-03-07 19:55:19

From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,677

Re: [SOLVED]nvidia-ck 313.26

@jim1960 - Can you verify your problem exists in the nvidia package that works with the ARCH kernel?  If so, I would suggest that you open a flyspray if you can verify that the problem is not related to the ck package.  I'm guess it's in upstream but do make sure.

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs


#4 2013-03-08 10:31:40

Registered: 2011-08-19
Posts: 24

Re: [SOLVED]nvidia-ck 313.26

I install a new Arch to another partition and it work just fine with nvidia-ck-313.26, so the old Arch had problems which i don't know why.

Sorry for my poor english.


Board footer

Powered by FluxBB