You are not logged in.

#1 2013-03-11 16:23:50

Registered: 2012-12-03
Posts: 26

[Solved]Help fix failed upgrade to systemd

Hello, I just tried to upgrade my server from the rc.d system to systemd, but I failed somewhere in the progress.
So now the server won't start properly.

- When the server boots up I get these errors:

Starting D-Bus System Message Bus...
[FAILED] Failed to start D-Bus System Message Bus.
See 'systemctl status dbus.service' for details.
Starting D-Bus System Message Bus.
[  OK  ] Started D-Bus system Message Bus.
Starting D-Bus System Message Bus.
[  OK  ] Started D-Bus system Message Bus.
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.
[   OK  ] Reached target Multi-User.
[   OK  ] Reached target Graphical Interface.

- Nginx are running, and webpages on the server can be accessed.
- I get up the login window(terminal style), but when I log in nothing happens for a short while before it returns to the login window.

What I did:
- 'pacman -Syu'
- 'pacman -S systemd'
-  Added this in after 'Append' in my syslinux config:


- rebooted the system
- All of these happened over ssh

What I've tried:
- changing init= to /bin/bash in syslinux on boot. I got into a terminal but my keyboard don't work
- Sadly the server can't boot with USB, nor does it have a cd-rom. So I tried PXE, following this guide:   But I can't get it to work, I get this error on the server(which is the PXE client/node):

PXE-E76: Bad or missing multicast discovery address

What I haven't tried yet:
- Put the servers harddrive into my pc to fix it here.

So the questions are:
1. How do I get PXE to work?
2. What should I do when I manage to boot up the server with a live arch image?

Thank you for all your help! I'll be on #archlinux@freenode

Last edited by totokaka (2013-03-11 18:20:57)


#2 2013-03-11 18:20:46

Registered: 2012-12-03
Posts: 26

Re: [Solved]Help fix failed upgrade to systemd

I solved it after much help from cinelli, thank you so much!
Here is the solution that worked for me:
1. In the bootloader remove the init= kernel param and add this:
2. Merge all pacnew files
3. Make sure everything in mkinitcpio is up to date(mkinitcpio -L)
4. reboot


Board footer

Powered by FluxBB