You are not logged in.

#1 2013-03-12 04:52:44

mimosinnet
Member
Registered: 2012-09-22
Posts: 7

conky not starting as root

I am using my gentoo desktop configuration in archlinux (xdm + FVWM), setting the root window at the login prompt (conky, root-tail, fvwm-root). To be able to do this, I need conky to be executed as root. I get this error message:

# conky
No protocol specified
Conky: can't open display: :0
***** Imlib2 Developer Warning ***** :
	This program is calling the Imlib call:

	imlib_context_free();

	With the parameter:

	context

	being NULL. Please fix your program.

This same error message has  been reported by other users (see this post). I would very much appreciate any hints.

Thanks!

Offline

#2 2013-03-15 06:14:11

mimosinnet
Member
Registered: 2012-09-22
Posts: 7

Re: conky not starting as root

I have not been able to solve this issue. I have included conky in .xsession, starting it as my regular user.

Thanks your attention.

Cheers!

Offline

#3 2013-03-17 03:28:33

ardagnir
Member
From: USA
Registered: 2012-12-04
Posts: 11
Website

Re: conky not starting as root

Try:
conky --display=:1
(or whatever display you're using)
I don't think conky can figure it out by default if you're running it as a foreign user.

Last edited by ardagnir (2013-03-17 03:30:23)

Offline

#4 2013-03-19 01:16:27

mimosinnet
Member
Registered: 2012-09-22
Posts: 7

Re: conky not starting as root

ardagnir wrote:

Try:
conky --display=:1

Thanks very much for the hint. As a regular user, I can run:

conky --display=:0  
Conky: forked to background, pid is 3631

As root, I get the error, and the display is not recognised:

# conky --display=:0 
No protocol specified
Conky: can't open display: :0
***** Imlib2 Developer Warning ***** :
	This program is calling the Imlib call:

	imlib_context_free();

	With the parameter:

	context

	being NULL. Please fix your program.

I have tried different display values.

Let me know if you have any other suggestions.

Cheers!

Offline

#5 2013-03-19 03:07:16

ardagnir
Member
From: USA
Registered: 2012-12-04
Posts: 11
Website

Re: conky not starting as root

Offline

#6 2013-03-24 00:08:40

mimosinnet
Member
Registered: 2012-09-22
Posts: 7

Re: conky not starting as root

ardagnir wrote:

Thanks for the reply and the reference. I have checked the link and, as I undersand it, it gives information on how to run root applications when logged as a non-root user. In my case, I want to run applications as root before loggin into a particular user, at the login screen. This is, for example, what I have in my /etc/X11/xdm/Xsetup:

fvwm &

fvwm-root -r /home/mimosinnet/.fvwm/wallpapers/wallpaper.png &
# /usr/bin/root-tail -g 1276x300-0+0 /var/log/problem.log,palegreen &
# /ushr/bin/root-tail -g 1276x300-0+310 /home/mimosinnet/.xsession-errors,Turquoise & 

urxvtd -q -f -o 
urxvtc -font xft:Liberation\ Mono:pixelsize=14:antialias=false -sh 80 -tr -bg black -fg palegreen -geometry 129x22+69+0   +sb -name rxvt_root -e journalctl -f &
urxvtc -font xft:Liberation\ Mono:pixelsize=14:antialias=false -sh 80 -tr -bg black -fg palegreen -geometry 129x22+69+390 +sb -name rxvt_root -e tail -f /var/log/Xorg.0.log &

# conky -c /home/mimosinnet/.conkyrc &

# Keep the number of times the filesystem has been mounted in fsckcount.txt
fsckcount=`/sbin/tune2fs -l /dev/sda3 |  awk '/^Mount count/ { printf $3 }'`
echo $fsckcount > /etc/X11/xdm/fsckcount.txt

if [ $fsckcount -ge 35 ]
then
	touch /etc/X11/xdm/fsckcount_high.txt
else
	if [ -e /etc/X11/xdm/fsckcount_high.txt ]
	then
		rm /etc/X11/xdm/fsckcount_high.txt
	fi
fi

	
/sbin/tune2fs -l /dev/sda3 |  awk '/^Mount count/ { printf $3 }' > /etc/X11/xdm/fsckcount.txt 

I have successfully added gvim, being able to run it as root. My issue is with the conky command, that does not seem to work.

Thanks!

Offline

Board footer

Powered by FluxBB