You are not logged in.

#1 2013-03-12 21:45:52

Registered: 2010-09-29
Posts: 15

Ethernet freezing on acer aspire v3-771g


especially when doing big data transfers (rsync, ssh, ftp...) but also when simply having several irc, jabber, http connections open, my ethernet freezes. Interface lights are blinking (slowly, from time to time), but from the laptop I can't ping anything, and from a desktop machine, I can't access the laptop (ping, ssh etc).

Only solution is to physically unplug and replug the LAN cable

Bad thing is that syslog shows absolutely no entry when this happens, so I'm still guessing what might happen.

Not even sure if this is really related to the laptop. GBit ethernet switch might also be in cause, though I already switched the port I'm connected to, and from the desktop I can still access the internet when the laptop's connection is frozen -> at least desktop's port on the switch is working fine.

lspci reports
0e:00.0 Ethernet controller: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet (rev c0)

lspci -n
0e:00.0 0200: 1969:1083 (rev c0)

While googling, I found the trick to echo "1969 1083" > /sys/bus/pci/drivers/atl1c/new_id
but this did not help

Any advice from you guys on how to proceed debugging this ?

System is arch linux of course, up-to-date as of today (kernel, NetworkManager etc...)

Many thanks


#2 2013-03-13 01:04:56

From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Ethernet freezing on acer aspire v3-771g

try switching off the wireless and see if the LAN stays on without a freeze. Post your dmesg output too.

Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King


#3 2013-11-02 22:40:33

Registered: 2010-09-29
Posts: 15

Re: Ethernet freezing on acer aspire v3-771g

Just for the archives :
* switched WLess off, didn't change anything, problem still arising
* dmesg output after issue is same as before issue arises, /var/log/messages also shows no new entries
* problem disappeared alredy some months ago - must have been kernel related (or maybe networkmanager ?)

=> problem solved


Board footer

Powered by FluxBB