You are not logged in.

#1 2013-03-13 10:03:34

Registered: 2013-03-13
Posts: 1

USB root not found - Kernel 3.7.6-1 working, 3.7.9-1 and 3.7.10-1 NOT


I have archlinux installed on a USB flash drive.
I'm using syslinux with a single ext4 filesystem.

HOOKS in /etc/mkinitcpio.conf are:

HOOKS="base udev autodetect modconf block filesystems keyboard fsck consolefont keymap"

The entry in /boot/syslinux/syslinux.cfg  are:

LABEL arch
        MENU LABEL Arch Linux
        LINUX ../vmlinuz-linux
        APPEND root=LABEL=arch ro
        # APPEND root=/dev/disk/by-uuid/de0ebab9-f072-46d9-8c96-38f582dcfd0f
        # APPEND root=/dev/sdb1
        INITRD ../initramfs-linux.img

From kernel version 3.7.9+ the system won't boot any more. The first error message is:

usb 1-7: device not accepting address 2, error -110

Downgrading to 3.7.6-1 solved the problem. But this can't be a solution.
I've tried different boot device naming in syslinux.cfg, but this dosn't help, see comments above.
Just as silly things like rootdelay=30 did not work.

Thanks Kai.

Last edited by kthoene (2013-03-13 10:06:27)


Board footer

Powered by FluxBB