You are not logged in.

#1 2013-03-13 14:41:39

Vatri91
Member
Registered: 2011-11-04
Posts: 15

How to enable hibernation on Arch?

Hello. I have one problem. How to enable hibernation on Arch? I have 2GB swap and efi board. In arch wiki i can find ths
kernel /boot/vmlinuz-linux ... resume=/dev/sdaX
but i dont have kernel line in my grub.cfg

My grub.cfg
http://wklej.se/b8f9

Last edited by Vatri91 (2013-03-13 14:42:49)

Offline

#2 2013-03-13 15:47:06

10PinkPanther
Member
From: Croatia
Registered: 2012-11-10
Posts: 333

Re: How to enable hibernation on Arch?

/boot/grub/grub.cfg or /etc/grub/default.

Offline

#3 2013-03-13 15:52:13

Vatri91
Member
Registered: 2011-11-04
Posts: 15

Re: How to enable hibernation on Arch?

/boot/grub/grub.cfg

Offline

#4 2013-03-13 17:01:31

progandy
Member
Registered: 2012-05-17
Posts: 2,146

Re: How to enable hibernation on Arch?

The line beginning with "linux   /boot/vmlinuz-linux " in your grub.cfg is your kernel line.
If you want to automatically add the parameter when using grub-mkconfig, you'll have to add it in /etc/default/grub, e.g.:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=/dev/disk/by-uuid/xXxXxXxX-xXxX-xXxX-xXxX-xXxXxXxX"

Offline

#5 2013-03-13 19:40:27

Vatri91
Member
Registered: 2011-11-04
Posts: 15

Re: How to enable hibernation on Arch?

ok, it's work if i use comend line
$ systemctl suspend
$ systemctl hibernate
but i dont have hibernate option in gnome-shell aplet, and Suspend don't work. It's only lock sreen. I must use teminal,

Offline

Board footer

Powered by FluxBB