You are not logged in.

#1 2013-03-13 16:19:31

3])
Member
From: Netherlands
Registered: 2009-10-12
Posts: 215

[SOLVED]catalyst-utils and mesa-libgl in conflict-catalyst not found

I recently switched my distribution from an ATI laptop to an NVIDIA laptop (aka-I just put my old hard drive into the newer laptop).
So far with updates I haven't been getting any errors.

So I tried to find a solution to this to no avail. As I can't find the package to delete, thus can't solve the issue.

root /home/foo # pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: catalyst-utils and mesa-libgl are in conflict. Remove mesa-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: catalyst-utils and mesa-libgl are in conflict
root /home/foo # pacman -R catalyst-utils
error: target not found: catalyst-utils
root /home/foo # pacman -Ss catalyst
community/catalyst-dkms 13.1-2
    AMD proprietary gpu kernel driver
community/catalyst-utils 13.1-3
    AMD Catalyst drivers utilities and libraries.
community/opencl-catalyst 13.1-3
    OpenCL implemention from AMD
multilib/lib32-catalyst-utils 13.1-2
    AMD Catalyst drivers libraries (32 bits)
root /home/foo 

Any idea on how to remove an invisible package that is in conflict with another?

Last edited by 3]) (2013-03-13 17:19:53)


“There are two ways of constructing a software design. One way is to make it so simple that there are obviously no deficiencies. And the other way is to make it so complicated that there are no obvious deficiencies.”-- C.A.R. Hoare

Offline

#2 2013-03-13 17:09:50

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,132

Re: [SOLVED]catalyst-utils and mesa-libgl in conflict-catalyst not found

Do you have xvba-video-open installed? Or anything from the AUR that might depend on catalyst-utils?

Last edited by Scimmia (2013-03-13 17:11:12)

Online

#3 2013-03-13 17:18:49

3])
Member
From: Netherlands
Registered: 2009-10-12
Posts: 215

Re: [SOLVED]catalyst-utils and mesa-libgl in conflict-catalyst not found

Scimmia wrote:

Do you have xvba-video-open installed? Or anything from the AUR that might depend on catalyst-utils?

You truly are a problem solving god. That fixed it!
Thanks a bunch!
Will label this thread solved.

Last edited by 3]) (2013-03-13 17:20:25)


“There are two ways of constructing a software design. One way is to make it so simple that there are obviously no deficiencies. And the other way is to make it so complicated that there are no obvious deficiencies.”-- C.A.R. Hoare

Offline

Board footer

Powered by FluxBB