You are not logged in.

#1 2013-03-14 08:52:16

Nabobalis
Member
Registered: 2009-07-25
Posts: 7

[Solved] Haskell/Xmonad Upgrade Issues

It seems that the testing version of haskell-x11-xft requires the non-testing version of haskell-x11.

Further, installing xmonad-contrib from testing seems to want to install the non-testing version of xmonad and haskell-x11-xft.

It seems to be one very large circle which I can't resolve.

So a pacman -Syu gives me:

warning: cannot resolve "haskell-x11=1.6.0.2-2", a dependency of "haskell-x11-xft"
warning: cannot resolve "haskell-x11=1.6.0.2-2", a dependency of "xmonad"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      haskell-x11-xft  xmonad

Do you want to skip the above packages for this upgrade? [y/N] u
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-x11-xft: requires haskell-x11=1.6.0.2-2
:: xmonad: requires haskell-x11=1.6.0.2-2


Not sure if I've done something wrong or I'm being stupid.

Last edited by Nabobalis (2013-03-14 10:22:56)

Offline

#2 2013-03-14 10:15:03

opt1mus
Member
From: UK
Registered: 2011-12-31
Posts: 197
Website

Re: [Solved] Haskell/Xmonad Upgrade Issues

You can upgrade haskell-x11-xft and xmonad with;

# pacman -Syud --ignore haskell-x11

I too encountered what seemed to be a dependency loop, so used -d --nodeps option to skip the version check. Checking the Package repo shows that haskell-x11 is also flagged out of date, until things have been updated in the repo's you will see an error during update unless you

--ignore haskell-x11

Offline

Board footer

Powered by FluxBB