You are not logged in.

#1 2013-03-14 19:20:17

Registered: 2013-01-29
Posts: 27

[closed] kernel 3.7.10-1ARCH and intel video driver

Hi, since I've upgraded the kernel to 3.7.10-1-ARCH I am unable to get my video working or even rebooting from the black screen with ctrl-alt-del.
Since this event I have been surfing around to see if I can find something to workaround or even solve this problem.

1. I thought it could be and broken image. So I tried to build a new one.including with loading especifically the i915 modules. Did not work.

2. than I rebuild grub menu, on the thoughts that during any of the upgrades something could have gone amok. No result as well

3. Set manually, editing the grub option, and added either nomodeset (or i915.modeset=o);  video=SVIDEO-1:d or even both. Here also no result, although once I successfully made all booting steps be listed during boot time (probably by deleting the "quiet" parameter) and there the boot process stopped exactly during the video loading (don't remember exactly the words).

4. Also I checked two journalctl from booing processes and as far as I could understand the whole boot process went reasonably clean, at least until the point where it gives the booting time.Bellow you see an cut of the journalctl from one of those boot procedures and really marked red where lines 2 and3 and 8 and 9 below:

1   Mar 12 19:12:40 xxxx-archs systemd[1]: Reached target Sound Card.
     Mar 12 19:12:42 xxxx-archs kernel: BUG: unable to handle kernel NULL pointer dereference at           (null)
     Mar 12 19:12:42 xxxx-archs kernel: IP: [<ffffffffa049bc0c>] intel_enable_gtt+0xc/0x170 [intel_gtt]
     Mar 12 19:12:42 xxxx-archs kernel: PGD 231556067 PUD 232482067 PMD 0
5   Mar 12 19:12:42 xxxx-archs kernel: Oops: 0000 [#1] PREEMPT SMP
     Mar 12 19:12:42 xxxx-archs kernel: Modules linked in: snd_hda_codec_hdmi arc4 snd_hda_codec_conexant crc32c_intel ghash_clmulni_intel i915(O+) ath9k(O) ath
     Mar 12 19:12:42 xxxx-archs kernel: CPU 1
     Mar 12 19:12:42 xxxx-archs systemd-udevd[160]: worker [183] terminated by signal 9 (Killed)
     Mar 12 19:12:42 xxxx-archs systemd-udevd[160]: worker [183] failed while handling '/devices/pci0000:00/0000:00:02.0'
10 Mar 12 19:12:42 xxxx-archs kernel: Pid: 183, comm: systemd-udevd Tainted: G           O 3.7.10-1-ARCH #1 Dell Inc.          Inspiron 5420/0RHTCK
     Mar 12 19:12:42 xxxx-archs kernel: RIP: 0010:[<ffffffffa049bc0c>]  [<ffffffffa049bc0c>] intel_enable_gtt+0xc/0x170 [intel_gtt]

But I don't now if this has any meaning.

(I have the rest of the journalctl, it's just to long to post here.)

I see the same error messages in every boot procedure in the journal.
So I am really running out of available options and I really need my Arch working and I do not want to reinstall everything again or wait for an new kernel or video drive update.

I read that similar problems where solved in kernel 3.8, but I searched in the testing repositories (through yaourt and pacman) to see if I could install this testing kernel and chakc the situationg with it and I just found the headers.

Anyone with some other suggestion?

Last edited by camarao (2013-03-20 02:35:45)


#2 2013-03-14 20:42:46

Registered: 2012-06-22
Posts: 772

Re: [closed] kernel 3.7.10-1ARCH and intel video driver

Compile 3.8 or revert to some older 3.7 package (old packages may still exist in /var/cache/pacman/pkg). Or switch to linux-lts.

BTW, since i915 is probably a module, you can't pass options to it from kernel command line. Instead, you need to create file /etc/modprobe.d/something.conf containing

options i915 modeset=0


#3 2013-03-14 21:05:57

Registered: 2009-08-25
Posts: 3,575

Re: [closed] kernel 3.7.10-1ARCH and intel video driver

mich41 wrote:

BTW, since i915 is probably a module, you can't pass options to it from kernel command line.

Of course you can. camarao did it right, except the value to disable stuff is 0, not o - so i915.modeset=0. Note that the intel X driver won't work without kernel modesetting, so disabling it is only a temporary workaround to be able to use the machine at all.

@camarao: That log shows a driver crash. The easiest way to test a different kernel is to use linux-lts. Then there's the Arch Rollback Machine.


#4 2013-03-14 22:07:07

Registered: 2013-01-29
Posts: 27

Re: [closed] kernel 3.7.10-1ARCH and intel video driver

Hi folks,

thanks for your prompt answers, just to clear a couple of points

mich41 first;

Compiling I've never done it. I found, through package search in the arch site, compiled version of 3.8 (or at least it is an .xz archive) of both kernel and headers. but on the kernel page I think it is flagged. So I'm not quite sure if I should use it as it comes. I read somewhere that compiling a kernel should be more reliable than using an compiled version from development????. Well I'll search around on how can I do this.

About downgrading, I've done it from 3.7.10 to 3.7.9-2, but when I do this it leaves me, after booting, on an emergency mode shell and I do not know what to do from there because I could not identify the problem why is this happening.
I haven't downgraded to an lts kernel version, should it be done like "pacman (or yaourt) -S linux-lts" ?

About creating an file in modprobe.d, I saw this option as well, I haven't done this because I read that my option could be done for testing and if it works than I should do your suggestion, and Gusar confirmed this above.

Well now you Gusar:

Well I think the "0" and "o" was more a typo error but when I used it it was as you described. Any way it did not work anyway.

The strange think is that up to kernel 3.7.9-2 everything was working well, so I don't understand why this downgrading is not working. May be you guys have an hunch on that?

Since both of you suggested the downgrading to an lts kernel, I think this will be my next move, at least to try and bring back my system. I don't know what you guy think about it but I was thinking now to keep kernel updating as it comes as my primary boot option and permanent lts booting as an safe haven in case something goes wrong and avoid all this debugging mess in the middle of my dayly work, since it is not IT work.
Is there somewhere a guide in how to do it in Arch?

Well guys, once more thanks. I'l let you know if lts downgrade went well.

Last edited by camarao (2013-03-14 22:17:09)


#5 2013-03-15 08:09:31

David Batson
Registered: 2011-10-13
Posts: 640

Re: [closed] kernel 3.7.10-1ARCH and intel video driver

You can get kernel 3.8.x from the testing repository.  Enable all the testing repositories, run pacman -Syu to update the repo info, but do not install anything, then run pacman -S [kernel] to install the latest kernel {replace [kernel] with the actual kernel package shown after you run pacman -Syu}.  After that, you should probably disable the testing repositories.


#6 2013-03-15 13:35:42

Registered: 2013-01-29
Posts: 27

Re: [closed] kernel 3.7.10-1ARCH and intel video driver


Many thanks. I'll give a go on that option as well.

Hi folks,

just an last update. I tryed to install the 3.8 kernel but it could not be installed due to an virtualbox-host kernel dependency. So I decided to install the lts kernel. Everythink went smooth, but booting procedure ended up at the same place, no screen.
I give up, I can not wait anymore, I will reinstall arch and hope it solves the problem.

Sorry for the delay in making this last update:

Well tryed both suggestions, from above, but neither worked it apparently does not have to do with a kernel problem. So my conclusion is that there must be some file which got corrupted during my major crash a couple of days ago, which affects the loading of software necessary for managing the display. This file apparently is not replaced during an reinstallation and so do not chage status. It didn't matter what kernel version I tryed it always stopped loading in the same place.

After redoing an almost clean install (I did not deleted the home directory, which is in an separated partition), and reinstalled most of the software I had previously, the screen isn't back anymore and almost everything is now working. (Had a hardtime with mysql and amarok is still not working, time is not keeping sinchronized).

Last edited by camarao (2013-03-20 02:36:55)


Board footer

Powered by FluxBB