You are not logged in.

#1 2013-03-19 00:51:34

jc61990
Member
From: New York
Registered: 2012-07-14
Posts: 29
Website

(solved) Can not upgrade to kernel 3.8.2, bumblebee conflict

Hello, i have been trying to update my laptop today to the latest kernel as well as a few other updates. I seem to be getting an error every time i try to update. It looks like Bumblebee is the problem.  Here is my terminal output from the several commands i have tried to run.

jc61990@M14xR2 ~ % sudo pacman -Syyu
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-bumblebee: requires linux<3.8

jc61990@M14xR2 ~ % sudo pacman -S linux
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-bumblebee: requires linux<3.8
:: virtualbox-host-modules: requires linux<3.8
jc61990@M14xR2 ~ % sudo pacman -Syu --ignore linux
:: Starting full system upgrade...
warning: linux: ignoring package upgrade (3.7.10-1 => 3.8.3-2)
resolving dependencies...
warning: ignoring package linux-3.8.3-2
warning: cannot resolve "linux>=3.8", a dependency of "virtualbox-host-modules"
:: The following package cannot be upgraded due to unresolvable dependencies:
      virtualbox-host-modules
jc61990@M14xR2 ~ % packer -Syu
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-bumblebee: requires linux<3.8
:: Starting full aur upgrade...

Aur Targets    (1): nvidia-bumblebee

Proceed with installation? [Y/n] 

Edit nvidia-bumblebee PKGBUILD with $EDITOR? [Y/n] n
Edit nvidia-bumblebee.install with $EDITOR? [Y/n] n
==> Making package: nvidia-bumblebee 313.26-2 (Mon Mar 18 12:01:43 EDT 2013)
==> Checking runtime dependencies...
==> Missing Dependencies:
  -> linux>=3.8
==> Checking buildtime dependencies...
==> Missing Dependencies:
  -> linux-headers>=3.8
==> ERROR: Could not resolve all dependencies.
The build failed.

has anyone else had this problem and found a resolution yet?

Last edited by jc61990 (2013-03-19 14:57:29)


i put arch on everything.
Devices on arch: Desktop (self built), Dell XT Laptop, RaspberryPi, HTPC, PogoPlug, and my Web Server

Offline

#2 2013-03-19 13:04:53

samos123
Member
Registered: 2012-04-25
Posts: 8

Re: (solved) Can not upgrade to kernel 3.8.2, bumblebee conflict

I'm not an advanced Arch user yet, so would be great if somebody could confirm it's ok to do this, but I solved it in the following way:

First install the linux package without checking dependencies (Maybe not so safe to do):
yaourt -S linux --nodeps

Then update all packages including all AUR packages with the a options:
yaourt -Syua

You can swap yaourt with pacman and it should also work except the AUR package update.

Offline

#3 2013-03-19 14:57:02

jc61990
Member
From: New York
Registered: 2012-07-14
Posts: 29
Website

Re: (solved) Can not upgrade to kernel 3.8.2, bumblebee conflict

i actually solved this too,  but a different way.  I unloaded and stopped bumblebeed

# systemctl stop bumblebeed.service

# systemctl disable bumblebeed.service

then i removed the package  # pacman -R nvidia-bumblebee

did a full upgrade  # pacman -Syyu

all packages upgraded successfully.  i then rebooted my machine, and proceeded to re-install nvidia-bumblebee from the aur, then re enabled and started the service.  All seems to be working perfect without error.


i put arch on everything.
Devices on arch: Desktop (self built), Dell XT Laptop, RaspberryPi, HTPC, PogoPlug, and my Web Server

Offline

Board footer

Powered by FluxBB