You are not logged in.

#1 2013-03-21 09:26:44

Registered: 2013-03-20
Posts: 48

[SOLVED] xrdb not reading .Xresources at boot

spent a few hours trying to figure this out yesterday to no avail but still learned alot.

so in my home folder I have .Xresources file:

! terminal colors ------------------------------------------------------------

! tangoesque scheme
*background: #111111
*foreground: #babdb6
! Black (not tango) + DarkGrey
*color0:  #000000
*color8:  #555753
! DarkRed + Red
*color1:  #ff6565
*color9:  #ff8d8d
! DarkGreen + Green
*color2:  #93d44f
*color10: #c8e7a8
! DarkYellow + Yellow
*color3:  #eab93d
*color11: #ffc123
! DarkBlue + Blue
*color4:  #204a87
*color12: #3465a4
! DarkMagenta + Magenta
*color5:  #ce5c00
*color13: #f57900
!DarkCyan + Cyan (both not tango)
*color6:  #89b6e2
*color14: #46a4ff
! LightGrey + White
*color7:  #cccccc
*color15: #ffffff

I also made a .xinitrc file in my home directory:

xrdb -merge ~/.Xresources

my problem is after boot I still have to manually use xrdb ~/.Xresources to have my .Xresources file to run.

I know there is a lot on Google about this but I read through a large amount trying to get it to work. Apparently there are various problems and they depended up how your Desktop Manager starts the X environment.

I am using LXDE (desktop manager) and openbox (windowd manager). At login I am greated with a login splash screen that takes me into my LXDE environment... I just can't figure out how to force startx to trigger the reading of my .Xresources file.

I made sure all files were not made as root and they have the proper permissions including being ecexcutable.

However my boot is configured,  the .Xresources is simply not getting run through xrdb as doing it manually after boot workds perfectly...

The arch wiki reads: "are using  a Display Manager t log into X. Most DM will autoload the ~/.Xresources file on login"

So is this more a lxde question?

Another blog I read said that LXDE may not read .Xresources automatically thus the need for the .xinitrc file.... I followed those instructions as well to no avail:

create .xinitrc
chmod +x .xinitrc
add xrdb -load ~/.Xresources &     
to the .xinitrc file

... did not work for my setup

at this point I am at a loss.

Any help would be greatly appreciated.

Last edited by soulrainX (2013-03-21 13:05:53)

n00b learning linux
arch + lxde


#2 2013-03-21 11:30:13

Registered: 2011-01-17
Posts: 1,233

Re: [SOLVED] xrdb not reading .Xresources at boot


Have you tried adding the command to Openbox' file? I don't know exactly how it's called, but it's usually placed in $XDG_CONFIG_HOME/openbox/ and if everything works correctly, it is executed upon starting Openbox.

... and having read the comment below, yes, please use code tags. It confused me at first whether you were literally typing 'add' and 'create' as commands in your shell or not.

Last edited by ayekat (2013-03-21 11:56:01)


#3 2013-03-21 11:49:21

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,837

Re: [SOLVED] xrdb not reading .Xresources at boot

Please use [code ][/ code] tags to show your config files, rather than boxing them in superfluous whitespace.

I don't think LXDM reads .xinitrc, try putting the xrdb command into the autostart file instead: … t_Programs

Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#4 2013-03-21 12:00:10

Registered: 2013-03-20
Posts: 48

Re: [SOLVED] xrdb not reading .Xresources at boot

Thanks guys! I definitely will try the suggestions and thanks for the code tag suggestion... It does make the post much easier to understand. Will test out suggestions and get back.

Last edited by soulrainX (2013-03-21 12:01:51)

n00b learning linux
arch + lxde


#5 2013-03-21 13:06:36

Registered: 2013-03-20
Posts: 48

Re: [SOLVED] xrdb not reading .Xresources at boot

Works as advertised. Thank you very much ayekat and WorMzy!

n00b learning linux
arch + lxde


Board footer

Powered by FluxBB