You are not logged in.

#1 2013-03-23 18:28:38

theking2
Member
From: Romanshorn Switzerland
Registered: 2009-03-04
Posts: 330

[SOLVED] systemd devmon script

Hi!

I did see the other thread but that didn't went very well.

I'm trying to get my NAS to auto mount usb disks. I attempt to use devmon. devmon from the prompt works fine.
With the following script however

[Unit]
Description=Devmon Service
[Service]
Type=simple
ExecStart=/dev/bin/devmon
[Install]
WantedBy=multi-user.target

I get this result:

devmon.service - Devmon Service
          Loaded: loaded (/etc/systemd/system/devmon.service; disabled)
          Active: failed (Result: exit-code) since Sat 2013-03-23 19:27:38 CET; 4s ago
         Process: 27691 ExecStart=/dev/bin/devmon (code=exited, status=203/EXEC)

Mar 23 19:27:38 janus systemd[1]: Starting Devmon Service...
Mar 23 19:27:38 janus systemd[1]: Started Devmon Service.
Mar 23 19:27:38 janus systemd[1]: devmon.service: main process exited, code=exited, status=203/EXEC
Mar 23 19:27:38 janus systemd[1]: Unit devmon.service entered failed state

So I guess I miss something in the script.
What would be the proper way to start devmon ?

Last edited by theking2 (2013-10-14 16:53:44)


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer(-git), Samba, MiniDLNA, TOR

Offline

#2 2013-03-23 18:58:27

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] systemd devmon script

ExecStart=/dev/bin/devmon

I'm pretty sure that's not where the binary is, you probably mean /usr/bin/devmon.

Offline

#3 2013-03-23 19:19:34

theking2
Member
From: Romanshorn Switzerland
Registered: 2009-03-04
Posts: 330

Re: [SOLVED] systemd devmon script

hmm that is odd.

I'm sure I typed /usr :-)

Thanks for the hint!

[Unit]
Description=Devmon Service
[Service]
Type=simple
ExecStart=/usr/bin/devmon
[Install]
WantedBy=multi-user.target

it is now


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer(-git), Samba, MiniDLNA, TOR

Offline

Board footer

Powered by FluxBB