You are not logged in.

#1 2013-03-24 15:15:29

ffuentes
Member
From: Santiago, Chile
Registered: 2009-08-23
Posts: 34
Website

Can't install virtualbox: Nvidia error (solved)

Hi everyone:

When I try to install virtualbox I get an error from pacman which states:

:: nvidia needs linux>3.7

However, when I perform uname -a I get this:

uname -a
Linux localhost 3.6.11-1-ARCH #1 SMP PREEMPT Tue Dec 18 12:58:46 CET 2012 i686 GNU/Linux

What should I do? Thank you in advance.

Last edited by ffuentes (2013-03-24 17:58:27)

Offline

#2 2013-03-24 15:19:48

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,992
Website

Re: Can't install virtualbox: Nvidia error (solved)

Don't do partial upgrades, they're not supported.

Solution: pacman -Syu.

To be able to load modules (like vboxdrv) after that, reboot.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-03-24 15:43:16

ffuentes
Member
From: Santiago, Chile
Registered: 2009-08-23
Posts: 34
Website

Re: Can't install virtualbox: Nvidia error (solved)

Thank you. I'll try and post the results.

EDIT: It worked. The system was upgraded and after that the virtualbox installation worked flawlessly. I rebooted the system and then loaded the vboxdrv module.

Last edited by ffuentes (2013-03-24 17:59:32)

Offline

Board footer

Powered by FluxBB