You are not logged in.

#1 2013-03-24 17:20:20

meridius
Member
Registered: 2013-03-24
Posts: 5

HOW TO SOLVE: "Two or more conflicting lines configured, ignoring"?

I have one problem with suspending my desktop. I have nvidia GeForce 8200 installed and to get system suspend without immediately waking up I have to disable USB0 and US15 in /proc/acpi/wakeup file. I can do this by simply echo those to the file, so I created temporary file in /etc/tmpfiles.d/ as advised on Arch Wiki. The file contains the following:

w /proc/acpi/wakeup - - - - USB0
w /proc/acpi/wakeup - - - - US15

The problem is that only the first line gets done and the second is ignored as systemd-tmpfiles is telling me.

Two or more conflicting lines for /proc/acpi/wakeup configured, ignoring.

What do I have to do to get both lines done?

Offline

#2 2013-03-24 18:41:05

Raynman
Member
Registered: 2011-10-22
Posts: 1,111

Re: HOW TO SOLVE: "Two or more conflicting lines configured, ignoring"?

man tmpfiles.d wrote:

The argument parameter will be written without a trailing newline. C-style backslash escapes are interpreted.

Try a single line with argument "USB0\nUS15" (probably without quotes).

Last edited by Raynman (2013-03-24 18:41:34)

Offline

#3 2013-03-24 18:51:55

meridius
Member
Registered: 2013-03-24
Posts: 5

Re: HOW TO SOLVE: "Two or more conflicting lines configured, ignoring"?

Thanks for your reply. Unfortunately, it doesn't work. Both ways (with/out) quotes is complaining about short write:

Failed to write file /proc/acpi/wakeup: Short write

Which could mean that the second argument is standing alone on new line.

Offline

#4 2013-03-24 19:53:53

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: HOW TO SOLVE: "Two or more conflicting lines configured, ignoring"?

Maybe it might be better to simply create a service that runs a script in this situation.

Offline

Board footer

Powered by FluxBB