You are not logged in.

#1 2013-03-27 10:31:41

SgrA
Member
Registered: 2011-06-08
Posts: 36

[SOLVED] /dev/root is not a valid block device

After trying to boot my system after a few days of it remaining off, it fails to boot with:

Booting the kernel.
ERROR: resume: hibernation device '/dev/sda9' not found
mount: /dev/root is not a valid block device
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off.
[rootfs /]#

The sda9 error has been around for quite some time, even back when it was working and I've been ignoring it all these days.

Last edited by SgrA (2013-03-28 18:00:35)

Offline

#2 2013-03-27 10:37:19

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,154

Re: [SOLVED] /dev/root is not a valid block device

Should /dev/root be /dev/mapper/root, or /dev/disk/by-label/root? Have you been playing with your kernel command line in your bootloader?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#3 2013-03-27 10:41:37

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

I haven't done anything in my bootloader yet.

Offline

#4 2013-03-27 10:49:55

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,154

Re: [SOLVED] /dev/root is not a valid block device

Well, could you post it's config?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#5 2013-03-27 11:00:46

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

Here's /etc/lilo.conf

#
# /etc/lilo.conf
#

boot=/dev/sda
# This line often fixes L40 errors on bootup
# disk=/dev/hda bios=0x80

default=arch
timeout=100
lba32
prompt

image=/boot/vmlinuz-linux
	label=arch
	root=/dev/sda4
	initrd=/boot/initramfs-linux.img
	append="init=/bin/systemd noipv6 ro logo.nologo quiet nomodeset resume=/dev/sda9"
	read-only

image=/boot/vmlinuz-linux
	label=arch-fallback
	root=/dev/sda4
	initrd=/boot/initramfs-linux-fallback.img
        append="init=/bin/systemd"
	read-only

image=/mnt/Algenib/boot/vmlinuz-3.5.0-17-generic
	initrd=/mnt/Algenib/boot/initrd.img-3.5.0-17-generic
        append="root=/dev/sda3"
        root=/dev/sda3
	label=algenib
	read-only

image=/mnt/Gacrux/boot/vmlinuz-linux
        label=arch-backup
        root=/dev/sda7
        initrd=/mnt/Gacrux/boot/initramfs-linux.img
        append="noipv6 ro logo.nologo quiet nomodeset"
        read-only

Offline

#6 2013-03-27 13:05:39

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,154

Re: [SOLVED] /dev/root is not a valid block device

I'm not familiar with lilo, but if that's what it's using then it looks okay to me. The part that causes the "resume: hibernation device" error is pretty obvious in the append line of the "arch" label, but I assume that the /dev/root error is unrelated. One thing the wiki article says though, is that lilo has to be re-run after every kernel update; is there any chance you forgot to do so last time you updated the kernel?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#7 2013-03-27 13:30:11

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

Nope, I make it a point to run lilo every time.

Offline

#8 2013-03-27 13:34:59

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,154

Re: [SOLVED] /dev/root is not a valid block device

Have you tried the fallback option?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#9 2013-03-27 13:37:28

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

Yep, doesn't help either.

Offline

#10 2013-03-27 19:02:36

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: [SOLVED] /dev/root is not a valid block device

Can you post your fstab? I just want to check something!

And can you post "lsblk" output too?

Last edited by s1ln7m4s7r (2013-03-27 19:08:14)

Offline

#11 2013-03-28 05:37:22

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

Here's the fstab:

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>		<type>	<options>	<dump>	<pass>
/dev/sda1 	/boot 		ext2 	defaults 	0 	1
/dev/sda3	/mnt/Algenib 	ext4 	defaults	0 	1
/dev/sda4 	/ 		ext4	defaults 	0 	1
/dev/sda5	/mnt/Acrux	ext4	defaults 	0	1
/dev/sda6       /mnt/Mimosa	ext4	defaults 	0	1
/dev/sda7	/mnt/Gacrux 	ext4	defaults,noauto	0	1
/dev/sda9 	swap 		swap 	defaults 	0 	0

And here's lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
|-sda1   8:1    0   1.9G  0 part /boot
|-sda2   8:2    0     1K  0 part 
|-sda3   8:3    0    10G  0 part /mnt/Algenib
|-sda4   8:4    0  88.1G  0 part /
|-sda5   8:5    0   100G  0 part 
|-sda6   8:6    0   100G  0 part 
|-sda7   8:7    0   100G  0 part /mnt/Gacrux
|-sda8   8:8    0    50G  0 part 
`-sda9   8:9    0    15G  0 part [SWAP]

Last edited by SgrA (2013-03-28 05:38:20)

Offline

#12 2013-03-28 11:34:10

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: [SOLVED] /dev/root is not a valid block device

I can't see anything wrong. Have you tried to chroot into your arch install and rerun lilo?

Offline

#13 2013-03-28 13:12:34

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

I did try that. Now after a few suggestions on #archlinux, I'm using LABEL's instead of device names, and SYSLINUX. The scene isn't much different, now it complains that it can't find "LABEL=Arch" instead. Here's the current fstab:

# <file system>	<dir>		<type>	<options>	<dump>	<pass>
LABEL=Boot                               	/boot 		ext2 	defaults 	0 	1
UUID=c9e24897-af78-4768-bf67-2302ebf17a2b	/mnt/Algenib 	ext4 	defaults	0 	1
LABEL=Arch                               	/ 		ext4	defaults 	0 	1
UUID=2cc33548-62ef-4c22-a2c8-13bb5a979273	/mnt/Acrux	ext4	defaults 	0	1
UUID=cd53f792-f142-45b2-aa0c-ab314950b53b       /mnt/Mimosa	ext4	defaults 	0	1
UUID=122606f2-7ef7-4746-a688-806caaacc86f	/mnt/Gacrux 	ext4	defaults,noauto	0	1
UUID=5b4c6ccb-b90c-488b-aa5d-135a2e98eaf0 	swap 		swap 	defaults 	0 	0

and here's syslinux.cfg:

# Config file for Syslinux -
# /boot/syslinux/syslinux.cfg
#
# Comboot modules:
#   * menu.c32 - provides a text menu
#   * vesamenu.c32 - provides a graphical menu
#   * chain.c32 - chainload MBRs, partition boot sectors, Windows bootloaders
#   * hdt.c32 - hardware detection tool
#   * reboot.c32 - reboots the system
#   * poweroff.com - shutdown the system
#
# To Use: Copy the respective files from /usr/lib/syslinux to /boot/syslinux.
# If /usr and /boot are on the same file system, symlink the files instead
# of copying them.
#
# If you do not use a menu, a 'boot:' prompt will be shown and the system
# will boot automatically after 5 seconds.
#
# Please review the wiki: [url]https://wiki.archlinux.org/index.php/Syslinux[/url]
# The wiki provides further configuration examples

DEFAULT arch
PROMPT 0        # Set to 1 if you always want to display the boot: prompt 
TIMEOUT 50
# You can create syslinux keymaps with the keytab-lilo tool
#KBDMAP de.ktl

# Menu Configuration
# Either menu.c32 or vesamenu32.c32 must be copied to /boot/syslinux 
UI menu.c32
#UI vesamenu.c32

# Refer to [url]http://syslinux.zytor.com/wiki/index.php/Doc/menu[/url]
MENU TITLE Arch Linux
#MENU BACKGROUND splash.png
MENU COLOR border       30;44   #40ffffff #a0000000 std
MENU COLOR title        1;36;44 #9033ccff #a0000000 std
MENU COLOR sel          7;37;40 #e0ffffff #20ffffff all
MENU COLOR unsel        37;44   #50ffffff #a0000000 std
MENU COLOR help         37;40   #c0ffffff #a0000000 std
MENU COLOR timeout_msg  37;40   #80ffffff #00000000 std
MENU COLOR timeout      1;37;40 #c0ffffff #00000000 std
MENU COLOR msg07        37;40   #90ffffff #a0000000 std
MENU COLOR tabmsg       31;40   #30ffffff #00000000 std

# boot sections follow
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

LABEL arch
	MENU LABEL Arch Linux
	LINUX ../vmlinuz-linux
	APPEND root=LABEL=Arch ro
	INITRD ../initramfs-linux.img

LABEL archfallback
	MENU LABEL Arch Linux Fallback
	LINUX ../vmlinuz-linux
	APPEND root=LABEL=Arch ro
	INITRD ../initramfs-linux-fallback.img
LABEL algenib
        MENU LABEL Algenib
        LINUX ../vml-alg
        APPEND root=UUID=c9e24897-af78-4768-bf67-2302ebf17a2b
        INITRD ../ini-alg

#LABEL windows
#        MENU LABEL Windows
#        COM32 chain.c32
#        APPEND hd0 1

LABEL hdt
        MENU LABEL HDT (Hardware Detection Tool)
        COM32 hdt.c32
 
LABEL reboot
        MENU LABEL Reboot
        COM32 reboot.c32
 
LABEL off
        MENU LABEL Power Off
        COMBOOT poweroff.com

This is what happens:
http://i.imgur.com/cVh1l1l.jpg

Last edited by SgrA (2013-03-28 13:20:22)

Offline

#14 2013-03-28 13:25:33

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,154

Re: [SOLVED] /dev/root is not a valid block device

All right, as a sanity check, could you see whether you can mount your / from the rootfs emergency shell prompt. If you can't find /dev/disk/by-label/Arch, then try /dev/sda4. Mount it to /new_root, then exit the shell and see if boot continues as normal.

EDIT: Also, you shouldn't have "1" on the end of every entry in fstab. Only the root partition should have a pass_no value of 1, everything else should have a 2 or 0 -- 2 for filesystem check, 0 for skip filesystem check. This is unrelated to the current problem though, it's just a mistake that a lot of users seem to make.

Last edited by WorMzy (2013-03-28 13:30:13)


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#15 2013-03-28 13:43:56

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [SOLVED] /dev/root is not a valid block device

Sounds like your initramfs is missing modules. Output of 'lsinitcpio -a /path/to/initramfs.img' would be helpful.

Offline

#16 2013-03-28 18:00:19

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

Solved, thanks, everybody for your time. The problem was that I didn't have the udev hook mkinitcpio.conf, added that and it works.

Offline

#17 2013-03-28 18:18:41

SgrA
Member
Registered: 2011-06-08
Posts: 36

Re: [SOLVED] /dev/root is not a valid block device

WorMzy, Also, thanks for the suggestion on setting up pass_no to 2 for non-root partitions.

Offline

Board footer

Powered by FluxBB