You are not logged in.

#1 2013-03-27 14:08:22

MadCat_X
Member
Registered: 2009-10-08
Posts: 157

[SOLVED] High CPU load with SMPlayer and VAAPI

Hi,

I recently switched to a "new" laptop with an Intel HD3000 GPU. I immediately noticed that even though I appear to have all necessary libraries and software installed, mplayer-vaapi uses a lot of CPU during playback even though VAAPI is enabled. If I launch mplayer from console with -vo vdpau vaapi or use GNOME MPlayer instead, CPU load won't exceed ~2 %, whereas when I use SMPlayer, it goes as high as 50 % (I don't have "Divide by # of CPUs" enabled in KDE's Activity monitor, so full load would be 400 %). The machine has an i5-2410 with four logical CPUs. Is this a known issue with SMPlayer? I use KDE 4.10 with KWin's compositing enabled, but switching it off doesn't make any difference.

At the moment I have installed:

- extra/xf86-video-intel 2.21.5-1
- community/mplayer-vaapi 35107-5
- extra/libva 1.1.0-2
- extra/libva-intel-driver 1.0.19-1
- extra/libva-vdpau-driver 0.7.4-1
- extra/smplayer 0.8.3-2

EDIT: I by mistake typed vdpau instead of vaapi, I hope you all noticed the mix up.

Last edited by MadCat_X (2013-03-29 20:00:37)

Offline

#2 2013-03-27 16:07:16

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [SOLVED] High CPU load with SMPlayer and VAAPI

What type of files did you try to play?

Options->View logs->SMPlayer might help.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#3 2013-03-27 18:29:22

MadCat_X
Member
Registered: 2009-10-08
Posts: 157

Re: [SOLVED] High CPU load with SMPlayer and VAAPI

Nothing unusual, mostly x264 encoded videos which play fine on my old nVidia laptop through VDPAU or when I use anything else than SMPlayer. The SMPlayer log is here (http://pastebin.com/v1ZRNZky)

Offline

#4 2013-03-29 20:00:20

MadCat_X
Member
Registered: 2009-10-08
Posts: 157

Re: [SOLVED] High CPU load with SMPlayer and VAAPI

Solved, it turned out to be the video filters. SMPlayer disables video filters automatically when VDPAU is in use but with VAAPI it's not the case. Unchecking "Postprocessing" in Video->Filters reduces the CPU usage to where I expect it to be.

Offline

Board footer

Powered by FluxBB