You are not logged in.

#1 2013-03-27 18:08:19

AlVer
Member
Registered: 2013-03-23
Posts: 8

[SOLVED] Problem with sound (pulseaudio ?)

Hello,

I'm new on Arch. I solved almost all the little problems I've had but this one is a bit trickier.
So, when I open an application that use sound (like banshee or smplayer), my keyboard keys to increase or reduce the sound are effective only on the application's sound, but not on the "general" sound.

I know it's not very clear so I add a picture of my gnome "sound applet" to explain it better :

http://www.hostingpics.net/viewer.php?i … roblem.png


So normally, it should be the "green" gauge that moves and not the others (the red ones). On my Ubuntu partition, it's like that.
It's like the application take control of the sound. So, for example, when I open banshee, the volume automaticaly comes to the maximum...

Pulseausio seems running :

$ ps -aux | grep pulse
alex       641  3.9  0.1 513956 13852 ?        S<l  18:10   2:01 /usr/bin/pulseaudio --start
alex       669  0.0  0.0  69132  2640 ?        S    18:11   0:00 /usr/lib/pulse/gconf-helper
alex      1834  0.0  0.0  12348  1120 pts/0    S+   19:01   0:00 grep pulse

How can I fix that ?

Thanks in advance !

Last edited by AlVer (2013-03-28 18:12:12)

Offline

#2 2013-03-27 22:25:00

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Problem with sound (pulseaudio ?)

What controls the keys? What kind of machine is it?  Have you done anything to configure pulseaudio?  If it works in another operating system, what controls those keys?

Offline

#3 2013-03-28 02:44:15

Max-P
Member
Registered: 2011-06-11
Posts: 164

Re: [SOLVED] Problem with sound (pulseaudio ?)

https://wiki.archlinux.org/index.php/Pu … is_started

Disable flat-volumes in the config.

Offline

#4 2013-03-28 18:11:58

AlVer
Member
Registered: 2013-03-23
Posts: 8

Re: [SOLVED] Problem with sound (pulseaudio ?)

Hello and thanks for your responses.

@Max-P : I tried and it works ! Thank you !

Offline

Board footer

Powered by FluxBB