You are not logged in.

#1 2013-03-28 08:10:49

oconnor663
Member
Registered: 2012-12-16
Posts: 45

Stuck trying to get unigine-heaven to run

I'd like to run benchmarks on a couple of graphics cards I have around, so I'm trying out unigine-heaven from the AUR. (Forgive me for asking for help with unsupported packages.) The initial window launches, but when I actually try to run the benchmark it fails with:

$ unigine-valley
Loading "/opt/unigine-valley/bin/../data/valley_1.0.cfg"...
Loading "libGPUMonitor_x64.so"...
Loading "libGL.so.1"...
Loading "libopenal.so.1"...
Set 1280x1024 fullscreen video mode
X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  53
  Current serial number in output stream:  52
AL lib: (EE) alc_cleanup: 1 device not closed

I read on https://aur.archlinux.org/packages/unigine-heaven/ that the open source ATI drivers are unsupported, and that's what I'm using, so maybe that explains the error. But when I try to install catalyst-dkms (even from a totally fresh arch base system), I run into this bug https://bugs.archlinux.org/task/34360

:: catalyst-utils and xorg-server are in conflict. Remove xorg-server? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)

So now I've got two problems, plus I'm not sure they're related. Does anyone know of either
1) A way to make unigine-heaven work on on the open source drivers
2) A way to install the closed source drivers right now

Or even:
3) A good GPU benchmark besides this one

Thanks for any and all help.

Offline

#2 2013-03-28 13:22:37

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: Stuck trying to get unigine-heaven to run

run glxinfo , and at the end you'll see something like this :

360 GLXFBConfigs:
    visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
  id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------------
0x071 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x072 24 tc  0  32  0 r  . .   8  8  8  8 .  .  0  0  0 16 16 16 16  0 0 Slow
0x073 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None
0x074 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0 16 16 16 16  0 0 Slow
0x075 24 tc  0  32  0 r  y .   8  8  8  8 .  .  0  0  0  0  0  0  0  0 0 None

That list shows all supported GLXFBConfigs, but unigine-valley needs one that is NOT on the list.
Unigine valley doesn't specifiy their openGL requirements, so it's hard to tell what exactly is missing.

For graphics benchmarks, check the wiki on the Phoronix Test Suite,

Incase you want to switch to the closed drivers, check the catalyst wiki page.
Basically you need an older version of X .

Last edited by Lone_Wolf (2013-03-28 13:23:09)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2013-03-28 20:38:03

oconnor663
Member
Registered: 2012-12-16
Posts: 45

Re: Stuck trying to get unigine-heaven to run

Thanks Lone_Wolf! Here's the specific section about getting that old version of X, for anyone else reading: https://wiki.archlinux.org/index.php/AM … positories

I'll take a look at Phoronix too. Awesome.

Offline

Board footer

Powered by FluxBB