You are not logged in.

#1 2005-10-22 21:27:02

From: Christiansfeld - Denmark
Registered: 2005-01-25
Posts: 45

No sound.

Hi Everybody,

I got a new laptop yesterday, it's brillant, except one problem.
I can't get the audio to work.

hwd says no soundcard, lspci doesn't seem to find it.
Tried to use alsaconf, it reports it as: hda_intel 00:1b.0 Class 0403: Intel Corp.: Unknown Device 2668.
After alsacong, everything looks fine,. it doesn't give any errors, i can mute and unmute, and changes the volume with no problems. If I try to play a mp3 in e.g. xmms, it plays the file, the only problem is there is no sound coming out of the speakers nor the head phones. I lso tried as root, allthough I added my user to the audio group.

Anyone having a suggestion ?

Know your rights -


#2 2005-10-23 11:48:45

From: Karlsruhe / Germany
Registered: 2005-10-06
Posts: 404

Re: No sound.

The same here. I have a Creative Labs ES1371 in my Notebook.

Everything looks ok, but there is no sound output on my speakers. Everything is unmuted but still no sound.
I have done the steps, which are in the wiki (adding user to group sound, etc.), but it doesn't work....

There are no error messages, everything seems fine. I have the newest kernel (kernel26 installed and the newest packages which are available.



#3 2005-10-24 11:45:40

From: Cornwall, UK
Registered: 2004-09-17
Posts: 549

Re: No sound.

It would be worth booting up from a knoppix or kanotix livecd as their automatic hardware detection is second to none.  They both play audio during the kde startup (a female voice saying "initialising system startup" or something similar).

If that doesn't work you'll need to do some more homework - suggest the gentoo forums as a good starting place.


#4 2005-10-25 08:25:37

Registered: 2005-03-01
Posts: 442

Re: No sound.

Cotton wrote:

If that doesn't work you'll need to do some more homework.

Nah.  I had sound working on Arch, since January, on my laptop -- until kernel26  Now Hotplug takes forever to do it's magic and it complains bitterly about the sound module.

Will post here again when the resolution is found.

[EDIT] Ok.  Realized this is a "new sound card" thread.  I fixed my sound issues, but the fix isn't applicable to this thread.

Moving on...


#5 2005-10-25 09:08:49

From: Skien, Norway
Registered: 2003-12-29
Posts: 286

Re: No sound.

I have a laptop with a hda-intel, and it seems the drivers are quite new, and it seems to be many different cards, and the driver isn't very good at deciding how to handle everything. Here's some things you can try when you're loading the snd-had-intel module.

This is from the kernel source


Module snd-hda-intel

    Module for Intel HD Audio (ICH6, ICH6M, ICH7), ATI SB450,
               VIA VT8251/VT8237A

    model       - force the model name
    position_fix - Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size)

    Module supports up to 8 cards.

    Each codec may have a model table for different configurations.
    If your machine isn't listed there, the default (usually minimal)
    configuration is set up.  You can pass "model=<name>" option to
    specify a certain model in such a case.  There are different
    models depending on the codec chip.

          Model name    Description
          ----------    -----------
          3stack        3-jack in back and a headphone out
          3stack-digout 3-jack in back, a HP out and a SPDIF out
          5stack        5-jack in back, 2-jack in front
          5stack-digout 5-jack in back, 2-jack in front, a SPDIF out
          6stack        6-jack in back, 2-jack in front
          6stack-digout 6-jack with a SPDIF out
          w810          3-jack
          z71v          3-jack (HP shared SPDIF)
          asus          3-jack
          uniwill       3-jack
          F1734         2-jack
          test          for testing/debugging purpose, almost all controls can be
                        adjusted.  Appearing only when compiled with

          minimal       3-jack in back
          min_fp        3-jack in back, 2-jack in front
          full          6-jack in back, 2-jack in front
          full_dig      6-jack in back, 2-jack in front, SPDIF I/O
          allout        5-jack in back, 2-jack in front, SPDIF out
          auto          auto-config reading BIOS (default)

    If the default configuration doesn't work and one of the above
    matches with your device, report it together with the PCI
    subsystem ID (output of "lspci -nv") to ALSA BTS or alsa-devel
    ML (see the section "Links and Addresses").

    Note 2: If you get click noises on output, try the module option
            position_fix=1 or 2.  position_fix=1 will use the SD_LPIB
            register value without FIFO size correction as the current
            DMA pointer.  position_fix=2 will make the driver to use
            the position buffer instead of reading SD_LPIB register.
            (Usually SD_LPLIB register is more accurate than the
            position buffer.)

I got sound, but the mixer is quite strange. There's no Master control, and usually no PCM control, but I got a Front control, which works for sound. Sometime I also get a PCM which works. In the beginning I got clicking sounds espessially when playing in Audacity. Then I used this option for the module to get rid of it:

modprobe snd-hda-intel position_fix=2


#6 2005-10-28 18:36:19

From: Christiansfeld - Denmark
Registered: 2005-01-25
Posts: 45

Re: No sound.

Hmmm, unfortunately it didn't work for me, not even with the diffrent position_fix'

Know your rights -


Board footer

Powered by FluxBB