You are not logged in.

#1 2013-03-28 22:07:03

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

[SOLVED]linux-headers upgrade fails with PGP signature error

Whe trying to upgrade the linux kernel using:

pacman -S linux linux-headers

it fails with the following error:

(2/2) checking package integrity                             [#################################] 100%
error: linux: signature from "Tobias Powalowski <tobias.powalowski@googlemail.com>" is unknown trust
error: linux-headers: signature from "Tobias Powalowski <tobias.powalowski@googlemail.com>" is invalid
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

I have tried deleting /etc/pacman.d/gnupg and the recreating it with

pacman-key --init

, I have also run

pacman -Syy

to make sure the repository is up to date.  I read the wiki post about time, but my ntp daemon is running, and I have confirmed that my time is exactly right.

Last edited by MikeDacre (2013-04-01 23:32:27)

Offline

#2 2013-03-28 22:30:59

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,537
Website

Re: [SOLVED]linux-headers upgrade fails with PGP signature error


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#3 2013-04-01 23:11:25

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

Re: [SOLVED]linux-headers upgrade fails with PGP signature error

Hi,

Sorry, but that doesn't help me.  I can't find any reference in that post to this problem.  I get a similar issue when I try to upgrade mysql:

>> sudo pacman -S mariadb libmariadbclient mariadb-clients                      16:06 Mon 04-01-2013
resolving dependencies...
looking for inter-conflicts...
:: libmariadbclient and libmysqlclient are in conflict. Remove libmysqlclient? [y/N] y
:: mariadb-clients and mysql-clients are in conflict. Remove mysql-clients? [y/N] y
:: mariadb and mysql are in conflict. Remove mysql? [y/N] y

Targets (6): libmysqlclient-5.5.30-6 [removal]  mysql-5.5.30-6 [removal]
             mysql-clients-5.5.30-6 [removal]  libmariadbclient-5.5.30-2  mariadb-5.5.30-2
             mariadb-clients-5.5.30-2

Total Download Size:    16.85 MiB
Total Installed Size:   152.41 MiB
Net Upgrade Size:       28.51 MiB

Proceed with installation? [Y/n] y
:: Retrieving packages from extra...
 libmariadbclient-5.5.30-2-x86_64     6.6 MiB  1479K/s 00:05 [#################################] 100%
 mariadb-clients-5.5.30-2-x86_64    871.8 KiB   421K/s 00:02 [#################################] 100%
 mariadb-5.5.30-2-x86_64              9.4 MiB   440K/s 00:22 [#################################] 100%
(3/3) checking package integrity                             [#################################] 100%
error: libmariadbclient: key "BBE43771487328A9" is unknown
:: Import PGP key , "Bartlomiej Piotrowski <b@bpiotrowski.pl>", created 2011-10-10? [Y/n] y
error: key "Bartlomiej Piotrowski <b@bpiotrowski.pl>" could not be imported
error: mariadb-clients: key "BBE43771487328A9" is unknown
:: Import PGP key 487328A9, "Bartlomiej Piotrowski <b@bpiotrowski.pl>", created 2011-10-10? [Y/n] y
(3/3) checking package integrity                             [#################################] 100%
error: libmariadbclient: signature from "Bartlomiej Piotrowski <b@bpiotrowski.pl>" is unknown trust
error: mariadb-clients: signature from "Bartlomiej Piotrowski <b@bpiotrowski.pl>" is unknown trust
error: mariadb: signature from "Bartlomiej Piotrowski <b@bpiotrowski.pl>" is unknown trust
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Offline

#4 2013-04-01 23:24:17

MikeDacre
Member
From: San Francisco Bay Area
Registered: 2013-01-18
Posts: 51
Website

Re: [SOLVED]linux-headers upgrade fails with PGP signature error

Argh, once again I mis-googled, I don't know how I missed the other posts on this forum earlier.  At the risk of being obscenely redundant, for anyone else looking, check out this blog post:

http://allanmcrae.com/2011/12/pacman-pa … rch-linux/

I hadn't merged /etc/pacman.d/mirrorlist.pacnew.

Note: after fixing the issues you may still get key errors with previously failed downloads.  Just do pacman -Sc to clean the db and try again.

Sorry for spamming the list.

Last edited by MikeDacre (2013-04-01 23:59:53)

Offline

Board footer

Powered by FluxBB