You are not logged in.

#1 2013-03-29 20:48:36

FlyingHappy
Member
From: Cincinnati, OH
Registered: 2011-04-18
Posts: 186

Heekscnc opt dependancie libactp

I am trying to get this package to build from source.  I seem to be running into an error that google cannot seem to solve for me.

http://pastebin.com/uJh8QF9J

I'm downloading source from www.github.com/Heeks/libactp and running the below commands...

$ cd PythonLib
$ make

And that is where I get the error.  Not sure if I have all the information needed but this is the first time I have not been able to build something on this machine!

Last edited by FlyingHappy (2013-03-29 20:49:04)

Offline

#2 2013-03-30 11:44:55

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,166

Re: Heekscnc opt dependancie libactp

PyInt_FromLong appears to be python2 only.

a DDG search for PyInt_FromLong gave me this link : http://docs.python.org/2/c-api/int.html

another search for 'PyInt_FromLong python3' gave this : http://python3porting.com/cextensions.html

In short libactp looks like a python2 library, try building it against python2 .


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2013-03-30 14:24:21

FlyingHappy
Member
From: Cincinnati, OH
Registered: 2011-04-18
Posts: 186

Re: Heekscnc opt dependancie libactp

Got it to compile.  Really getting frusterated with Heeks though.  Anybody else around here use it?  I can't get the zigzag path or waterline paths to show up.  I have installed opencamlib so they should be present.  Been a real pain for me.

Offline

Board footer

Powered by FluxBB