You are not logged in.

#1 2013-03-31 22:24:08

Flanders
Member
Registered: 2013-02-17
Posts: 4

[SOLVED] System stopped seeing my second HDD

Today after system upgrade and reboot my Arch stopped seeing my second HDD (it doesn't appear in /dev )

Disk: WD3200AAJS
dmesg:

# dmesg | grep ata1.01
[    0.727453] ata1.01: ATA-7: WDC WD3200AAJS-00RYA0, 12.01B01, max UDMA/133
[    0.727458] ata1.01: 625142448 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    0.728464] ata1.01: no PIO support
[    5.879153] ata1.01: no PIO support
[    5.879155] ata1.01: disabled

Disk is still accessible by Windows(which boots from it) so it can't be broken(or can?)...

Last edited by Flanders (2013-04-01 12:00:55)

Offline

#2 2013-03-31 22:46:35

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: [SOLVED] System stopped seeing my second HDD

Your disk is SATA or PATA? Internal or External? Do you have SATA Mode in bios in compatibility mode or AHCI?

Offline

#3 2013-03-31 23:11:02

Flanders
Member
Registered: 2013-02-17
Posts: 4

Re: [SOLVED] System stopped seeing my second HDD

Disk is SATA and internal.
In BIOS I have found such options:
ATA/IDE mode set as Native
Storage Controller set as IDE (the second option to choose is AHCI)

Offline

#4 2013-03-31 23:31:52

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: [SOLVED] System stopped seeing my second HDD

Storage Controller set as IDE (the second option to choose is AHCI)

Arch kernel doesn't have support for IDE devices anymore, you should select AHCI. The problem is that if you installed "Windows" with the controller as IDE then it will seace to work when you select AHCI.

For what i've read arround here, there is a workarround for IDE devices, but i don't know if it works anylonger:

pcie_aspm=force

Last edited by s1ln7m4s7r (2013-03-31 23:32:36)

Offline

#5 2013-04-01 03:05:41

PReP
Member
From: Sweden/Sala
Registered: 2010-06-13
Posts: 347
Website

Re: [SOLVED] System stopped seeing my second HDD

If AHCI is the case, i did this on my Win7 system some month ago or so to be prepared (and it worked here atleast)
http://forums.guru3d.com/showthread.php?t=313676

Just remember to set AHCI mode in BIOS, after changing it in Win.


#1 Main: Intel Core i5 2500k (Sandy) @ 3.9 Ghz, 8 GB DDR2-XMP RAM @ 1600 Mhz, Geforce GTX 570 (Gainward Phantom) - Arch Linux 64-Bit
#2 Server: Intel C2D E8400 @ 3.6 Ghz, 3 GB DDR2-RAM @ 802mhz, XFX GF GTX260 XT -ArchLinux 64-bit.

<- Server Homepage: http://prep.mine.nu ->

Offline

#6 2013-04-01 12:00:44

Flanders
Member
Registered: 2013-02-17
Posts: 4

Re: [SOLVED] System stopped seeing my second HDD

OK, switching to AHCI helped, thanks wink

Offline

Board footer

Powered by FluxBB