You are not logged in.

#1 2013-04-05 17:27:42

LyCC
Member
Registered: 2012-09-05
Posts: 83

Apper not working after recent update

Hi everyone,

with today's update of pacman, apper stopped working, any solution to get it back and running? I get this in the terminal:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
enumFromString ( Role ) : converted "" to "UnknownRole" , enum id 0
enumFromString ( Group ) : converted "" to "UnknownGroup" , enum id 1
enumFromString ( Filter ) : converted "" to "UnknownFilter" , enum id 3
Error, cannot create transaction proxy
QDBusError("com.trolltech.QtDBus.Error.InvalidObjectPath", "Invalid object path: Process /usr/lib/dbus-1.0/dbus-daemon-launch-helper received signal 5")
Error, cannot create transaction proxy
QDBusError("com.trolltech.QtDBus.Error.InvalidObjectPath", "Invalid object path: Process /usr/lib/dbus-1.0/dbus-daemon-launch-helper received signal 5")

and in the GUI i get "an error occured" for everything, no package list, no nothing.

Thanks.

Edit: it started to work after a forced repo update today.

Last edited by LyCC (2013-04-06 07:19:42)

Offline

#2 2013-04-11 10:45:32

Hannus
Member
Registered: 2013-04-04
Posts: 14

Re: Apper not working after recent update

At my computer, there was a problem with the configuration file of pacman (/etc/pacman.conf). Do something with pacman in the terminal, and see if there is an warning message of pacman. After I updated the configuration file, the problem with Apper was gone.

When solved, please change the subject with [SOLVED].

Offline

Board footer

Powered by FluxBB