You are not logged in.

#1 2013-04-06 18:09:46

jaredanderson
Member
Registered: 2013-04-06
Posts: 18

ehci-pci setting latency timer causes mouse lag [SOLVED]

Long story short I have been having a mouse lag issue since I installed Arch, about two weeks ago. Everytime the mouse lags the kernel log displays this message

  ehci-pci 0000:00:1a.0: setting latency timer to 64 

  it is fairly clear that my issue is somehow related to this message but I suspect maybe something else is going on here. any help on this would be appreciated thank you.

Last edited by jaredanderson (2014-10-19 01:23:19)

Offline

#2 2013-04-10 22:29:24

jaredanderson
Member
Registered: 2013-04-06
Posts: 18

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

I searched for answers everywhere, I have yet to figure out why the problem comes and goes. I now know that it is only related to my external mouse not the touchpad, Ehci is in charge of connecting external usb devices in some way.

Offline

#3 2013-05-09 21:28:56

stimut
Member
Registered: 2011-03-03
Posts: 4

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

I have the same problem on my laptop. I haven't fully solved it, but I found a workaround here: https://bbs.archlinux.org/viewtopic.php … 9#p1270259 .

In short, I need to either boot without mains power connected, or else disconnect mains power so that I'm using battery power at least for a couple of seconds.

Offline

#4 2013-07-09 13:24:15

Markus00000
Member
Registered: 2011-03-27
Posts: 281

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

I have the same issue but only with one of four USB ports on my laptop:

  • USB 3.0, xhci_hcd, no lag

  • Powered USB 3.0, xhci_hcd, no lag

  • eSATA/USB 2.0, xhci_hcd, no lag

  • USB 2.0, ehci-pci, lag

Just wanted to mention it in case you haven't noticed the "use another port" workaround.

Offline

#5 2013-08-28 22:58:45

mieLouk
Member
Registered: 2012-12-16
Posts: 36

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

Hi guys,

I exposed myself today voluntarily to this problem, because I wanted to get rid of linux-mode-tools, maybe even expand my battery usage a little longer.
This post I found while searching for the dmesg message with the ehci-pci entry, which popped up each time my mouse woke up.

A half year ago I'd tried to solve the activation lag of my mouse by editing the /etc/modprobe.de/modprobe.conf and set

options usbcore autosuspend=600

which didn't work.
Some people told me to directly fiddle with the kerneloptions and set them to a value. Which didn't work either.

In this post https://bbs.archlinux.org/viewtopic.php … 0#p1178070 I found this script, which shows the usb devices that can get autosuspend.

for d in /sys/bus/usb/devices/[0-9]* ; do if [[ -e $d/product ]] ; then echo -e "`basename $d`\t`cat $d/power/control`\t`cat $d/speed`\t`cat $d/product`" ; fi ; done

This lowered my expectations on finding a solution, at least for lowering the power usage.

Then I tried to apply this solution with making the file 91-local.rules with the content

ACTION=="add", SUBSYSTEM=="usb", ATTR{product}=="Unifying Receiver", ATTR{power/control}="on"

where I changed ATTR{product}==" * " to a lots of different values, but it didn't work. Udev(adm) is a b****!! Neither did this work.

This guy had the same problem and found the same solution as myself a half year ago. Use laptop-mode-tools, which I wanted to avoid.
http://fitzcarraldoblog.wordpress.com/2 … sconnected

Finally, I found a solution which works for me big_smile

Editing the /etc/udev/rules.d/usb_power_save.rules to not disable the autsuspend but delay it a bit more, where 60 is in seconds.

ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control", ATTR{power/control}="auto"
ACTION=="add", SUBSYSTEM=="usb", TEST=="power/autosuspend", ATTR{power/autosuspend}="60"

or this to disable the usb autsuspend completely:

ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control", ATTR{power/control}="on"

As the script above told me, there is only my webcam and my mousereceiver which get autosuspended, so I might disable it completely, have not decided yet, but it works now wink

Hope this will help someone with this very annoying problem.

Last edited by mieLouk (2013-08-29 12:18:53)

Offline

#6 2013-08-28 23:28:17

brebs
Member
Registered: 2007-04-03
Posts: 3,401

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

You've missed out commas between TEST and ATTR.

Offline

#7 2013-08-29 12:17:00

mieLouk
Member
Registered: 2012-12-16
Posts: 36

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

Thx, fixed it wink

Offline

#8 2013-09-23 22:55:00

invsblduck
Member
Registered: 2012-07-12
Posts: 4

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

In my case laptop-mode was configured to enable the autosuspend, so the udev rule wasn't fixing the problem.

I added

AUTOSUSPEND_USBTYPE_BLACKLIST="usbhid"

to

/etc/laptop-mode/conf.d/usb-autosuspend.conf

and now my USB mouse doesn't power save when I unplug the AC adapter.

duck

Offline

#9 2014-10-19 01:21:07

jaredanderson
Member
Registered: 2013-04-06
Posts: 18

Re: ehci-pci setting latency timer causes mouse lag [SOLVED]

I forgot to check this post, I recently got it to work by changing my usb-autosuspend in laptopmode

Offline

Board footer

Powered by FluxBB