You are not logged in.

#1 2013-04-09 02:47:16

cecure
Member
Registered: 2013-04-09
Posts: 5

Unable to find root device after upgrade

Following my latest pacman update (I believe it included an upgrade to kernel 3.8.6), on boot I am told that it is unable to find my root device.

I use refind for my boot manager and before my reboot I copied the new initramfs image files to my /boot/efi/EFI/Arch directory as I have done several times before.

When I noticed the problem I had /dev/sda2 as my root, I replaced it in my conf file for refind with its PARTUUID with no success.
I am able to mount the disk in the Arch install disk environment and can chroot into my system.
I have rebuilt and re-installed to /boot/efi/EFI/Arch my initramfs images using the command:

mkinitcpio -p linux

I have tried that with both /etc/mkinitcpio.conf set to the defaults and with autodetect added at the end of the HOOKS list... both with no luck.

Every time I have tried a new initramfs build I try both the main image and the fallback.  Both fail.

The harddrive is a Kingston SSD and has been working fine for almost a month (it is a new system) with Arch.  My boot partition is on the same drive as the root so the harddrive is definitely working since I do get the initial boot screen for refind and the first few messages from the boot showing the initramfs image being used.

Any ideas for other avenues to try would be appreciated smile

Offline

#2 2013-04-10 16:59:54

Asudo
Member
Registered: 2013-04-09
Posts: 1

Re: Unable to find root device after upgrade

Maybe, I have the same situation.
I tried downgrading kernel to 3.8.5, then boot successful.
The cause is Kernel 3.8.6?
I also want to know the correct way.

Best regards,

Offline

Board footer

Powered by FluxBB