You are not logged in.

#1 2013-04-15 23:47:59

darkoverde
Member
Registered: 2013-04-15
Posts: 1

UEFI Boot on Dell Inspiron 14r 5420

Recently i bought a new notebook, Dell Inspiron 14r 5420...

I tried to install ArchLinux, but with no sucess.
My intention is make dual boot with windows 8 because of the games.

When i use Legacy BIOS, i can start the installation without problems, but win8 don't starts.

So I decided to install archlinux with grub-efi.

On first time, o burned a cd with ISO 2013.04.01, but after efi menu, system freezes. Ctrl+Alt+Del don't works. I have to turn off and on the notebook.

On second time, I made a bootable pendrive according the link: https://wiki.archlinux.org/index.php/Un … B_from_ISO, but is the same. System freezes after efi menu, with blank screen ...

I tested this pendrive and CD on my PC and it worked perfectly.

PS.: During this fight, "Secure Boot" was always disabled.

Is there a hardware compatibility problem? Is there anything i can do? Or just wait a new ISO and pray to work?


Thanks

Offline

#2 2013-04-16 13:58:46

arthro
Member
Registered: 2013-03-25
Posts: 6

Re: UEFI Boot on Dell Inspiron 14r 5420

I'm only a recent archlinux user, but I have had similar problems which I am sure are due to video screen problems. I.e. the laptop may have some odd variant of video HW that archlinux expects.

In my case, the indication was the start of words on the screen, a white small box and the rest of the screen blank. I would try again, sometimes up to 12 times (that takes alot of time) but finally it would succeed at the end.

However, you don't describe that .. you simply say "system freeze", so may be my experience was different, and it's not video problems that you have.


History: RedHat -> Slacker -> gentoo-> SuSE -> Ubuntu -> now Arch.

Offline

#3 2013-04-22 22:28:02

wakkadojo
Member
Registered: 2009-05-31
Posts: 50

Re: UEFI Boot on Dell Inspiron 14r 5420

There's nothing wrong with the ISO's I just think you're getting a little mixed up about how to boot up since you are switching around between legacy and UEFI.

It sounds like legacy booting worked fine for arch but you were having problems with win8. Windows 8 uses UEFI booting by default, but legacy booting can be enabled I believe. So what you tried had UEFI booting for Windows and legacy booting for arch. You need to choose one or the other. I think you should just stick with UEFI since it's easy to dual boot with UEFI.

Also, if you're in UEFI mode and are trying to boot linux off of a CD or USB, make sure that you didn't copy the full ISO's to your media. UEFI booting off of CD/USB doesn't work exactly the same way as legacy booting: you need to extract the ISO then copy the contents onto a FAT32 formatted USB. Please see https://wiki.archlinux.org/index.php/Un … B_from_ISO

Offline

Board footer

Powered by FluxBB