You are not logged in.

#1 2013-04-22 03:35:28

jiewmeng
Member
Registered: 2012-02-09
Posts: 117

Gnome 3.8 not working (upgrade from 3.6)

I just did `pacman -Syyu`, then I tried Alt-F2 -> "r" to refresh shell. The UI hangs. I reboot, login (gdm working I suppose), but after logging in the screen becomes just the "wallpaper" of GDM and a cursor (that can be moved) nothing else apart from that... So GNOME 3.8 seems to be failing for me. dmesg shows that theres a segfault about libxsettings.so? I also tried `pacman -Rc gnome` and then reinstall gnome, similar results.


Computer Science Student, Web Developer

Offline

#2 2013-04-22 05:15:04

KCE
Member
From: SoCal
Registered: 2007-06-26
Posts: 41

Re: Gnome 3.8 not working (upgrade from 3.6)

Same issue here.

Offline

#3 2013-04-22 05:29:38

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Gnome 3.8 not working (upgrade from 3.6)

gnome-shell has been working for the last 2-3 weeks without any issues for me. I have enabled the testing repo. How did you upgrade?


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#4 2013-04-22 06:43:54

jiewmeng
Member
Registered: 2012-02-09
Posts: 117

Re: Gnome 3.8 not working (upgrade from 3.6)

No I am not using testing repo. I used `pacman -Syyu`, cos I noticed GNOME 3.8 is now available ... but its GNOME 3.8 that seems to be failing ... did u upgrade to 3.8? I know 3.6 works... but now I am not sure how I might downgrade to 3.6 ...

Last edited by jiewmeng (2013-04-22 06:44:42)


Computer Science Student, Web Developer

Offline

#5 2013-04-22 07:06:32

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Gnome 3.8 not working (upgrade from 3.6)

Gnome 3.8 has just moved to extra. Try updating your system one more time. Possibly your mirrors didn't sync up all the packages yet.
You can downgrade by manually downloading your gnome 3.6 packages from arm.konnichi.com and installing it , which is too much trouble for a big DE like gnome.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#6 2013-04-22 08:49:23

@ilio
Member
Registered: 2012-02-21
Posts: 23

Re: Gnome 3.8 not working (upgrade from 3.6)

Same issue here. Just upgraded from the extra repo. This is my xsession-error. Any help is appreciated.

** (polkit-gnome-authentication-agent-1:1323): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
N: [pulseaudio] main.c: User-configured server at {933757b82e4f48a9b96604d7efcc4a09}unix:/run/user/1003/pulse/native, which appears to be local. Probing deeper.

** (nm-applet:1330): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
** Message: applet now removed from the notification area

(pcmanfm:1316): LIBDBUSMENU-GLIB-CRITICAL **: dbusmenu_server_set_root: assertion `DBUSMENU_IS_MENUITEM(root)' failed
** Message: applet now embedded in the notification area
[1408:1433:0422/102502:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[1408:1433:0422/102502:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[1408:1408:0422/102503:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[1408:1408:0422/102504:ERROR:object_proxy.cc(529)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
[1408:1408:0422/102506:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[1408:1408:0422/102511:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[1408:1408:0422/102523:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[1408:1408:0422/102524:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
Failed to parse arguments: Cannot open display: 
Failed to parse arguments: Cannot open display: 

** (gnome-terminal:1586): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (gedit:1776): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[1408:1408:0422/103812:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[1408:1408:0422/103813:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[1408:1408:0422/103819:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
QGtkStyle was unable to detect the current GTK+ theme.
Format encoding version mismatch : [found] != [expected]1.0

Thank you

Offline

#7 2013-04-22 09:11:42

ryanmichaelmcclure
Member
From: Cloudsdale, Equestria
Registered: 2012-10-26
Posts: 44
Website

Re: Gnome 3.8 not working (upgrade from 3.6)

I had a problem earlier too--logging into to an XFCE session promptly kicked me back to LightDM. Whenever I was able to make it into my session--very rare--launching Firefox didn't work. However, it terminal it told me there was a glib error. I downgraded all GNOME 3.8 packages to 3.6 and now it's working well again.

Offline

#8 2013-04-22 10:24:16

jiewmeng
Member
Registered: 2012-02-09
Posts: 117

Re: Gnome 3.8 not working (upgrade from 3.6)

@ryan how did u downgrade?


Computer Science Student, Web Developer

Offline

#9 2013-04-22 11:04:38

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: Gnome 3.8 not working (upgrade from 3.6)

Is this error still an unsolved problem? I generally check new updates every other day and now pacman suggest me to upgrade from Gnome 3.6 to Gnome 3.8 but I havent approved yet because of this problem. Is there any progress about this subject?

By the way I think gnome-games-extra-data package is removed from the extra repo, so there is no new version anymore. That's why I couldnt replace gnome-games with extra/gnome-chess, extra/gnome-klotski etc... because gnome-games is required by gnome-games-extra-data. I think first of all I have to uninstall gnome-games-extra-data and the try to update the system with pacman -Syu but this is silly error, there must be more formal solution.

Last edited by hoobastank (2013-04-22 11:05:18)

Offline

#10 2013-04-22 11:10:43

KingOfFreeMen
Member
Registered: 2013-02-10
Posts: 15

Re: Gnome 3.8 not working (upgrade from 3.6)

In my case, GDM doesn't even start anymore, anyone experiencing the same issue ?

Last edited by KingOfFreeMen (2013-04-22 11:10:55)

Offline

#11 2013-04-22 11:12:12

Boogie
Member
Registered: 2012-06-17
Posts: 27

Re: Gnome 3.8 not working (upgrade from 3.6)

#9 gnome-games-extra-data is deprecated so its not a error and it should be removed.

I havnt have problems with 3.8, i used it since it was in gnome-unstable, so no clue. It looks like a polkit issue.

Offline

#12 2013-04-22 11:18:13

jiewmeng
Member
Registered: 2012-02-09
Posts: 117

Re: Gnome 3.8 not working (upgrade from 3.6)

Looks like GNOME 3.8 is having lots of issues at least with Arch Linux, there are some who seem to be able to install/upgrade successfully. https://plus.google.com/communities/113 … ign=chrome


Computer Science Student, Web Developer

Offline

#13 2013-04-22 11:44:09

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Gnome 3.8 not working (upgrade from 3.6)

I have a suggestion which have worked very well.
1.Remove the gnome, gnome-extra packages from both 3.6 and 3.8.
2. install 3.8.
Looks like plain upgrade from 3.6 to 3.8 is creating issues.

Last edited by hadrons123 (2013-04-22 11:44:44)


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#14 2013-04-22 11:54:25

@ilio
Member
Registered: 2012-02-21
Posts: 23

Re: Gnome 3.8 not working (upgrade from 3.6)

I have removed all the gnome and gnome-extra packages using

yaourt -Rsc gnome gnome-extra

and I reinstalled both of them. It still doesn't work. Can you help me to debug it? (which log should I look into?)

Thanks

Offline

#15 2013-04-22 11:56:43

wwn
Member
Registered: 2013-03-25
Posts: 68

Re: Gnome 3.8 not working (upgrade from 3.6)

hadrons123 wrote:

I have a suggestion which have worked very well.
1.Remove the gnome, gnome-extra packages from both 3.6 and 3.8.
2. install 3.8.
Looks like plain upgrade from 3.6 to 3.8 is creating issues.

does not work for t420.

Offline

#16 2013-04-22 12:01:28

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Gnome 3.8 not working (upgrade from 3.6)

@ilio wrote:

I have removed all the gnome and gnome-extra packages using

yaourt -Rsc gnome gnome-extra

and I reinstalled both of them. It still doesn't work. Can you help me to debug it? (which log should I look into?)

Thanks

Some of the gnome 3.6 packages have been moved to community. Try removing them too.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#17 2013-04-22 12:03:26

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: Gnome 3.8 not working (upgrade from 3.6)

Boogie wrote:

#9 gnome-games-extra-data is deprecated so its not a error and it should be removed.

Yes you're right but suppose that I'm newbie linux user and dont even know what the gnome-games-extra-data package is or couldnt even remember when I've installed it. So how do I guess that I need to remove this package to keep up upgrade. Pacman interrupts upgrade because of this silly error. Yes this is still a silly error for me. Every end user can not be advenced in Linux. This is my opinion. Package management systems is exist for these situations according to me.

Last edited by hoobastank (2013-04-22 12:05:58)

Offline

#18 2013-04-22 12:10:55

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Gnome 3.8 not working (upgrade from 3.6)

hoobastank wrote:
Boogie wrote:

#9 gnome-games-extra-data is deprecated so its not a error and it should be removed.

Yes you're right but suppose that I'm newbie linux user and dont even know what the gnome-games-extra-data package is or couldnt even remember when I've installed it. So how do I guess that I need to remove this package to keep up upgrade. Pacman interrupts upgrade because of this silly error. Yes this is still a silly error for me. Every end user can not be advenced in Linux. This is my opinion. Package management systems is exist for these situations according to me.

I am sorry that you are facing issues but its nothing to do with Arch linux's package management system. No disrespect but Arch linux is a rolling distro for advanced users, you should probably know your ways around arch, when you are using it.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#19 2013-04-22 12:15:51

wwn
Member
Registered: 2013-03-25
Posts: 68

Re: Gnome 3.8 not working (upgrade from 3.6)

don't care about.

the question is: can I wait some days for a magic pacman -Syyu and all is fine or should I have to read tons of postings and try all of this...

Offline

#20 2013-04-22 12:39:55

Grima
Member
Registered: 2011-09-02
Posts: 58

Re: Gnome 3.8 not working (upgrade from 3.6)

hadrons123 wrote:

I have a suggestion which have worked very well.
1.Remove the gnome, gnome-extra packages from both 3.6 and 3.8.
2. install 3.8.
Looks like plain upgrade from 3.6 to 3.8 is creating issues.

I felt adventurous last night so I tried upgrading GNOME to 3.8. The only thing I did was to reinstall libsoup, which replaced libsoup with libsoup-gnome. After that, I just -Syu'd and pacman successfully updated my system.

So a regular upgrade from 3.6 to 3.8 worked just fine, at least for me.

Offline

#21 2013-04-22 12:52:06

@ilio
Member
Registered: 2012-02-21
Posts: 23

Re: Gnome 3.8 not working (upgrade from 3.6)

KingOfFreeMen wrote:

In my case, GDM doesn't even start anymore, anyone experiencing the same issue ?

Same issue here... Are you using intel drivers?

Offline

#22 2013-04-22 12:54:31

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: Gnome 3.8 not working (upgrade from 3.6)

hadrons123 wrote:
hoobastank wrote:
Boogie wrote:

#9 gnome-games-extra-data is deprecated so its not a error and it should be removed.

Yes you're right but suppose that I'm newbie linux user and dont even know what the gnome-games-extra-data package is or couldnt even remember when I've installed it. So how do I guess that I need to remove this package to keep up upgrade. Pacman interrupts upgrade because of this silly error. Yes this is still a silly error for me. Every end user can not be advenced in Linux. This is my opinion. Package management systems is exist for these situations according to me.

I am sorry that you are facing issues but its nothing to do with Arch linux's package management system. No disrespect but Arch linux is a rolling distro for advanced users, you should probably know your ways around arch, when you are using it.

According to me advanced distro means that you have to edit more conf files, or much more knowing filesystem of linux or maybe command line interface, shortly knowing what you do on Linux. Advenced distro is a kind of linux distro which is direct opposite of pre-customized ones so lets people to customize his/her system for any specific purpose for me. Because to edit tons of parameters are really hard, and requires good knowledge about linux. But it doesnt mean that to predict that you need to remove any package to keep up upgrade. Maybe if you are advanced in linux you can sense what you have to do but it doesnt add any contribution to your Linux knowledge. I hope I explain my viewpoint.

Last edited by hoobastank (2013-04-22 13:05:33)

Offline

#23 2013-04-22 13:02:55

@ilio
Member
Registered: 2012-02-21
Posts: 23

Re: Gnome 3.8 not working (upgrade from 3.6)

I have enable the debug options in /etc/gdm/custom.conf. In the following, the log in my /var/log/gdm folder is reported. Actually I cannot see anything weird but gdm still shows me the sad face with... Oh no, something gone wrong...

X.Org X Server 1.14.1
Release Date: 2013-04-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.8.7-1-ARCH x86_64 
Current Operating System: Linux myhost 3.8.8-1-ck #1 SMP PREEMPT Wed Apr 17 11:41:49 EDT 2013 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-linux-ck root=/dev/mapper/VolGroup00-lroot ro elevator=bfq cryptdevice=/dev/sda4:cryptoroot ipv6.disable=1 quiet
Build Date: 17 April 2013  02:37:06PM
 
Current version of pixman: 0.28.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 22 14:59:21 2013
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(==) No screen section available. Using defaults.
(**) |-->Screen "Default Screen Section" (0)
(**) |   |-->Monitor "<default monitor>"
(==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Automatically adding GPU devices
(WW) The directory "/usr/share/fonts/OTF/" does not exist.
	Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
	Entry deleted from font path.
	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
	Entry deleted from font path.
	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
(==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) config/udev: Adding drm device (/dev/dri/card0)
(--) PCI:*(0:0:2:0) 8086:0116:1043:1642 rev 9, Mem @ 0xdc400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e000/64
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 1.14.1, module version = 1.0.0
(==) AIGLX enabled
Loading extension GLX
(==) Matched intel as autoconfigured driver 0
(==) Matched intel as autoconfigured driver 1
(==) Matched vesa as autoconfigured driver 2
(==) Matched modesetting as autoconfigured driver 3
(==) Matched fbdev as autoconfigured driver 4
(==) Assigned the driver to the xf86ConfigLayout
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
	compiled for 1.14.0, module version = 2.21.6
(WW) Warning, couldn't open module vesa
(II) Unloading vesa
(EE) Failed to load module "vesa" (module does not exist, 0)
(WW) Warning, couldn't open module modesetting
(II) Unloading modesetting
(EE) Failed to load module "modesetting" (module does not exist, 0)
(WW) Warning, couldn't open module fbdev
(II) Unloading fbdev
(EE) Failed to load module "fbdev" (module does not exist, 0)
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
	i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
	4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
	Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
	Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
	Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
	Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
	Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
	Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
	Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
	Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
	Haswell Server (GT2+), Haswell SDV Desktop (GT1),
	Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
	Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
	Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
	Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
	Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
	Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
	Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
	Haswell ULT Server (GT1), Haswell ULT Server (GT2),
	Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
	Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
	Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
	Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
	Haswell CRW Server (GT2), Haswell CRW Server (GT2+),
	ValleyView PO board
(++) using VT number 1

(II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
(==) intel(0): Depth 24, (--) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(--) intel(0): Integrated Graphics Chipset: Intel(R) Sandybridge Mobile (GT2)
(**) intel(0): Relaxed fencing enabled
(**) intel(0): Wait on SwapBuffers? enabled
(**) intel(0): Triple buffering? enabled
(**) intel(0): Framebuffer tiled
(**) intel(0): Pixmaps tiled
(**) intel(0): 3D buffers tiled
(**) intel(0): SwapBuffers wait enabled
(==) intel(0): video overlay key set to 0x101fe
(II) intel(0): Output LVDS1 has no monitor section
(--) intel(0): found backlight control interface /sys/class/backlight/acpi_video1
(II) intel(0): Output VGA1 has no monitor section
(II) intel(0): Output HDMI1 has no monitor section
(II) intel(0): Output DP1 has no monitor section
(II) intel(0): EDID for output LVDS1
(II) intel(0): Manufacturer: LGD  Model: 250  Serial#: 0
(II) intel(0): Year: 2010  Week: 0
(II) intel(0): EDID Version: 1.3
(II) intel(0): Digital Display Input
(II) intel(0): Max Image Size [cm]: horiz.: 35  vert.: 19
(II) intel(0): Gamma: 2.20
(II) intel(0): No DPMS capabilities specified
(II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
(II) intel(0): First detailed timing is preferred mode
(II) intel(0): redX: 0.612 redY: 0.375   greenX: 0.332 greenY: 0.619
(II) intel(0): blueX: 0.151 blueY: 0.099   whiteX: 0.313 whiteY: 0.329
(II) intel(0): Manufacturer's mask: 0
(II) intel(0): Supported detailed timing:
(II) intel(0): clock: 72.3 MHz   Image Size:  345 x 194 mm
(II) intel(0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1526 h_border: 0
(II) intel(0): v_active: 768  v_sync: 771  v_sync_end 776 v_blanking: 790 v_border: 0
(II) intel(0):  LG Display
(II) intel(0):  LP156WH2-TLEA
(II) intel(0): EDID (in hex):
(II) intel(0): 	00ffffffffffff0030e4500200000000
(II) intel(0): 	00140103802313780ac2d59c60559e26
(II) intel(0): 	19505400000001010101010101010101
(II) intel(0): 	0101010101013e1c56a0500016303020
(II) intel(0): 	350059c2100000190000000000000000
(II) intel(0): 	00000000000000000000000000fe004c
(II) intel(0): 	4720446973706c61790a2020000000fe
(II) intel(0): 	004c503135365748322d544c454100fd
(II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
(II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
(II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
(II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
(II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
(II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
(II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
(II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
(II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
(II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
(II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
(II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
(II) intel(0): Printing probed modes for output LVDS1
(II) intel(0): Modeline "1366x768"x60.0   72.30  1366 1414 1446 1526  768 771 776 790 -hsync -vsync (47.4 kHz eP)
(II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
(II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
(II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
(II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
(II) intel(0): EDID for output VGA1
(II) intel(0): EDID for output HDMI1
(II) intel(0): EDID for output DP1
(II) intel(0): Output LVDS1 connected
(II) intel(0): Output VGA1 disconnected
(II) intel(0): Output HDMI1 disconnected
(II) intel(0): Output DP1 disconnected
(II) intel(0): Using exact sizes for initial modes
(II) intel(0): Output LVDS1 using initial mode 1366x768
(II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
(II) intel(0): Kernel page flipping support detected, enabling
(==) intel(0): DPI set to (96, 96)
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 1.14.1, module version = 1.0.0
(==) Depth 24 pixmap format is 32 bpp
(II) intel(0): [DRI2] Setup complete
(II) intel(0): [DRI2]   DRI driver: i965
(II) intel(0): Allocated new frame buffer 1408x768 stride 5632, tiled
(II) UXA(0): Driver registered support for the following operations:
(II)         solid
(II)         copy
(II)         composite (RENDER acceleration)
(II)         put_image
(II)         get_image
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(==) intel(0): DPMS enabled
(==) intel(0): Intel XvMC decoder enabled
(II) intel(0): Set up textured video
(II) intel(0): [XvMC] xvmc_vld driver initialized.
(II) intel(0): direct rendering: DRI2 Enabled
(==) intel(0): hotplug detection: "enabled"
(--) RandR disabled
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_INTEL_swap_event
(II) AIGLX: enabled GLX_ARB_create_context
(II) AIGLX: enabled GLX_ARB_create_context_profile
(II) AIGLX: enabled GLX_EXT_create_context_es2_profile
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized i965
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) intel(0): Setting screen physical size to 361 x 203
(II) config/udev: Adding input device Power Button (/dev/input/event2)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
	compiled for 1.14.0, module version = 2.8.0
(II) Using input driver 'evdev' for 'Power Button'
(**) Power Button: always reports core events
(**) evdev: Power Button: Device: "/dev/input/event2"
(--) evdev: Power Button: Vendor 0 Product 0x1
(--) evdev: Power Button: Found keys
(II) evdev: Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
(II) config/udev: Adding input device Video Bus (/dev/input/event5)
(**) Video Bus: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'Video Bus'
(**) Video Bus: always reports core events
(**) evdev: Video Bus: Device: "/dev/input/event5"
(--) evdev: Video Bus: Vendor 0 Product 0x6
(--) evdev: Video Bus: Found keys
(II) evdev: Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
(II) config/udev: Adding input device Video Bus (/dev/input/event4)
(**) Video Bus: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'Video Bus'
(**) Video Bus: always reports core events
(**) evdev: Video Bus: Device: "/dev/input/event4"
(--) evdev: Video Bus: Vendor 0 Product 0x6
(--) evdev: Video Bus: Found keys
(II) evdev: Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
(II) config/udev: Adding input device Lid Switch (/dev/input/event0)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device Sleep Button (/dev/input/event1)
(**) Sleep Button: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'Sleep Button'
(**) Sleep Button: always reports core events
(**) evdev: Sleep Button: Device: "/dev/input/event1"
(--) evdev: Sleep Button: Vendor 0 Product 0x3
(--) evdev: Sleep Button: Found keys
(II) evdev: Sleep Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
(II) config/udev: Adding drm device (/dev/dri/card0)
(II) config/udev: Adding input device USB2.0 UVC 2M WebCam (/dev/input/event12)
(**) USB2.0 UVC 2M WebCam: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'USB2.0 UVC 2M WebCam'
(**) USB2.0 UVC 2M WebCam: always reports core events
(**) evdev: USB2.0 UVC 2M WebCam: Device: "/dev/input/event12"
(--) evdev: USB2.0 UVC 2M WebCam: Vendor 0x13d3 Product 0x5122
(--) evdev: USB2.0 UVC 2M WebCam: Found keys
(II) evdev: USB2.0 UVC 2M WebCam: Configuring as keyboard
(II) XINPUT: Adding extended input device "USB2.0 UVC 2M WebCam" (type: KEYBOARD, id 10)
(II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event10)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event11)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event9)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event13)
(**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
(II) Using input driver 'evdev' for 'Logitech USB Receiver'
(**) Logitech USB Receiver: always reports core events
(**) evdev: Logitech USB Receiver: Device: "/dev/input/event13"
(--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52f
(--) evdev: Logitech USB Receiver: Found 20 mouse buttons
(--) evdev: Logitech USB Receiver: Found scroll wheel(s)
(--) evdev: Logitech USB Receiver: Found relative axes
(--) evdev: Logitech USB Receiver: Found x and y relative axes
(II) evdev: Logitech USB Receiver: Configuring as mouse
(II) evdev: Logitech USB Receiver: Adding scrollwheel support
(**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE, id 11)
(II) evdev: Logitech USB Receiver: initialized for relative axes.
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) acceleration profile 0
(**) Logitech USB Receiver: (accel) acceleration factor: 2.000
(**) Logitech USB Receiver: (accel) acceleration threshold: 4
(II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse1)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event14)
(**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'Logitech USB Receiver'
(**) Logitech USB Receiver: always reports core events
(**) evdev: Logitech USB Receiver: Device: "/dev/input/event14"
(--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52f
(--) evdev: Logitech USB Receiver: Found 1 mouse buttons
(--) evdev: Logitech USB Receiver: Found scroll wheel(s)
(--) evdev: Logitech USB Receiver: Found relative axes
(II) evdev: Logitech USB Receiver: Forcing relative x/y axes to exist.
(--) evdev: Logitech USB Receiver: Found absolute axes
(II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
(--) evdev: Logitech USB Receiver: Found keys
(II) evdev: Logitech USB Receiver: Configuring as mouse
(II) evdev: Logitech USB Receiver: Configuring as keyboard
(II) evdev: Logitech USB Receiver: Adding scrollwheel support
(**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 12)
(II) evdev: Logitech USB Receiver: initialized for relative axes.
(WW) evdev: Logitech USB Receiver: ignoring absolute axes.
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) acceleration profile 0
(**) Logitech USB Receiver: (accel) acceleration factor: 2.000
(**) Logitech USB Receiver: (accel) acceleration threshold: 4
(II) config/udev: Adding input device Asus WMI hotkeys (/dev/input/event8)
(**) Asus WMI hotkeys: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'Asus WMI hotkeys'
(**) Asus WMI hotkeys: always reports core events
(**) evdev: Asus WMI hotkeys: Device: "/dev/input/event8"
(--) evdev: Asus WMI hotkeys: Vendor 0 Product 0
(--) evdev: Asus WMI hotkeys: Found keys
(II) evdev: Asus WMI hotkeys: Configuring as keyboard
(II) XINPUT: Adding extended input device "Asus WMI hotkeys" (type: KEYBOARD, id 13)
(II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
(**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
(II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
(**) AT Translated Set 2 keyboard: always reports core events
(**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event3"
(--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
(--) evdev: AT Translated Set 2 keyboard: Found keys
(II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 14)
(II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event7)
(**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
(**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
(**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
	compiled for 1.14.0, module version = 1.7.0
(II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
(**) ETPS/2 Elantech Touchpad: always reports core events
(II) synaptics: ETPS/2 Elantech Touchpad: ignoring touch events for semi-multitouch device
(--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 1152 (res 0)
(--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 576 (res 0)
(--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
(--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
(--) synaptics: ETPS/2 Elantech Touchpad: buttons: left right double triple
(--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
(--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
(**) ETPS/2 Elantech Touchpad: always reports core events
(II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 15)
(**) synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
(**) synaptics: ETPS/2 Elantech Touchpad: (accel) MaxSpeed is now 1.75
(**) synaptics: ETPS/2 Elantech Touchpad: (accel) AccelFactor is now 0.155
(**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
(**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
(**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
(**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
(--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
(II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
(**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
(II) config/udev: Adding input device PC Speaker (/dev/input/event6)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) intel(0): EDID vendor "LGD", prod id 592
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1366x768"x0.0   72.30  1366 1414 1446 1526  768 771 776 790 -hsync -vsync (47.4 kHz eP)
(II) intel(0): EDID vendor "LGD", prod id 592
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1366x768"x0.0   72.30  1366 1414 1446 1526  768 771 776 790 -hsync -vsync (47.4 kHz eP)
(II) intel(0): EDID vendor "LGD", prod id 592
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1366x768"x0.0   72.30  1366 1414 1446 1526  768 771 776 790 -hsync -vsync (47.4 kHz eP)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
(II) intel(0): EDID vendor "LGD", prod id 592
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1366x768"x0.0   72.30  1366 1414 1446 1526  768 771 776 790 -hsync -vsync (47.4 kHz eP)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server

I have no idea how to fix this...

Last edited by @ilio (2013-04-22 13:03:45)

Offline

#24 2013-04-22 13:06:47

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: Gnome 3.8 not working (upgrade from 3.6)

wwn wrote:

don't care about.

the question is: can I wait some days for a magic pacman -Syyu and all is fine or should I have to read tons of postings and try all of this...

I think waiting will be best option.

Offline

#25 2013-04-22 13:22:33

KingOfFreeMen
Member
Registered: 2013-02-10
Posts: 15

Re: Gnome 3.8 not working (upgrade from 3.6)

@ilio wrote:
KingOfFreeMen wrote:

In my case, GDM doesn't even start anymore, anyone experiencing the same issue ?

Same issue here... Are you using intel drivers?




Yes, and I just solved it ! I simply replaced GDM (# systemctl disable gdm) with Slim (# systemctl enable slim).

Slim starts fine and I'm able to loggin. Gnome 3.8 works.


I'll just wait for a few days for this to be solved before going back to GDM.

Last edited by KingOfFreeMen (2013-04-22 13:35:08)

Offline

Board footer

Powered by FluxBB