You are not logged in.

#1 2013-04-22 22:15:48

dif
Member
From: Stalowa Wola, Poland
Registered: 2009-12-22
Posts: 114

Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

After an update to gnome 3.8 my keybindings stopped working under cinnamon. They still work when I'm logged into gnome.
I tried removing the keybindings and replacing them with new ones, using the usual Settings->Keybord_shortcuts both under gnome and cinnamon. It did not help - the keybindings work under gnome and they don't under cinnamon.

As a workaround,
(1) I installed xbindkeys,
(2) set my shorcuts under ~/.xbindkeysrc  (see wiki)
(3) added xbindkeys to the list of gnome startup applications (run: gnome-session-properties)
(4) logged out of cinnamon and back in.

The keybindings started working again, although the word "again" does nor seem correct as this is a totally different set of key shorcuts  set independantly of the Gnome environment.

I still have no idea why shorcuts work under gnome and not cinnamon.

Offline

#2 2013-04-23 17:44:42

veneratio
Member
Registered: 2011-08-05
Posts: 11

Re: Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

I'm having the same issues and more.  Background settings seem broken too. . . .  Maybe fixes are incoming?  Thanks for the workaround!

Offline

#3 2013-04-23 22:46:35

dif
Member
From: Stalowa Wola, Poland
Registered: 2009-12-22
Posts: 114

Re: Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

Something to add about xbindkeys.
I've now had a hard time adding Ctrl-Alt-Del to my defined keybindings. For some reason I randomly got three different key-code seqences for Ctrl-Alt-Del.

xbindkeys -k

In despare I put all three into my ~/.xbindkeysrc

"gnome-session-quit --power-off"
    Control+Alt+Mod2 + Delete
#   m:0x1c + c:119
"gnome-session-quit --power-off"
    Control+Alt+Mod2 + Control_L
#   m:0x1c + c:37
"gnome-session-quit --power-off"
    Control+Alt+Mod2 + Alt_L
#   m:0x1c + c:64

Off topic: I read that people couldn't set jpg backround wallpapers. I have a "png" wallpaper and had no problem setting it back with the most simple method, i.e. right-clicking the desktop.

Last edited by dif (2013-04-23 22:47:24)

Offline

#4 2013-04-23 23:02:13

LinuxFTW
Member
Registered: 2012-03-17
Posts: 30

Re: Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

Cinnamon seems to be weird for me. It works fine for a while but then the panel will freeze and I can't use alt tab or anything. Anyone know how to fix this?


veneratio wrote:

I'm having the same issues and more.  Background settings seem broken too. . . .  Maybe fixes are incoming?  Thanks for the workaround!

sudo pacman -Rdd nautilus

That should fix it. (If you can't right click on desktop then you haven't set nemo as the default file manager (read the nemo wiki), work around to not setting it as the default would be to manually open nemo (though menu/terminal).

Last edited by LinuxFTW (2013-04-23 23:03:16)

Offline

#5 2013-04-24 23:15:47

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

Hi everyone, I'm the maintainer of the Unity-for-Arch project. I just wanted to let you know that both issues (nautilus background and media keys) are caused because those features are now implemented in GNOME Shell 3.8. They're no longer part of gnome-settings-daemon, which both Unity and Cinnamon use.

It is possible to revert the git commits for gnome-settings-daemon, but note that GNOME Shell will break.

EDIT: From what I can see, the maintainer of the cinnamon package merged some commits from gnome-shell that should fix those issues.

Last edited by chenxiaolong (2013-04-24 23:56:53)


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#6 2013-04-25 02:28:43

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

I hope that all of these issues were solved in version 1.7.4-3:
- gnome-fallback-media-keys-helper is autostarted on login.
- Alt+Tab works again with the default settings.
- The panel no longer freeze. If you still experience this problem, then try to reset these settings:

$ gsettings reset org.gnome.desktop.wm.keybindings switch-applications
$ gsettings reset org.gnome.desktop.wm.keybindings switch-windows

My packages | My PGP Key: 0x0901C163

Offline

#7 2013-06-28 14:19:58

manouchk
Member
Registered: 2008-07-29
Posts: 212

Re: Keybindings not working in Cinnamon with Gnome 3.8 [worked around]

I don't know if my problem is connected to this one but I wasn't able to get the compose key in cinnamon, except by running manually setxkbmap after launching cinnamon. I've tried quite a lot of things!
https://bbs.archlinux.org/viewtopic.php … 7#p1293557
I'm trying Xbindkeys now as an alternative.

Offline

Board footer

Powered by FluxBB