You are not logged in.

#1 2013-04-23 04:54:02

newtonelectron
Member
Registered: 2012-03-29
Posts: 30

[Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

Hi, I can't seem to be able to use the vertical scrolling function of my touchpad on my laptop. I've looked under the usual places in the settings menu to enable vertical scrolling, however I can't find it. I've searched around and haven't found anyone (yet) w/ the same issues. I know there are a lot of 'Gnome 3.8 [whatever] not working' threads at the moment, but if someone could point me in the correct direction....

Last edited by newtonelectron (2013-04-23 05:12:57)

Offline

#2 2013-04-23 05:12:43

newtonelectron
Member
Registered: 2012-03-29
Posts: 30

Re: [Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

So I've found a fix if anyone else is having the same problems:

Gnome settings daemon does not include the option to set 'edge-scrolling' (another of these insane Gnome decisions?)
You must use the 'dconf Editor'. Option, 'scrol-method' is under 'org.gnome.settings-daemon.peripherals.touchpad'. Set that to 'edge-scrolling'.

Offline

#3 2013-04-23 07:45:17

forumache
Member
From: Bucharest, Romania
Registered: 2011-09-02
Posts: 47

Re: [Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

On my laptop it was the same, for a new install. I think the default is two fingers scrolling.
I went into Settings, Mouse and Touchpad end enabled side scrolling.
But on my work computer, that option does not appear. It's ok, it does not have a touchpad.

The option is there for touchpad, Gnome developers did not remove this yet wink
My guess is that your touchpad is identified as a mouse.

Offline

#4 2013-04-23 09:10:45

newtonelectron
Member
Registered: 2012-03-29
Posts: 30

Re: [Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

forumache wrote:

On my laptop it was the same, for a new install. I think the default is two fingers scrolling.
I went into Settings, Mouse and Touchpad end enabled side scrolling.
But on my work computer, that option does not appear. It's ok, it does not have a touchpad.

The option is there for touchpad, Gnome developers did not remove this yet wink
My guess is that your touchpad is identified as a mouse.

Well, it doesn't show up for me:
http://imgur.com/JyRVdFs

Any way to change my touchpad showing up as a mouse, or just live with it?

Last edited by newtonelectron (2013-04-23 09:11:50)

Offline

#5 2013-04-23 14:00:55

dejavu
Member
Registered: 2008-05-26
Posts: 103

Re: [Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

@newtonelectron:
Thanks for the information. I have the same problem and will try your setting.
I am using an old X server (therefore an old synaptics driver) because of the catalyst driver. Probably therefore it doesn't get recognized correct anymore and therefore that special option won't be shown.
The touchpad section will only appear if the synaptics driver is installed, afaik.
Best Regards

Offline

#6 2013-05-02 01:08:42

marcio
Member
Registered: 2010-10-08
Posts: 30

Re: [Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

Why they don't put that kind of option on gnome-control-center?

Offline

#7 2013-10-07 18:25:21

leonardof
Member
Registered: 2008-09-05
Posts: 48

Re: [Solved] Gnome 3.8 Touchpad Synaptics Vertical Scrolling Not Working

newtonelectron wrote:

So I've found a fix if anyone else is having the same problems:

Gnome settings daemon does not include the option to set 'edge-scrolling' (another of these insane Gnome decisions?)
You must use the 'dconf Editor'. Option, 'scrol-method' is under 'org.gnome.settings-daemon.peripherals.touchpad'. Set that to 'edge-scrolling'.

Thank you!

Offline

Board footer

Powered by FluxBB