You are not logged in.

#1 2013-04-23 05:59:11

Registered: 2012-07-09
Posts: 2

[Solved] No module named parse- python errors as own user

A number of applications on my system (wicd and turpial, among others) return python errors when I run them as my own user. I can run these applications as root with no errors, so I'm not missing any packages. The most common of these errors, appearing when I run applications like turpial and hotot looks like this:

➤ turpial 
Traceback (most recent call last):
  File "/usr/bin/turpial", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.3/site-packages/", line 17, in <module>
    from urllib.parse import urlparse, urlunparse
ImportError: No module named parse

When I run wicd-curses:

➤ wicd-curses 
Traceback (most recent call last):
  File "/usr/share/wicd/curses/", line 44, in <module>
    from dbus import DBusException
  File "/usr/lib/python3.3/site-packages/dbus/", line 82, in <module>
    import dbus.types as types
  File "/usr/lib/python3.3/site-packages/dbus/", line 6, in <module>
    from _dbus_bindings import (
ImportError: /usr/lib/python3.3/site-packages/ undefined symbol: PyBytes_Type

Again, both applications mentioned here work fine when run as root. It should also be noted that I only installed turpial after already witnessing this error with hotot-gtk3-git. Has anyone seen this before, or have any idea how to start troubleshooting it?


EDIT: It was a Pythonpath issue.

Last edited by apurplermixture (2013-04-24 00:55:28)


Board footer

Powered by FluxBB