You are not logged in.

#1 2013-04-23 09:30:46

kjozsa
Member
Registered: 2008-06-05
Posts: 112

Gnome 3.8 Alt+Tab behaviour

I updated to Gnome 3.8.1 yesterday - a smooth experience. However, I find that the Alt+Tab key combination works quite hectic, I can not really guess what window it will show up as the first choice. Previously with Gnome 3.6, the first choice of Alt+Tab was the "previous" window I was using from the workspace. Currently.. I have no idea, seems pretty much random for me.

Anyone can comment on this experience? Is there any way to return to the previous, predictable behaviour? If anyone could explain the current logic, it also might help a bit..

Thanks a lot.

Offline

#2 2013-04-23 09:45:07

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Alt+Tab behaviour

The shortcuts has been changed in this version. Now everything is done with "Logo" (the windows key on most keybord).
Check here : https://help.gnome.org/misc/release-not … ts.html.fr


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#3 2013-04-23 09:48:33

kjozsa
Member
Registered: 2008-06-05
Posts: 112

Re: Gnome 3.8 Alt+Tab behaviour

That's right, but the Logo+Tab combination works the same unpredictable way for me. Meanwhile I found this extension: https://extensions.gnome.org/extension/15/alternatetab/ and setting it to switch between windows on the current workspace only does exactly what I need (gnome 3.6 was different, but this fits my needs perfectly).

Offline

#4 2013-04-23 09:51:55

el_psycho
Member
From: Vancouver, Canada
Registered: 2012-04-30
Posts: 24

Re: Gnome 3.8 Alt+Tab behaviour

alt+tab still works for me in gnome 3.8 and it has the same behavior as in 3.6, that is, the last application that was active before is the first choice.
logo+tab works in the same way as alt+tab for me.

Last edited by el_psycho (2013-04-23 09:52:46)

Offline

#5 2013-04-23 09:54:51

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Alt+Tab behaviour

For what I can see, it seems Gnome sorts it by use : the first is the one you use, the second the previous you used, the third the one you used before the second, etc…
I admit I didn't pay a lot attention to it as I rarely use it, I prefer working with the mouse and the dash.


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#6 2013-04-23 17:29:14

kahlil88
Member
From: Mendocino, CA
Registered: 2010-08-10
Posts: 135
Website

Re: Gnome 3.8 Alt+Tab behaviour

Neither works for me, it just ignores the Alt/Super and tabs instead. I thought at first the problem might have been with gtk3-scroll (from AUR) since it was outdated and didn't conflict during the upgrade. Manually updated the PKGBUILD and rebuilt, even tried vanilla gtk3 but I still can't Alt/Super-Tab.

Last edited by kahlil88 (2013-04-23 18:53:34)


There is no system but GNU and Linux is one of its kernels.

Offline

#7 2013-04-23 20:01:57

varg04444
Member
From: Colombia
Registered: 2009-09-26
Posts: 21

Re: Gnome 3.8 Alt+Tab behaviour

I have the same issue. Alt-Tab e Super+Tab have the same behavior. The extension "fix" the problem (really doesn't fix, i like see all applications, but i want first the apps in the current desktop), but would be great have all features smile


[EN] In the world there are 10 kinds of people, those who understand binary and those who not.
[ES] En el mundo hay 10 tipos de personas, las que entienden binario y las que no.

Offline

#8 2013-04-23 23:15:32

dif
Member
From: Stalowa Wola, Poland
Registered: 2009-12-22
Posts: 117

Re: Gnome 3.8 Alt+Tab behaviour

My Alt+Tab did not work after update to gnome 3.8. (I use cinnamon.)
All I had to do to fix it was just to re-set it with Settings->keyboard->Keyboard_shortcuts(tab)->Cinnamon(category)->Cycle_through_open_windows.
I noticed the value was unassigned after update, though.
I can't say anything about the erratic behaviour as mentioned in the title.

I set the custom shortcuts with "xbindkeys" (read wiki) as a workaround, because the standard method mentioned above did not work.

Last edited by dif (2013-04-23 23:17:26)

Offline

#9 2013-04-24 15:18:01

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 370
Website

Re: Gnome 3.8 Alt+Tab behaviour

It's weird, I tought "Alt+Tab" should no switch between the windows. But it does the same like "Super+Tab".
If I set "Alt+Tab" for "Switch Windows" it hangs after the first switch O_o

Offline

#10 2013-04-24 19:19:54

chungy
Member
Registered: 2009-09-07
Posts: 28

Re: Gnome 3.8 Alt+Tab behaviour

I'm having teh same issue.  Alt-Tab (or Super-Tab) doesn't appear to have any sort of consistency.  Applications aren't separated by desktop anymore and the order just appears to be random, not based on the last one you used (I've gotton the CURRENT application second in the list so many times making the combo appear to do nothing... it is aggravating).

Offline

#11 2013-04-25 00:05:44

kahlil88
Member
From: Mendocino, CA
Registered: 2010-08-10
Posts: 135
Website

Re: Gnome 3.8 Alt+Tab behaviour

I eventually got this working when I realized there was a separate keyboard setting for Cinnamon and configured Alt-Tab for switching windows.


There is no system but GNU and Linux is one of its kernels.

Offline

#12 2013-04-25 02:21:22

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Gnome 3.8 Alt+Tab behaviour

@dif, kahlil88: I modified Cinnamon behavior in version 1.7.4-3 to use the same keybinding as GNOME Shell for Alt+Tab. You have to reset your settings to avoid problems:

$ gsettings reset org.gnome.desktop.wm.keybindings switch-applications
$ gsettings reset org.gnome.desktop.wm.keybindings switch-windows

Last edited by City-busz (2013-04-25 02:29:17)


My packages | My PGP Key: 0x0901C163

Offline

#13 2013-04-25 15:38:14

Chais
Member
Registered: 2011-08-08
Posts: 32

Re: Gnome 3.8 Alt+Tab behaviour

Previously to 3.8 Alt+Tab would first suggest the applications on the same workspace. After I cycled through them it would switch to the applications on other workspaces. Now it cycles through all applications in order of their last use, which is useless to me. There's a reason I only have a handful of applications per workspace. I don't understand why they even removed the switch for that behaviour. Anyway I found, that Alt+Esc does roughly what I need. It looks butt ugly though (you'll get an unsightly black fram around the windows you're switching to)
If they go on making shitty decisions and not letting their users a choice I'll have to learn more C++ and gtk and start a fork that does it the Arch way...


--
Chais

Offline

#14 2013-04-25 16:15:43

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 370
Website

Re: Gnome 3.8 Alt+Tab behaviour

City-busz wrote:

@dif, kahlil88: I modified Cinnamon behavior in version 1.7.4-3 to use the same keybinding as GNOME Shell for Alt+Tab. You have to reset your settings to avoid problems:

$ gsettings reset org.gnome.desktop.wm.keybindings switch-applications
$ gsettings reset org.gnome.desktop.wm.keybindings switch-windows

What!?
switch application: ['<Super>Tab', '<Alt>Tab'] // that is the default

see here:
https://live.gnome.org/GnomeOS/Design/W … dShortcuts

Desc.                                 Old         New
Switch to next application Alt+Tab Super+Tab
Switch to next window                      This is the 'classic' Alt-Tab

It is not changed.

// UPDATE -> FIX
Use dconf or gsetting to change this:

1.
gsettings reset org.gnome.desktop.wm.keybindings switch-applications
['<Super>Tab', '<Alt>Tab'] -> ['<Super>Tab']
2.
gsettings reset org.gnome.desktop.wm.keybindings switch-windows
[] -> ['<Alt>Tab']

System Settings -> Keyboard won't show you that Super+Tab and Alt+Tab are mapped to switch-applications. System Settings -> Keyboard  will not remove Alt+Tab from switch-applications, when you assign ALT+Tab to an other action!

Last edited by hoschi (2013-04-25 16:23:19)

Offline

#15 2014-02-23 14:10:13

tcsisman
Member
Registered: 2014-02-23
Posts: 1

Re: Gnome 3.8 Alt+Tab behaviour

I was also frustrated due to not being able to switch between the windows of the current workspace with Alt+Tab or Super+Tab and continuously jumping between workspaces with Alt+Tab. In the end, I reached a fix which is in short: make "Switch applications" shortcut as "Alt+Tab" and "Switch windows" shortcut as "Super+Tab".

To give the details, first, I tried to assign "Alt+Tab" to "Switch windows" while keeping "Switch applications" shortcut as "Super+Tab" under  System Settings -> Keyboard -> Shortcuts -> Navigation and had the same problem as

hoschi wrote:

... If I set "Alt+Tab" for "Switch Windows" it hangs after the first switch O_o

Then, I followed

   https://ask.fedoraproject.org/en/questi … t-id-27308

and just made "Switch applications" shortcut as "Alt+Tab" and "Switch windows" shortcut as "Super+Tab". Now, I can switch between the active workspace applications with Super+Tab and switch between the applications in the order I used (mixed workspace) with Alt+Tab.

Last edited by tcsisman (2014-02-23 14:15:57)

Offline

Board footer

Powered by FluxBB