You are not logged in.

#1 2013-04-23 14:01:44

tomzooi
Member
Registered: 2010-05-01
Posts: 24

[Solved] Boot hangs before GDM

Hello all,

After being able to update pacman and all packaged after removing yaourt, arch linux hangs on boot so I'm stuck with windows for now. It does seem to do all the systemd loading, but at some point it will state the following:
[ok] gnome display manager started
      Starting accounts service
      Starting authorization manager

after which the cursor stops blinking and my whole laptop dies, no ctrl+c, no magic key commands can change it status, only a hard off will do the trick.

can somebody tell me what is wrong and how the hell I can fix it?

Tom

Last edited by tomzooi (2013-04-23 16:05:42)

Offline

#2 2013-04-23 14:08:56

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: [Solved] Boot hangs before GDM

Some say that GDM is broken, so you should probably use another DesktopManager, such as LXDM, KDM, SLIM, etc.
At boot can you still access the other virtual terminals? TTY1, 2, and the others? (with Control+Alt+F1, +F2, +F3, etc)
If so, then you can login and do:

sudo systemctl disable gdm
sudo systemctl stop gdm
sudo pacman -S lxdm
sudo systemctl enable lxdm
sudo systemctl start lxdm

If you can't, chroot and do:

sudo systemctl disable gdm
sudo pacman -S lxdm
sudo systemctl enable lxdm
reboot

Or you could install the older version of gdm (and other packages) with pacman -U /var/cache/pacman/pkg/PACKAGE-NAME.tar.xz (if you still have it there).

Last edited by ubunchu (2013-04-23 14:19:23)


Don't forget to mark as [SOLVED].

Offline

#3 2013-04-23 16:06:41

tomzooi
Member
Registered: 2010-05-01
Posts: 24

Re: [Solved] Boot hangs before GDM

Great, that helped, strange that I couldn't acces the other virtual terminals before, because I did try that, however with an external keyboard it did work.... strange laptop. thx anyway.

Offline

#4 2013-04-24 17:59:18

tlleech2
Member
Registered: 2013-04-24
Posts: 1

Re: [Solved] Boot hangs before GDM

The whole system hanged after the last update after gdm started. No keyboard, no other tty, only holding the power button worked. Everybody said that I need to use slim or others instead of gdm. So I did it.
I disabled gdm then installed slim and tried it twice. It said that calling login was failed or something. Then I disabled it and enabled gdm again. Now, it works for me.
I thought, it might help someone...

Offline

#5 2013-04-24 21:38:30

sultanoswing
Member
Registered: 2008-07-23
Posts: 310

Re: [Solved] Boot hangs before GDM

There are already quite a few threads on this issue. I had a similar problem - system froze at boot and I couldn't switch to alternative consoles to solve it, so had to chroot.

You can either:

1. Switch to a different login manager (slim etc), as above

2. If you're using intel graphics chipset, try adding the following to your kernal boot options (via grub, using chroot if, like me, the GRUB menu won't pause for you!):

* Hit 'e' to edit the kernel command line
* Append "i915.i915_enable_rc6=0" (without quotes) as a kernel boot parameter
* boot
* you can of course make this change permanent by editing /etc/default/grub and regenerating your grub config.

4. Some have had success removing then reinstalling gdm:
systemctl stop gdm
pacman -R gdm
rm -rf /var/lib/gdm
pacman -Sy gdm


Arch-4.15.12 (x86_64) w/Gnome 3.28
ASUS P7P55-E-Pro, Geforce GTX460, i5-750, 8GB, Samsung 830 SSD | Intel NUC 5i5RYK | ASUS ux303ua | HP Folio 13

Offline

Board footer

Powered by FluxBB