You are not logged in.

#1 2013-04-25 19:43:17

buntwo
Member
Registered: 2012-02-14
Posts: 14

Flash fullscreen not working properly

When I click the fullscreen button on flash video players (YouTube, vimeo, etc), most of the time it fullscreens for a split second and then exits fullscreen. I have to spam the button really fast and get lucky for the fullscreen mode to "stick." Any ideas?

I've had this problem for a while now, any help is appreciated!

Offline

#2 2013-04-25 20:41:43

Jodell
Member
Registered: 2009-10-09
Posts: 285

Re: Flash fullscreen not working properly

Are you using Gnome 3.8?

Last edited by Jodell (2013-04-25 20:42:02)

Offline

#3 2013-04-25 20:52:33

buntwo
Member
Registered: 2012-02-14
Posts: 14

Re: Flash fullscreen not working properly

I am but this has been a problem even before 3.6

Offline

#4 2013-04-26 02:38:22

0X1A
Member
Registered: 2013-03-27
Posts: 43

Re: Flash fullscreen not working properly

Have you installed the multilib version of flash? Do you have flashplugin installed? What browser are you using?

Offline

#5 2013-05-21 15:21:49

lolow
Member
Registered: 2013-05-21
Posts: 2

Re: Flash fullscreen not working properly

I have the same problem. The first flash fullscreen works, in a firefox or chromium session. Then, if I try again to watch a flash video in fullscreen, it goes fullscreen for a second then the webpage is back with the video freezing. The videoplayback is continuing in another layer, I can hear the sound. If I click on the top of the window, the video continue embedded.

If have extra/flashplugin
and
the content of /etc/adobe/mms.cfg

# Adobe player settings
AVHardwareDisable = 0
FullScreenDisable = 0
LocalFileReadDisable = 1
FileDownloadDisable = 1
FileUploadDisable = 1
LocalStorageLimit = 1
ThirdPartyStorage = 1
AssetCacheSize = 10
AutoUpdateDisable = 1
LegacyDomainMatching = 0
LocalFileLegacyAction = 0
AllowUserLocalTrust = 0
# DisableSockets = 1
OverrideGPUValidation = 1
EnableLinuxHWVideoDecode=1

I try many parameter combinations without success.

Offline

#6 2013-05-22 20:56:06

lmello
Member
From: Brazil
Registered: 2012-11-06
Posts: 295
Website

Re: Flash fullscreen not working properly

I have the exact same problem, using GNOME 3.8.

With youtube videos this does not happen, fullscreen toggle works as expected. Other like blip.tv and vimeo a 'plugin-container' window appears instead, but isn't hightlighted automatically - you must use Alt-Tab or use the favorites/taskbar under 'Activities' and click on it.


Fundamental Axiom of the Universe (aka Murphy's Law): Whatever can go wrong, will go wrong.
First Digital Deduction: Nothing obeys Murphy's Law so well as computers.
Second Digital Deduction: Everything go wrong at least once.
Third Digital Deduction: Things go wrong even when there's absolutely no possibility of anything go wrong.

Offline

#7 2013-05-25 12:57:17

drizzd
Member
Registered: 2012-10-20
Posts: 4

Re: Flash fullscreen not working properly

Offline

#8 2013-07-29 19:32:11

chsinpc
Member
From: Munich, Germany
Registered: 2013-04-07
Posts: 4

Re: Flash fullscreen not working properly

Hello,

there is a workaround to get flash working in fullscreen. I found it at http://askubuntu.com/questions/305417/a … ull-screen:

1. Install devilspie:

pacman -S devilspie

2. Create a directory ~/.devilspie and a configuration file named flash-fullscreen-firefox.ds in there, with the following content:

(if
(is (application_name) "plugin-container")
(begin
(focus)
)
)

3. Make devilspie autostart by creating a devilspie.desktop file in the ~/.config/autostart directory, with the following content:

[Desktop Entry]
Name=Devilspie
GenericName=Devilspie
Exec=/usr/bin/devilspie

Have fun!

Offline

#9 2013-07-29 23:46:40

buntwo
Member
Registered: 2012-02-14
Posts: 14

Re: Flash fullscreen not working properly

Wow, great! Works for me.

Offline

#10 2013-09-06 17:34:09

metapunk
Member
Registered: 2013-09-06
Posts: 1

Re: Flash fullscreen not working properly

And you can do this for chromium like this:

~/.devilspie/flash-fullscreen-chromium.ds

(if
(is (application_name) "exe")
(begin
(focus)
)
)

At least, it is working 4 me! smile

Offline

#11 2013-12-18 03:20:10

aiguofer
Member
Registered: 2011-10-09
Posts: 31

Re: Flash fullscreen not working properly

I know it's a bit old... but just wanted to point out https://extensions.gnome.org/extension/ … -my-focus/ also does the trick in case anyone else stumbles into this problem.

Offline

Board footer

Powered by FluxBB