You are not logged in.

#1 2013-04-25 23:50:21

jnhieber
Member
Registered: 2011-02-01
Posts: 22

[SOLVED] GTK suddenly really slow

Hi,
3 weeks ago i tried cinnamon and gnome but i didn't like it, my Openbox/AWN combo is much faster, so i switched back and removed most unneeded gnome packages.

Since that i have the problem, that all gtk apps ar sometimes really slow (gmrun, thunar, evince... take 5-10 seconds to start, every click takes about 5 seconds). The problem appears often after suspending my laptop. When i kill X and restart it, everything is fast again.

- I have an up to date system (no testing)
- switching gtk theme has to effect
- killing xcompmgr has no effect
- QT apps like virtualbox are fast, firefox and pidgin also not affected
- AWN is fast, except the gtk part (right click menu)
- text input in gtk is fast, only the UI elements like menus and buttons are affected

SW/HW:
Core i5 / 8GB / HD4000 GPU / SSD
up to date versions of intel driver and gtk packages

Last edited by jnhieber (2013-07-13 16:43:12)

Offline

#2 2013-04-26 18:22:50

lorencini.brdev
Member
Registered: 2013-04-26
Posts: 1

Re: [SOLVED] GTK suddenly really slow

I think i can go +1 on this. Every time Gnome locks my screen, and i get that nice screen locker, when i return to the desktop, everything is very slow. Firefox takes 30 seconds to start, going into/out overview mode on gnome shell is a pain... when i reboot, or kill X, i get my speed back.

Seems that if i run my machine for hours without letting it lock the screen, the desktop is fast as possible. One lock, then it's slow. Any help?

What outputs should i post here? Let me know if anything is needed...

Thanks in advance.

Hardware and Software:

Intel Core i5 2nd Generation, Radeon HD 6478m with FGLRX drivers
Gnome 3.8.1 fully updated (no testing), and linux kernel 3.8.8-2-ARCH

Last edited by lorencini.brdev (2013-04-26 18:24:58)

Offline

#3 2013-04-28 22:32:08

jnhieber
Member
Registered: 2011-02-01
Posts: 22

Re: [SOLVED] GTK suddenly really slow

Maybe this can help, i did the following:

$ strace -r gmrun

The output is really fast, but i think the problem is in this line and the following one.
Im 90% sure that gmrun hangs at this line about 3 seconds, and then goes on.

#2277: 0.000060 futex(0x255ba84, FUTEX_WAIT_REQUEUE_PI_PRIVATE, 1, NULL, 0x255bf80) = 0
#2278: 3.008805 futex(0x255bf80, FUTEX_UNLOCK_PI_PRIVATE, 0) = 0

Full strace: http://pastebin.com/CTV2Weyn

Last edited by jnhieber (2013-04-28 22:32:53)

Offline

#4 2013-05-17 12:10:17

jnhieber
Member
Registered: 2011-02-01
Posts: 22

Re: [SOLVED] GTK suddenly really slow

OK, something new:
I woke up my Laptop, GTK was fast (testet with gmrun). Then my WLAN connection was established after a few seconds, now gmrun was very slow.

I disabled WLAN with the HW switch and it was fast again. Killing nm-applet has no effect. I will test later without networkmanager and manually WLAN connection.

Offline

#5 2013-05-24 10:30:30

kahlil88
Member
From: Mendocino, CA
Registered: 2010-08-10
Posts: 132
Website

Re: [SOLVED] GTK suddenly really slow

I'm running MATE and noticing this as well. Looking at the system monitor, X and Caja (the file manager) are each using around 800MB of RAM!


There is no system but GNU and Linux is one of its kernels.

Offline

#6 2013-05-26 21:24:21

jnhieber
Member
Registered: 2011-02-01
Posts: 22

Re: [SOLVED] GTK suddenly really slow

OK, some new infos:
I disabled networkmanager and connected manuall via wpa supplicant, i removed all entries from resolv.conf and didn't provide any default gateway route. the only routes are the route in the network connected directly.

so now the test: all devices in the wireless network are in the 192.168.0.0/24 subnet (wlan aps, routers, some pcs and ipad/ iphones...). i gave the wlan0 adapter a address in this subnet and GTK was suddenly slow. no i gave me a ip in the 192.168.1.0/24 subnet, where no other devices are, and GTK was fast again.

So the only difference i can see, is that in the first subnet the other devices have ips, in the second subnet no other device has a ip.
but i don't have any default routes enabled and no DNS. so the question is, what is GTK doing in the network? scanning the whole ip area for clients?

BTW: for all other subnets except 192.168.0.0, GTk is fast.

BTW: i configured my xserver to accept tcp connections, as i don't use this anymore i disabled it. but it will took a few days to see if this is/was the problem. => Tested, has no effect sad

kahlil88: gmrun ram usage is in both cases the same, when its slow and when its fast

Last edited by jnhieber (2013-05-28 21:49:56)

Offline

#7 2013-07-13 13:17:20

jnhieber
Member
Registered: 2011-02-01
Posts: 22

Re: [SOLVED] GTK suddenly really slow

OK the problem has gone away.
i don't know why, maybe some update.

Last edited by jnhieber (2013-07-13 16:42:52)

Offline

Board footer

Powered by FluxBB