You are not logged in.

#1 2013-04-27 17:19:41

Registered: 2013-04-27
Posts: 2

X11 not picking up my monitors

I am having a lot of X11 issues. Neither nouveau nor nvidia drivers got X to start, but with bumblebee on top of them I have output to my VGA screen. I'm trying to get screen output to my laptop built in screen (which works fine before I start X) and my HDMI connected screen - simultaneously or not, whichever way gets it done. The problem seems that the drivers for my graphics card (which worked fine under Ubuntu) doesn't pick up the output streams or something.

As far as I can tell others with GT 540M are also having trouble finding the right configuration on their Arch installs, but Google provided no answers that worked for me.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected primary 1280x1024+0+0 0mm x 0mm
   1280x1024       0.0* 
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0 

Currently installed driver packages: nvidia, nouveau-dri, bumblebee and their dependencies. My xorg.conf file had to be deleted to get any graphics output, and I get no X output when i run something like nvidia-config.

Advice would be appreciated.


#2 2013-04-29 15:56:26

Registered: 2013-01-16
Posts: 42

Re: X11 not picking up my monitors

You are trying to start X, which means you have GUI Desktop Environment or Window Manager installed.

1) If you have installed Nvidia's proprietary drivers, then there is no need to install other drivers (conflict).
2) Have you revised your installation using these guides:

If everything is installed correctly, you should successfully run (as root):

# Xorg -configure 

And depending on your DE/WM here is how you can start a display manager at login:

"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity." --Dennis Ritchie-- RIP


#3 2013-05-01 22:19:22

Registered: 2013-04-27
Posts: 2

Re: X11 not picking up my monitors

Still can't crack it. I tried your instructions with a fresh install (though it is basically what I did in the first place). I cannot get X to start at all. startx renders the message "no screens detected". (Configured X, copied the conf file over, installed X's default environment, and even rebooted to give the proprietary drivers a chance to breathe. No dice.)

Note in my initial post, both intel and nvidia serve as graphics controllers, so I tried installing a bunch more drivers - bumblebee and its optional dependencies - and it made the problem worse.

No clue where to go from here.


#4 2013-05-05 02:07:33

Registered: 2012-02-07
Posts: 3

Re: X11 not picking up my monitors

I have the same gfx cards as you
my setup:

remove all the (nvidia, intel, noveau, etc) and install xf86-video-fbdev
remove xorg.conf and any xorg.conf.d/10-monitor.conf you might have
remove any reference to vga or nomodeset from your /boot/grub/menu.lst
reboot and startx

you should be able to have your screen in mirror

my problem is that I'm unable to have dual screen and I've tried installing the nvidia-304xx driver and configuring a xorg.conf.d/10-monitor.conf file
I don't really care which driver I need to use to have the dual screen working (intel or nvidia or vesa)
like I said, my gfx cards are the same as sequel's

anyone have any tips?

EDIT: I have now fixed my problem by uninstalling the fbdev and installing intel and using arandr to configure the monitors

Last edited by tt* (2013-05-11 18:57:23)


Board footer

Powered by FluxBB