You are not logged in.

#1 2013-04-29 20:49:31

LyCC
Member
Registered: 2012-09-05
Posts: 92

Realtek ALC888 5.1 Sound problems

Hello everyone,

I have been using Arch with KDE for quite a bit now, but i'm still a stranger to the sound system (maybe i'm just dumb and all),
i have a GA-965P-DS3 motherboard with a Realtek ALC888 8 Channel Audio on it, i have an 5.1 plugged in the back and a headphone in the front.
I rearly use the 5.1, about a month or so. First i used just plain alsa and kMix, it was all fine, untill the native Steam client comed and i noticed that
all games are running in a 7.1 setup, so ... i installed pulseaudio (i never liked it, but ...), then it was all ok, untill some kernet update.
Now i have the following issue, when i boot Arch, I allways get the KDE multimedia warning that yada yada yada device is not available, do you want
to forget, yada yada yada ... and i have no audio at all. So i have to open kMix, and at the Audio Hardware Setup i need to chose Headphones (however
it can't remember this setting, i have to make this at every boot), so far ok, now comes the 5.1, at headphone i have 2 channels at the 5.1 pluged in at
the back of the PC, when i chose 5.1 or whatever i have absolutly no sound at all (the channels are mutted every time i change the profile/connector
in kMix, i unmute them, even tried in alsamixer, everything unmuted, no sound once so ever, even tried the speaker-test -c 6 , speaker-test -c 2 nothing,
it only works on "headphones" connector and two channels). Here is an image of kMix:
144m.jpg

fuser -fv /dev/snd/* /dev/dsp*
Specified filename /dev/dsp* does not exist.
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  user        407 F.... kded4
                     user        661 F.... kmix
                     user        751 F.... pulseaudio
lsmod | grep '^snd' | column -t
snd_hda_codec_realtek  62279   1
snd_hda_intel          33946   5
snd_hda_codec          101474  2   snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              6364    1   snd_hda_codec
snd_pcm                76956   2   snd_hda_codec,snd_hda_intel
snd_page_alloc         7298    2   snd_pcm,snd_hda_intel
snd_timer              18687   1   snd_pcm
snd                    58893   16  snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel
ls -l /dev/snd
total 0
drwxr-xr-x  2 root root       60 Apr 29 00:33 by-path
crw-rw----+ 1 root audio 116,  8 Apr 29 00:33 controlC0
crw-rw----+ 1 root audio 116,  7 Apr 29 00:33 hwC0D2
crw-rw----+ 1 root audio 116,  6 Apr 29 08:41 pcmC0D0c
crw-rw----+ 1 root audio 116,  5 Apr 29 23:24 pcmC0D0p
crw-rw----+ 1 root audio 116,  4 Apr 29 00:33 pcmC0D1c
crw-rw----+ 1 root audio 116,  3 Apr 29 00:33 pcmC0D1p
crw-rw----+ 1 root audio 116,  2 Apr 29 00:33 pcmC0D2c
crw-rw----  1 root audio 116,  1 Apr 29 00:33 seq
crw-rw----+ 1 root audio 116, 33 Apr 29 00:33 timer

Anyone any ideas on how to get the 5.1 working? thank you, help is appreciated.

Last edited by LyCC (2013-04-29 21:54:01)

Offline

Board footer

Powered by FluxBB