You are not logged in.

#1 2013-04-30 02:22:31

ceramics
Member
Registered: 2013-04-30
Posts: 4

(SOLVED) Rawtherapee 1:4.0.10-2 not starting after update.

After upgrading my system (-Syu), and with it rawtherapee to 1:4.0.10-2, rawtherapee will not start. The following message is given when rawtherapee is started from the terminal:
"rawtherapee: error while loading shared libraries: libpng16.so.16: cannot open shared object file: No such file or directory". 

I am currently running the i686 version of archlinux.
I had a look at the packages that might provide libpng16 and found that lib32-libpng that is in Multilib provides libpng15.so.15.15.0, and I wondered if the problem might be that the latest rawtherapee requires something that is not yet in the repository?

I am very new to arch and wondered if I should be posting this as a bug report, but didn't want to waste someone's time?  Please let me know if I should submit it as a bug?

Last edited by ceramics (2013-04-30 22:52:03)

Offline

#2 2013-04-30 02:52:53

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: (SOLVED) Rawtherapee 1:4.0.10-2 not starting after update.

Welcome to forums ceramics.

There's a big libpng rebuild going on in the staging repo right now. That libpng provides the correct version. I'm guessing that rawtherapee wasn't supposed to be pushed out into community yet. If that's the case, then it's a bug.

Offline

#3 2013-04-30 04:32:56

ceramics
Member
Registered: 2013-04-30
Posts: 4

Re: (SOLVED) Rawtherapee 1:4.0.10-2 not starting after update.

Thank you for your quick reply skottish, it is much appreciated.  I have filed a bug report.

Offline

#4 2013-04-30 22:50:46

ceramics
Member
Registered: 2013-04-30
Posts: 4

Re: (SOLVED) Rawtherapee 1:4.0.10-2 not starting after update.

Happy to report that it has been fixed wonderfully promptly with Rawtherapee 1:4.0.10-4.
Thank You.

Offline

Board footer

Powered by FluxBB