You are not logged in.

#1 2013-04-30 07:38:28

Registered: 2011-01-26
Posts: 70

[Solved] Gstreamer 1.0.7 and pulsesink plugin

I noticed quite recently that when I play sound using whatever gstreamer 1.0 application, it plays through PulseAudio's ALSA plugin, instead of playing directly through pulse. I have installed every gstreamer package available in the official repos, and when I enter

gst-inspect-1.0 pulsesink

it returns stating that there is no such plugin. On the contrary, with gstreamer0.10,

gst-inspect-0.10 pulsesink

returns the whole specifications of the pulse plugin.

Is there something I missed ? Does it work on your installation ? Thanks in advance.

[Edit] I managed to get it to work with pulse after going back to gstreamer 1.0.6 then upgrading to 1.0.7 again. Now I've got problems opening video in Totem. I did a fsck check and nothing wrong happens... may something have gone wrong in my root partition ?

[Edit 2] Ok I had to remove gst-libav and install it again. Don't know where it came from, but this problem is solved.
All credits go to lazork :
Although I still don't know why I had to install it again...

Last edited by omer666 (2013-05-02 08:58:52)


Board footer

Powered by FluxBB