You are not logged in.

#1 2005-11-01 23:28:53

uggwar
Member
From: Oslo, Norway
Registered: 2005-01-13
Posts: 9

tetex 3.0 is extremely slow

somehow everything in tetex 3.0 is performing extremely slow. it takes maybe 20 seconds to get to the prompt by typing 'latex'. anyone else having the same problem? have i forgotten some post install configuration?

i run tetex 3.0 at work under cygwin (yeah, i know) and it seems to perform 100x faster. and no, it is not a 100x faster computer :-)

Offline

#2 2005-11-02 03:01:44

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: tetex 3.0 is extremely slow

latex runs quickly here.  When you compare with the latex at work, do you process the same document? It could take 20 s for latex to process a large document ( 100+ pages with figures).

Offline

#3 2005-11-02 09:06:44

uggwar
Member
From: Oslo, Norway
Registered: 2005-01-13
Posts: 9

Re: tetex 3.0 is extremely slow

yes, i am testing a typical "hello world" document, which is processed in less than a second at work, but on my beloved arch laptop it takes maybe 120 seconds.

everything that has to do with tetex takes forever. like starting lyx etc.

christer

Offline

#4 2005-11-02 18:23:56

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: tetex 3.0 is extremely slow

That's strange. Try reinstalling tetex.

Offline

#5 2005-11-03 22:55:17

uggwar
Member
From: Oslo, Norway
Registered: 2005-01-13
Posts: 9

Re: tetex 3.0 is extremely slow

Reinstalled tetex, but I have the same problem. It takes 30 sec. to get to the prompt by typing 'latex'. It is alot of activity on the harddrive, like it is searching for something.

christer

Offline

#6 2005-11-03 23:40:45

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: tetex 3.0 is extremely slow

Have you checked the output for error message?

Offline

#7 2005-11-03 23:54:17

uggwar
Member
From: Oslo, Norway
Registered: 2005-01-13
Posts: 9

Re: tetex 3.0 is extremely slow

I created a new user and it worked perfectly... I am trying to find out what config file in my home directory that causes it, but I can't seem to find any obvious ones.

christer

Offline

#8 2005-11-04 06:06:09

Largon
Member
From: Czech Republic
Registered: 2004-11-03
Posts: 18
Website

Re: tetex 3.0 is extremely slow

I have the same problem. When I tried strace tex ... I found that TeX browses all files in my $HOME. It searchs for .texmf-config.

Offline

#9 2005-11-04 11:37:05

jftaylor21
Member
From: Arch Linux Forums
Registered: 2004-02-21
Posts: 237

Re: tetex 3.0 is extremely slow

Hmm.... If that is the case, you should be able to create an empty file in your home directory called .texmf-config to fix the problem. That is kind of weird though, I have a ton of files in my home directory without a .texmf-config file and latex runs quickly for me.

Offline

#10 2005-11-04 13:58:16

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: tetex 3.0 is extremely slow

Usually ~/.texmf-config/ is created by running 'texconfig'. Maybe that could be of some help?

Offline

#11 2006-06-05 09:11:41

uggwar
Member
From: Oslo, Norway
Registered: 2005-01-13
Posts: 9

Re: tetex 3.0 is extremely slow

Been a while since last time, but i'll post anyway :-)

It seems to be the $HOME variable that is set to /home/user/ and not /home/user. This does give kpathsea a /home/user//path/ where the // will tell kpathsea to do a recursive search.

Setting HOME=/home/user also fixed the annoying bug with zsh/bash that they wouldn't abbr my home path to ~.

Where should this be fixed?

Christer.

Offline

#12 2006-06-05 17:12:18

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: tetex 3.0 is extremely slow

Use usermod to change the HOME dir (man usermod).

Offline

#13 2006-06-07 15:53:22

eWoud
Member
Registered: 2005-07-06
Posts: 39

Re: tetex 3.0 is extremely slow

uggwar wrote:

It seems to be the $HOME variable that is set to /home/user/ and not /home/user. This does give kpathsea a /home/user//path/ where the // will tell kpathsea to do a recursive search.

Setting HOME=/home/user also fixed the annoying bug with zsh/bash that they wouldn't abbr my home path to ~.

Yes! finally got those two problems fixed. pdflatex load times were hell.

Thanks.


tea is overrated

Offline

Board footer

Powered by FluxBB