You are not logged in.

#1 2013-04-30 18:56:24

From: St. Louis
Registered: 2011-05-16
Posts: 251

[SOLVED] Trouble playing DVDs

VLC spits the error:

Playback failure:
DVDRead could not open the disc "/dev/dvd".
Your input can't be opened:
VLC is unable to open the MRL 'dvd:///dev/dvd'. Check the log for details.

and the same thing for /dev/sr0

When trying to play through mplayer:

mplayer -dvd-device /dev/sr0 dvd://1

MPlayer SVN-r35920-4.7.2 (C) 2000-2013 MPlayer Team
203 audio & 421 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvd://1.
libdvdread: Using libdvdcss version 1.2.12 for DVD access
libdvdread: Could not open /dev/sr0 with libdvdcss.
libdvdread: Can't open /dev/sr0 for reading
Couldn't open DVD device: /dev/sr0 (No medium found)
No stream found to handle url dvd://1

Exiting... (End of file)

I get the same result when I don't specify the dvd-device except '/dev/sr0' is replaced with '/dev/dvd'

So far, I can't access my DVD with any program, including VLC, mplayer, handbrake, etc. I am not too sure about mount points. Could that be an issue? I have ldm installed and followed these instructions. What else can I do to narrow down what is causing the problem?

Last edited by jgreen1tc (2013-05-01 00:54:13)


#2 2013-05-01 00:46:27

Registered: 2013-02-21
Posts: 278

Re: [SOLVED] Trouble playing DVDs

A couple of thoughts.
Does lsblk show /dev/sr0 as your optical drive?
Does lsdvd or similar show there to be a chapter 1 on the DVD?
How about

mplayer dvdnav:// -mouse-movements

Have you used this DVD drive with Arch before?
extra/libdvdcss 1.2.12-1 is from early march, but you have MPlayer SVN-r35920-4.7.2. Are you up to date?

pacman -Ss dvdcss mplayer
extra/libdvdcss 1.2.13-1 [installed]
extra/mplayer 35920-1 [installed]
    A movie player for linux

Edit: Spelling, grammar

Last edited by teckk (2013-05-01 00:49:29)


#3 2013-05-01 00:53:49

From: St. Louis
Registered: 2011-05-16
Posts: 251

Re: [SOLVED] Trouble playing DVDs

Oh man I'm embarrassed. I was trying to play/rip the BluRay version of my DVD. Everything is up to date, I have used DVDs on Arch before... Everything is fine. I feel like an idiot. No problem here.

Edit: at least no problem that wasn't caused by my oversight. God, that was a day wasted...

Last edited by jgreen1tc (2013-05-01 01:03:20)


Board footer

Powered by FluxBB