You are not logged in.

#1 2013-05-01 11:59:26

ubunchu
Member
Registered: 2012-05-01
Posts: 175

[SOLVED] yaourt musescore -build error

EDIT: Solution at the end.

Hello, I was trying to build musescore, when I got:

Qt lib found at /usr/lib64
CMake Error at CMakeLists.txt:161 (message):
  Fatal error: ALSA >= 1.0.0 required


-- Configuring incomplete, errors occurred!

This happened on every machine I tried. I have alsa-utils installed.
Any hints?

Thanks in advance.

Last edited by ubunchu (2013-05-01 14:49:50)


Don't forget to mark as [SOLVED].

Offline

#2 2013-05-01 12:09:50

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: [SOLVED] yaourt musescore -build error

As always, when an error arises with yaourt, try building it manually with makepkg, and see if the same error arises. If it succeeds, then the problem was yaourt. If it fails, makepkg may reveal more helpful error output.

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#3 2013-05-01 12:20:42

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,153

Re: [SOLVED] yaourt musescore -build error

Builds fine in a clean chroot.

Last edited by WorMzy (2013-05-01 12:30:41)


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Online

#4 2013-05-01 12:27:54

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,900

Re: [SOLVED] yaourt musescore -build error

% pkgfile alsa.pc
extra/alsa-lib
multilib/lib32-alsa-lib

Something wrong with your alsa-lib package?

Offline

#5 2013-05-01 12:51:46

ubunchu
Member
Registered: 2012-05-01
Posts: 175

Re: [SOLVED] yaourt musescore -build error

I tried to build from source, same error. I reinstalled the alsa packages, no change, same problem.

EDIT: Same with makepkg -s.

Last edited by ubunchu (2013-05-01 13:08:59)


Don't forget to mark as [SOLVED].

Offline

#6 2013-05-01 14:48:02

ubunchu
Member
Registered: 2012-05-01
Posts: 175

Re: [SOLVED] yaourt musescore -build error

UPDATE: Weird...
Computer 1, 32bit, build failed because of the reason mentioned before.
Computer 2, 64bit, build failed because of the same thing.
Computer 2, 32bit, success.

Computer 1 -32bit, and Computer 2 -64bit, have these things in common: both have alsa-lib installed.
Computer 2 -32bit does not have alsa-lib, this has pulseaudio (which ironically does not work atm).

This is from the build:

-- The C compiler identification is GNU 4.8.0
-- The CXX compiler identification is GNU 4.8.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found Doxygen: /usr/bin/doxygen (found version "1.8.3.1") 
found Doxygen
-- configured /tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/mscore/Doxyfile.in --> /tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/build/Doxyfile
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt4: /usr/bin/qmake-qt4 (found suitable version "4.8.4", minimum required is "4.6") 
Qt lib found at /usr/lib
Alsa detected.
-- jack (jack audio connection kit) >= 0.98.0 found
portaudio detected /usr/include /usr/lib -lportaudio -lasound -lm -lpthread
-- CMAKE_CXX_COMPILER_ID:GNU
-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/build
make[1]: Entering directory `/tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/build'
make[2]: Entering directory `/tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/build'
make[3]: Entering directory `/tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/build'
make[4]: Entering directory `/tmp/yaourt-tmp-ubunchu/aur-musescore/src/mscore-1.3/build'

Solved.
In case someone needs it asap, here you go: http://www.mediafire.com/?sh88807ja4ghtbu
(works properly on 32-bit machines, did not try on 64)
Cheers!

Thinking: maybe the build failed because of sound permissions, though I'm not sure, since I tried as root as well.

Last edited by ubunchu (2013-05-01 14:50:17)


Don't forget to mark as [SOLVED].

Offline

Board footer

Powered by FluxBB