You are not logged in.

#1 2013-05-06 16:29:03

vwyodajl
Member
Registered: 2012-01-21
Posts: 183

[Solved] Filezilla issues with vsftpd - GnuTLS error -15

I am trying to setup vsftpd on a new server and I am running into issues when I am connecting to that box with Filezilla.

Error:

GnuTLS error -15: An unexpected TLS packet was received.

Full debug output:

Status:	Resolving address of site.com
Status:	Connecting to m.y.i.p:21...
Status:	Connection established, waiting for welcome message...
Trace:	CFtpControlSocket::OnReceive()
Response:	220 (vsFTPd 3.0.2)
Trace:	CFtpControlSocket::SendNextCommand()
Command:	AUTH TLS
Trace:	CFtpControlSocket::OnReceive()
Response:	234 Proceed with negotiation.
Status:	Initializing TLS...
Trace:	CTlsSocket::Handshake()
Trace:	CTlsSocket::ContinueHandshake()
Trace:	CTlsSocket::OnSend()
Trace:	CTlsSocket::OnRead()
Trace:	CTlsSocket::ContinueHandshake()
Trace:	CTlsSocket::OnRead()
Trace:	CTlsSocket::ContinueHandshake()
Trace:	TLS Handshake successful
Trace:	Cipher: AES-256-CBC, MAC: SHA256
Status:	Verifying certificate...
Trace:	CFtpControlSocket::SendNextCommand()
Command:	USER username
Status:	TLS/SSL connection established.
Trace:	CTlsSocket::OnRead()
Trace:	CFtpControlSocket::OnReceive()
Response:	331 Please specify the password.
Trace:	CFtpControlSocket::SendNextCommand()
Command:	PASS ******************************
Trace:	CTlsSocket::OnRead()
Trace:	CTlsSocket::Failure(-15, 103)
Error:	GnuTLS error -15: An unexpected TLS packet was received.
Trace:	CRealControlSocket::OnClose(103)
Trace:	CControlSocket::DoClose(64)
Trace:	CFtpControlSocket::ResetOperation(66)
Trace:	CControlSocket::ResetOperation(66)
Error:	Could not connect to server
Trace:	CFileZillaEnginePrivate::ResetOperation(66)

I followed the setup in the Wiki [1]. I have tried searching on google for a solution, but I am noticing most have the error from Gnutils as -9 not -15 not sure if that makes a difference, but I can not seem to figure out what I am missing here. The rest of the solutions I have found online are to add curl options into PHP code, which I did not think was the correct way to try and solve this.

Config:

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
chroot_local_user=YES
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd with two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES


userlist_deny=NO
userlist_file=/etc/vsftpd.user_list
local_max_rate=1000000 # Maximum data transfer rate in bytes per second
max_clients=2         # Maximum number of clients that may be connected
max_per_ip=2           # Maximum connections per IP
#this is important
ssl_enable=YES
ssl_ciphers=HIGH
#choose what you like, if you accept anon-connections
# you may want to enable this
# allow_anon_ssl=NO

#choose what you like,
# it's a matter of performance i guess
# force_local_data_ssl=NO

#choose what you like
force_local_logins_ssl=YES

#you should at least enable this if you enable ssl...
ssl_tlsv1=YES
#choose what you like
ssl_sslv2=YES
#choose what you like
ssl_sslv3=YES
#give the correct path to your currently generated *.pem file
rsa_cert_file=/etc/ssl/certs/vsftpd.pem
#the *.pem file contains both the key and cert
rsa_private_key_file=/etc/ssl/certs/vsftpd.pem
guest_enable=YES
guest_username=virtual
virtual_use_local_privs=YES
local_root=/srv/ftp/$USER
user_sub_token=$USER

Can anyone spot my mistake here? Thanks for the help and time.

[1] https://wiki.archlinux.org/index.php/Ve … root.28.29

EDIT: I also tried to connect with lftp and get the same type of error:

Fatal error: gnutls_record_recv: An unexpected TLS packet was received.

Last edited by vwyodajl (2013-05-06 17:53:43)

Offline

#2 2013-05-06 17:47:47

vwyodajl
Member
Registered: 2012-01-21
Posts: 183

Re: [Solved] Filezilla issues with vsftpd - GnuTLS error -15

Well I got a little further. Figured out that it was due to missing the file
/etc/vsftpd.chroot_list

Now that its there it logs in without that error but hangs on LIST now.

Offline

#3 2013-05-06 17:54:25

vwyodajl
Member
Registered: 2012-01-21
Posts: 183

Re: [Solved] Filezilla issues with vsftpd - GnuTLS error -15

My issue with LIST was I forgot to enable
pasv_enable=YES
pasv_min_port=PortNumber
pasv_max_port=PortNumber
pasv_address=ip.ad.dr.e.ss

Offline

#4 2019-09-23 07:05:40

doctorzeus
Member
Registered: 2011-12-24
Posts: 66

Re: [Solved] Filezilla issues with vsftpd - GnuTLS error -15

Old post I know but I am also stuck on this problem after spending a solid 10-12 hours trying to fix it.

Everything works fine without SSL encryption however the use case I am looking for is definitely going to require it and I experience the same issue when tried on our Ubuntu PROD server (so guessing not necessarily distro related)!

Found a lot of posts on the internet stating that adding "ssl_ciphers=HIGH" solved the issue however for me this was unfortunately not the case..

Offline

#5 2019-09-23 08:06:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,995

Re: [Solved] Filezilla issues with vsftpd - GnuTLS error -15

The problem was solved at that point in time, if you have an issue chances that it is completely unrelated to something solved 6 years ago are almost guaranteed. Make your own thread with information from your own system.

Don't necrobump, closing.

Offline

Board footer

Powered by FluxBB