You are not logged in.

#1 2013-05-07 18:52:41

weirddan455
Member
Registered: 2012-04-15
Posts: 192

Couple errors relating to the libpng update. Should I worry?

I just did a "pacman -Syu" and a couple packages popped errors probably related to the libpng upgrade.  Libpng was upgraded with the same command but it did it's upgrade before these two packages that popped errors.  FIrefox was one of the packages with an error but I'm using it at the moment and don't notice any obvious issues.

Here's the relevent part of /var/log/pacman.log

[2013-05-07 10:30] [PACMAN] Running 'pacman -Syu'
[2013-05-07 10:30] [PACMAN] synchronizing package lists
[2013-05-07 10:31] [PACMAN] starting full system upgrade
[2013-05-07 10:34] [PACMAN] upgraded alsa-lib (1.0.27-1 -> 1.0.27-2)
[2013-05-07 10:34] [PACMAN] upgraded avahi (0.6.31-6 -> 0.6.31-7)
[2013-05-07 10:34] [PACMAN] upgraded libpng (1.5.15-1 -> 1.6.2-3)
[2013-05-07 10:34] [PACMAN] upgraded cairo (1.12.14-3 -> 1.12.14-4)
[2013-05-07 10:34] [ALPM-SCRIPTLET] gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-07 10:34] [PACMAN] upgraded firefox (20.0.1-2 -> 20.0.1-5)
[2013-05-07 10:34] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-07 10:34] [PACMAN] upgraded gdk-pixbuf2 (2.28.1-1 -> 2.28.1-2)
[2013-05-07 10:34] [PACMAN] upgraded libkate (0.4.1-3 -> 0.4.1-4)
[2013-05-07 10:34] [PACMAN] upgraded librsvg (2.37.0-1 -> 2.37.0-2)
[2013-05-07 10:34] [PACMAN] upgraded mkinitcpio (0.13.0-1 -> 0.14.0-1)
[2013-05-07 10:34] [PACMAN] upgraded qt4 (4.8.4-16 -> 4.8.4-17)
[2013-05-07 10:34] [PACMAN] upgraded sdl_image (1.2.12-2 -> 1.2.12-3)
[2013-05-07 10:34] [PACMAN] upgraded tumbler (0.1.27-2 -> 0.1.29-1)
[2013-05-07 10:34] [PACMAN] upgraded zvbi (0.2.33-4 -> 0.2.33-5)
[2013-05-07 10:34] [PACMAN] upgraded vlc (2.0.6-1 -> 2.0.6-2)
[2013-05-07 10:34] [PACMAN] upgraded wxgtk (2.8.12.1-4 -> 2.8.12.1-5)

IIRC (I already closed the terminal and rebooted) the errors were on Firefox for sure, and I think gdk-pixbuf2.  I'm assuming pacman.log just puts the errors above the affected package while it was the opposite in the terminal.  I guess it's possible it was cairo popping the error instead though.

Offline

#2 2013-05-07 19:03:56

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Couple errors relating to the libpng update. Should I worry?

Please search before posting.
https://bbs.archlinux.org/viewtopic.php?id=162661
https://bbs.archlinux.org/viewtopic.php?id=162840

weirddan455 wrote:

I'm assuming pacman.log just puts the errors above the affected package while it was the opposite in the terminal.

Yes.

Offline

#3 2013-05-07 20:42:30

weirddan455
Member
Registered: 2012-04-15
Posts: 192

Re: Couple errors relating to the libpng update. Should I worry?

Thanks for the links.  Didn't think to look outside the Upgrade forum since it seems like the proper place for this topic.

I just did a

pacman -S gdk-pixbuf2

followed by

pacman -S firefox

Is that enough to make everything install clean or do I need to remove the packages first and then install them again?

Offline

#4 2013-05-07 22:07:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Couple errors relating to the libpng update. Should I worry?

You can try e.g. restarting firefox to see if it works with the new libraries. If it does, you should be just fine.

Offline

Board footer

Powered by FluxBB