You are not logged in.

#1 2013-05-08 07:37:17

Registered: 2010-04-22
Posts: 14

[SOLVED] New motherboard - won't boot - uefi?

Hi all

I have recently installed arch 64 on Herself's machine <rant basis="probably ignorance"> taking a weekend instead of a coupla hours like with /arch/setup</rant>.

I had a lot of issues with uefi and in the end created partitions for /boot (500M) and /boot/efi (500M) (in addition to / (50G) and /home (rest of 320G disk)).  I also had to mess with CSM(?) in the system's configuration to make everything uefi compatible.

Following a fail, a new motherboard* has been installed, and now when booting I now only get to a blank screen with a flashing cursor.

The first thing I did was try to follow the steps of the Guide again (except the destructive bits like partitioning). I can boot from the CD, and I can mount the disk and arch-chroot into it.

Network access is fine, as I am able to do the `pacman -Syu` download (though there were problems when trying to do a full install).  Running `pacman -Sy linux linux-headers` worked correctly, but the reboot took me to the blank screen with flashing cursor.

I tried `mkinitcpio -p linux` but this also booted to the same blank screen with flashing cursor.

I tried running `efibootmgr`, both with the `-c -g -d /dev ...` parameters as directed in the Beginner's Guide, and with -v as suggested in other forum questions, but this resulted in a fatal error about the procfs and another file system not being available. 

Following instructions related to that error, I exited chroot and ran `modprobe efivars`.  There was no success or error message. I chrooted in again and ran the efibootmgr again, but got the same fatal result.

So I'm a bit stuck.  Can someone see anything I'm not doing right, or perhaps suggest the steps I should follow to try to reinstall/reconfigure uefi correctly, preferably without the need to do the partitioning again?

* The new m/board is a Asus p8h77-m
CPU:  Intel G630 2.7Ghz
8GB ram

Last edited by mcalex (2013-05-08 15:58:45)


#2 2013-05-08 15:57:41

Registered: 2010-04-22
Posts: 14

Re: [SOLVED] New motherboard - won't boot - uefi?

OK.  Managed to work this out.

Had to do some serious mucking around with the CSM stuff in the uefi boot thing - finally convinced it that both the CD and HDD were uefi bootable ... or something, and it now boots. (sorta, I seem to have lost the network, but that's a minor issue).

Thanks for the help.    :-)


Board footer

Powered by FluxBB