You are not logged in.

#1 2013-05-12 10:26:43

senjin
Member
Registered: 2006-09-15
Posts: 180
Website

USB drive no longer works after system reinstallation

Recently I reinstalled the system (after 1 year of no uptades). One of my USB disks (strictly speaking it is a 2.5" disk in a USB enclosure) stopped to work. When I connect the USB cable the drive icon doesn't appear on the desktop. I attach the dmesg messages:

[   94.770021] usb 5-5: new high-speed USB device number 3 using ehci-pci
[   95.000996] Initializing USB Mass Storage driver...
[   95.001670] usbcore: registered new interface driver usb-storage
[   95.001677] USB Mass Storage support registered.
[   95.026831] scsi4 : usb-storage 5-5:1.0
[   95.027324] usbcore: registered new interface driver ums-cypress
[   96.070828] scsi 4:0:0:0: Direct-Access     Hitachi  HTS547575A9E384       PQ: 0 ANSI: 0
[   96.073181] sd 4:0:0:0: [sdb] 1465149168 512-byte logical blocks: (750 GB/698 GiB)
[   96.073804] sd 4:0:0:0: [sdb] Write Protect is off
[   96.073813] sd 4:0:0:0: [sdb] Mode Sense: 03 00 00 00
[   96.074428] sd 4:0:0:0: [sdb] No Caching mode page present
[   96.074436] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[   96.076557] sd 4:0:0:0: [sdb] No Caching mode page present
[   96.076568] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[   96.105465]  sdb: sdb1 sdb2
[   96.108041] sd 4:0:0:0: [sdb] No Caching mode page present
[   96.108052] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[   96.108060] sd 4:0:0:0: [sdb] Attached SCSI disk
[  104.480029] usb 5-5: reset high-speed USB device number 3 using ehci-pci
[  116.032583] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.032595] sd 4:0:0:0: [sdb]  
[  116.032600] Result: hostbyte=0x00 driverbyte=0x08
[  116.032605] sd 4:0:0:0: [sdb]  
[  116.032608] Sense Key : 0x3 [current] 
[  116.032615] sd 4:0:0:0: [sdb]  
[  116.032618] ASC=0x12 ASCQ=0x0
[  116.032623] sd 4:0:0:0: [sdb] CDB: 
[  116.032626] cdb[0]=0x28: 28 00 57 54 52 ee 00 00 08 00
[  116.032640] end_request: I/O error, dev sdb, sector 1465144046
[  116.032648] Buffer I/O error on device sdb2, logical block 1269825776
[  116.032655] Buffer I/O error on device sdb2, logical block 1269825777
[  116.032660] Buffer I/O error on device sdb2, logical block 1269825778
[  116.032665] Buffer I/O error on device sdb2, logical block 1269825779
[  116.032669] Buffer I/O error on device sdb2, logical block 1269825780
[  116.032673] Buffer I/O error on device sdb2, logical block 1269825781
[  116.032678] Buffer I/O error on device sdb2, logical block 1269825782
[  116.032682] Buffer I/O error on device sdb2, logical block 1269825783
[  116.192558] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.192568] sd 4:0:0:0: [sdb]  
[  116.192572] Result: hostbyte=0x00 driverbyte=0x08
[  116.192577] sd 4:0:0:0: [sdb]  
[  116.192580] Sense Key : 0x3 [current] 
[  116.192586] sd 4:0:0:0: [sdb]  
[  116.192589] ASC=0x12 ASCQ=0x0
[  116.192594] sd 4:0:0:0: [sdb] CDB: 
[  116.192597] cdb[0]=0x28: 28 00 0b a4 51 3f 00 00 08 00
[  116.192610] end_request: I/O error, dev sdb, sector 195318079
[  116.192617] Buffer I/O error on device sdb1, logical block 195318016
[  116.349174] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.349186] sd 4:0:0:0: [sdb]  
[  116.349191] Result: hostbyte=0x00 driverbyte=0x08
[  116.349196] sd 4:0:0:0: [sdb]  
[  116.349199] Sense Key : 0x3 [current] 
[  116.349206] sd 4:0:0:0: [sdb]  
[  116.349209] ASC=0x12 ASCQ=0x0
[  116.349214] sd 4:0:0:0: [sdb] CDB: 
[  116.349217] cdb[0]=0x28: 28 00 57 54 52 ee 00 00 01 00
[  116.349230] end_request: I/O error, dev sdb, sector 1465144046
[  116.509279] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.509291] sd 4:0:0:0: [sdb]  
[  116.509295] Result: hostbyte=0x00 driverbyte=0x08
[  116.509300] sd 4:0:0:0: [sdb]  
[  116.509304] Sense Key : 0x3 [current] 
[  116.509311] sd 4:0:0:0: [sdb]  
[  116.509314] ASC=0x12 ASCQ=0x0
[  116.509319] sd 4:0:0:0: [sdb] CDB: 
[  116.509322] cdb[0]=0x28: 28 00 57 54 52 ef 00 00 07 00
[  116.509336] end_request: I/O error, dev sdb, sector 1465144047
[  116.669240] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.669249] sd 4:0:0:0: [sdb]  
[  116.669253] Result: hostbyte=0x00 driverbyte=0x08
[  116.669258] sd 4:0:0:0: [sdb]  
[  116.669261] Sense Key : 0x3 [current] 
[  116.669267] sd 4:0:0:0: [sdb]  
[  116.669270] ASC=0x12 ASCQ=0x0
[  116.669275] sd 4:0:0:0: [sdb] CDB: 
[  116.669278] cdb[0]=0x28: 28 00 0b a4 51 3f 00 00 08 00
[  116.669291] end_request: I/O error, dev sdb, sector 195318079
[  116.825843] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.825852] sd 4:0:0:0: [sdb]  
[  116.825856] Result: hostbyte=0x00 driverbyte=0x08
[  116.825860] sd 4:0:0:0: [sdb]  
[  116.825863] Sense Key : 0x3 [current] 
[  116.825870] sd 4:0:0:0: [sdb]  
[  116.825873] ASC=0x12 ASCQ=0x0
[  116.825877] sd 4:0:0:0: [sdb] CDB: 
[  116.825880] cdb[0]=0x28: 28 00 0b a4 51 fe 00 00 08 00
[  116.825892] end_request: I/O error, dev sdb, sector 195318270
[  116.982587] sd 4:0:0:0: [sdb] Unhandled sense code
[  116.982599] sd 4:0:0:0: [sdb]  
[  116.982603] Result: hostbyte=0x00 driverbyte=0x08
[  116.982608] sd 4:0:0:0: [sdb]  
[  116.982611] Sense Key : 0x3 [current] 
[  116.982618] sd 4:0:0:0: [sdb]  
[  116.982621] ASC=0x12 ASCQ=0x0
[  116.982626] sd 4:0:0:0: [sdb] CDB: 
[  116.982629] cdb[0]=0x28: 28 00 0b a4 51 e7 00 00 08 00
[  116.982642] end_request: I/O error, dev sdb, sector 195318247
[  117.139178] sd 4:0:0:0: [sdb] Unhandled sense code
[  117.139189] sd 4:0:0:0: [sdb]  
[  117.139193] Result: hostbyte=0x00 driverbyte=0x08
[  117.139198] sd 4:0:0:0: [sdb]  
[  117.139201] Sense Key : 0x3 [current] 
[  117.139208] sd 4:0:0:0: [sdb]  
[  117.139211] ASC=0x12 ASCQ=0x0
[  117.139216] sd 4:0:0:0: [sdb] CDB: 
[  117.139219] cdb[0]=0x28: 28 00 0b a4 51 fe 00 00 01 00
[  117.139232] end_request: I/O error, dev sdb, sector 195318270
[  117.295904] sd 4:0:0:0: [sdb] Unhandled sense code
[  117.295913] sd 4:0:0:0: [sdb]  
[  117.295917] Result: hostbyte=0x00 driverbyte=0x08
[  117.295922] sd 4:0:0:0: [sdb]  
[  117.295925] Sense Key : 0x3 [current] 
[  117.295932] sd 4:0:0:0: [sdb]  
[  117.295935] ASC=0x12 ASCQ=0x0
[  117.295940] sd 4:0:0:0: [sdb] CDB: 
[  117.295943] cdb[0]=0x28: 28 00 0b a4 51 ff 00 00 07 00
[  117.295955] end_request: I/O error, dev sdb, sector 195318271
[  117.452511] sd 4:0:0:0: [sdb] Unhandled sense code
[  117.452520] sd 4:0:0:0: [sdb]  
[  117.452524] Result: hostbyte=0x00 driverbyte=0x08
[  117.452529] sd 4:0:0:0: [sdb]  
[  117.452532] Sense Key : 0x3 [current] 
[  117.452538] sd 4:0:0:0: [sdb]  
[  117.452541] ASC=0x12 ASCQ=0x0
[  117.452546] sd 4:0:0:0: [sdb] CDB: 
[  117.452549] cdb[0]=0x28: 28 00 0b a4 51 e7 00 00 08 00
[  117.452562] end_request: I/O error, dev sdb, sector 195318247
[  117.609238] sd 4:0:0:0: [sdb] Unhandled sense code
[  117.609247] sd 4:0:0:0: [sdb]  
[  117.609251] Result: hostbyte=0x00 driverbyte=0x08
[  117.609256] sd 4:0:0:0: [sdb]  
[  117.609258] Sense Key : 0x3 [current] 
[  117.609265] sd 4:0:0:0: [sdb]  
[  117.609268] ASC=0x12 ASCQ=0x0
[  117.609273] sd 4:0:0:0: [sdb] CDB: 
[  117.609275] cdb[0]=0x28: 28 00 0b a4 52 06 00 00 08 00
[  117.765841] sd 4:0:0:0: [sdb] Unhandled sense code
[  117.765849] sd 4:0:0:0: [sdb]  
[  117.765853] Result: hostbyte=0x00 driverbyte=0x08
[  117.765858] sd 4:0:0:0: [sdb]  
[  117.765861] Sense Key : 0x3 [current] 
[  117.765867] sd 4:0:0:0: [sdb]  
[  117.765870] ASC=0x12 ASCQ=0x0
[  117.765875] sd 4:0:0:0: [sdb] CDB: 
[  117.765877] cdb[0]=0x28: 28 00 00 00 00 3f 00 00 08 00
[  117.922568] sd 4:0:0:0: [sdb] Unhandled sense code
[  117.922576] sd 4:0:0:0: [sdb]  
[  117.922580] Result: hostbyte=0x00 driverbyte=0x08

... (errors repeat)

If I try to 'mount' it as root I get:

mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

The drive is OK. I was able to use it on other computers, reiserfsck showed no errors. Also my computer is OK, and I was able to mount the drive using some old arch linux cd.


The system is 64-bit, I use the default kernel (3.9.2-1-ARCH x86_64). I wonder, what could be missing in my configuration?

I'm able to use other USB pendrives, hard disks, mouse with no problems

Last edited by senjin (2013-05-12 10:27:29)

Offline

#2 2013-05-12 15:31:36

senjin
Member
Registered: 2006-09-15
Posts: 180
Website

Re: USB drive no longer works after system reinstallation

For comparison, I attach dmesg log from another computer, which sees the drive normally:

[  576.596709] usb 5-3: new high-speed USB device number 3 using ehci-pci
[  577.092795] Initializing USB Mass Storage driver...
[  577.092922] usbcore: registered new interface driver usb-storage
[  577.092926] USB Mass Storage support registered.
[  577.096041] scsi6 : usb-storage 5-3:1.0
[  577.096429] usbcore: registered new interface driver ums-cypress
[  578.097696] scsi 6:0:0:0: Direct-Access     Hitachi  HTS547575A9E384       PQ: 0 ANSI: 0
[  578.100360] sd 6:0:0:0: [sdb] 1465149168 512-byte logical blocks: (750 GB/698 GiB)
[  578.101488] sd 6:0:0:0: [sdb] Write Protect is off
[  578.101499] sd 6:0:0:0: [sdb] Mode Sense: 03 00 00 00
[  578.102675] sd 6:0:0:0: [sdb] No Caching mode page present
[  578.102687] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  578.105731] sd 6:0:0:0: [sdb] No Caching mode page present
[  578.105741] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  578.140717]  sdb: sdb1 sdb2
[  578.143382] sd 6:0:0:0: [sdb] No Caching mode page present
[  578.143391] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  578.143398] sd 6:0:0:0: [sdb] Attached SCSI disk

The computer which doesn't open the drive is fairly old (AMD Athlon 64, MSI K8T Neo2). I wonder, maybe there is some module or firmware that has been recently dropped from the default setup, that I need to install separately?

Offline

#3 2013-05-14 19:38:58

senjin
Member
Registered: 2006-09-15
Posts: 180
Website

Re: USB drive no longer works after system reinstallation

OK, finally, after the problem appeared on anothert machine I have just updated, I tracked down the source to kernel upgrade:
linux-3.8.7-1 is fine
linux-3.8.8-1 and 3.9.2-1 cause problem.

What should I do? File a bug report? Or is it a known problem, and there's a solution for it?

Offline

#4 2013-05-23 19:43:06

senjin
Member
Registered: 2006-09-15
Posts: 180
Website

Re: USB drive no longer works after system reinstallation

Actually it didn't work well just after downgrading the kernel (or was it random?). I managed to make the usb drive stably work again I downgraded the whole system back to April 1, 2013 using ARM. I had to do this on two completely different machines, so I'm quite sure this is a bug related to some of the new packages.

Bug report submitted: https://bugs.archlinux.org/task/35445

Offline

Board footer

Powered by FluxBB