You are not logged in.

#1 2013-05-13 12:14:23

starfry
Member
From: Surrey, UK
Registered: 2010-08-18
Posts: 170

[SOLVED] boot symlink /bin/systemd gone

Just noticed the symlink /bin/systemd which is owned by the systemd package got removed at systemd-204-1. My boot command-line used 'init=/bin/systemd' which is broken by this. My solution is to use init=/usr/lib/systemd/systemd' instead.

Wasn't using '/bin/systemd' the correct way since the removal of /sbin/init ?

Last edited by starfry (2013-05-13 12:36:53)

Offline

#2 2013-05-13 12:15:54

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,249

Re: [SOLVED] boot symlink /bin/systemd gone

No, the correct way is to install systemd-sysvcompat

Offline

#3 2013-05-13 12:18:19

starfry
Member
From: Surrey, UK
Registered: 2010-08-18
Posts: 170

Re: [SOLVED] boot symlink /bin/systemd gone

I thought that was just for people who wanted to hang onto old ways. It is an optional dependency of systemd....

Offline

#4 2013-05-13 12:28:05

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,338

Re: [SOLVED] boot symlink /bin/systemd gone

No, that's the recommended way and is the default on all new installations.

Offline

#5 2013-05-13 12:29:38

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] boot symlink /bin/systemd gone

Offline

#6 2013-05-13 12:36:35

starfry
Member
From: Surrey, UK
Registered: 2010-08-18
Posts: 170

Re: [SOLVED] boot symlink /bin/systemd gone

So the correct practice is to use

init=/usr/lib/systemd/systemd

Marking solved.

Offline

#7 2013-05-13 13:30:30

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED] boot symlink /bin/systemd gone

As arojas said, the correct practice is to install systemd-sysvcompat. It may be an optional dependency, but it is in `base` group, so it should be installed on all systems (unless someone wants to do something unusual, or just doesn't check if all of the base group is installed).

Offline

#8 2013-05-13 13:30:42

mamamia88
Member
Registered: 2012-08-29
Posts: 483

Re: [SOLVED] boot symlink /bin/systemd gone

starfry wrote:

So the correct practice is to use

init=/usr/lib/systemd/systemd

Marking solved.

see part 6.  you don't need to do anything if you have systemd-sysvcompat installed systemd-sysvcompat https://wiki.archlinux.org/index.php/Sy … stallation

Last edited by mamamia88 (2013-05-13 13:31:22)

Offline

#9 2013-05-13 22:38:47

starfry
Member
From: Surrey, UK
Registered: 2010-08-18
Posts: 170

Re: [SOLVED] boot symlink /bin/systemd gone

If using systemd-sysvcompat then you get back the /sbin/init symlink which means you don't need to mess around with kernel parameters at boot, whicn is nice.

Offline

#10 2013-05-15 01:14:35

corp
Member
Registered: 2013-05-15
Posts: 2

Re: [SOLVED] boot symlink /bin/systemd gone

Not sure of the best place to post my question, but as far as having "systemd --user &" in my .xinitrc file, what would be the better option; to create a symlink, or just call /usr/lib/systemd/systemd?

Offline

#11 2013-05-15 01:52:52

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,796

Re: [SOLVED] boot symlink /bin/systemd gone

corp wrote:

Not sure of the best place to post my question, but as far as having "systemd --user &" in my .xinitrc file, what would be the better option; to create a symlink, or just call /usr/lib/systemd/systemd?

Welcome to Arch Linux

Please open a new thread.  Be advised, I have no clue what you are asking there, so when you do open that thread, please be sure to include your question, what you have read, and what you are trying to do.

Thanks.

Leaving the thread open the event the original topic needs any additional discussion.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#12 2013-05-15 19:10:35

MilanKnizek
Member
Registered: 2005-12-13
Posts: 58

Re: [SOLVED] boot symlink /bin/systemd gone

He he, thanks for that post.

I got quite surprised that solution is so easy -> to remove init=/bin/systemd from the boot loader configs (since I have the systemd-sysvcompat installed). It got there in the early days of systemd adoption [1] and I may have missed the info that such a significant thing has changed :-/

[1] https://wiki.archlinux.org/index.php?ti … did=193253

Just a pitty that even the fallback ended up with a console, where typing on my usb wireless keyboard did not do anything and even the old PS/2 keyboard burried deep in boxes in garage was of no help (ctrl + alt + del worked, but only this) and I eventually had to create a live usb on another computer at work.

Offline

#13 2013-05-17 14:47:04

rlevArch
Member
Registered: 2011-12-04
Posts: 35

Re: [SOLVED] boot symlink /bin/systemd gone

This happened to me as well, I guess it was the first time I rebooted since the systemd update to 204 and I got the warning that /bin/systemd was not found. I had it loading as a kernel parameter probably because of the wiki page that MilanKnizek pointed to. I was only able to get back in to my system by pointing init at /usr/lib/systemd/systemd (I don't have a live USB or CD available.

Thanks for the updated info that all I have to do is remove the "init=*" parameter

Offline

#14 2013-05-26 21:04:05

corp
Member
Registered: 2013-05-15
Posts: 2

Re: [SOLVED] boot symlink /bin/systemd gone

Welcome to Arch Linux

Please open a new thread.  Be advised, I have no clue what you are asking there, so when you do open that thread, please be sure to include your question, what you have read, and what you are trying to do.

Thanks.

Leaving the thread open the event the original topic needs any additional discussion.

Was just a general question, I didn't realize I wasn't all too specific. My apologies!

(I have figured my issues out on my own, so I don't need to open a new thread.)

Partially on topic: From the update that deleted the sym link originally, I was having issue getting mpd to start, since I had it set up to run with systemd --user within my .xinitrc file. All I did was to recreate the sym link, and all was good after that. So a question that pertains to this - Is this a proper or improper way in resolving any issues regarding the original problem?

Offline

#15 2013-05-26 21:20:22

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

Re: [SOLVED] boot symlink /bin/systemd gone

I would guess the proper way is a new thread? wink

Offline

Board footer

Powered by FluxBB