You are not logged in.

#1 2013-05-23 11:48:40

ojZim
Member
From: Iran
Registered: 2013-05-05
Posts: 28
Website

[SOLVED] KDE fonts on arch is ugly and poor :(

Hi.
I installed KDE on a virtual arch machine, but the font is ugly. I searched but not founded the soulotion.
It's a screenshot of the ugly font in "Arch Linux + KDE":
http://upload7.ir/images/85945281008671097720.png

In other distros, I have not any problem. It's a screenshot of "Chakra Linux + KDE":
http://upload7.ir/images/00921596256764030800.png

I waiting for your answers! I tested it on many machines, but the font is ugly smile
Thanks.

Last edited by ojZim (2013-05-23 14:17:52)

Offline

#2 2013-05-23 12:08:59

xgdgsc
Member
Registered: 2012-02-03
Posts: 124

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

What's your fonts setting in systemsettings-application appearance( or some other appearance, I don' t remember exactly)?

Offline

#3 2013-05-23 12:13:37

ojZim
Member
From: Iran
Registered: 2013-05-05
Posts: 28
Website

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

It's default settings (Sans Serif) and anti-aliasing is enabled in two distros smile The settings in Arch and Chakra is Equal but the result is Different.

Offline

#4 2013-05-23 12:16:13

kourosh
Member
From: England
Registered: 2009-03-10
Posts: 241
Website

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

Try this font configuration:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

   <match target="font">
    <edit name="antialias" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="font">
    <edit name="hinting" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="font">
    <edit name="hintstyle" mode="assign">
      <const>hintslight</const>
    </edit>
  </match>

  <match target="font">
    <edit name="rgba" mode="assign">
      <const>rgb</const>
    </edit>
  </match>

  <match target="font">
    <edit mode="assign" name="lcdfilter">
      <const>lcddefault</const>
    </edit>
  </match>

</fontconfig>

Paste that into '.config/fontconfig/fonts.conf' and restart KDE, you might also want to look at: https://wiki.archlinux.org/index.php/Font_Configuration

Edit: and also make sure the font configuration in the KDE settings manager is the same as above.

Last edited by kourosh (2013-05-23 12:18:08)

Offline

#5 2013-05-23 12:48:43

ojZim
Member
From: Iran
Registered: 2013-05-05
Posts: 28
Website

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

kourosh wrote:

Try this font configuration:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

   <match target="font">
    <edit name="antialias" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="font">
    <edit name="hinting" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="font">
    <edit name="hintstyle" mode="assign">
      <const>hintslight</const>
    </edit>
  </match>

  <match target="font">
    <edit name="rgba" mode="assign">
      <const>rgb</const>
    </edit>
  </match>

  <match target="font">
    <edit mode="assign" name="lcdfilter">
      <const>lcddefault</const>
    </edit>
  </match>

</fontconfig>

Paste that into '.config/fontconfig/fonts.conf' and restart KDE, you might also want to look at: https://wiki.archlinux.org/index.php/Font_Configuration

Edit: and also make sure the font configuration in the KDE settings manager is the same as above.

Thanks Kourosh (ممنون big_smile)
It's Solved.

Offline

#6 2013-05-23 13:10:12

ojZim
Member
From: Iran
Registered: 2013-05-05
Posts: 28
Website

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

Oh!
Update: It's solved on my virtual machine, it was exists ~/config/fontconfig/fonts.conf file on the virtual machine and I edited it.
but on my real machine, It's not exists. I created it and copied your code on it, but my problem not solved in my real machine.
In virtual machin solved, In real machine not solved sad

Last edited by ojZim (2013-05-23 13:11:51)

Offline

#7 2013-05-23 14:17:43

ojZim
Member
From: Iran
Registered: 2013-05-05
Posts: 28
Website

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

Ok. It's Solved. the fons.conf is located on ~/.font.conf
You must install these packages:

pacman -S ttf-dejavu ttf-liberation

Offline

#8 2016-01-07 11:05:31

strawberryfields
Member
Registered: 2016-01-07
Posts: 5

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

kourosh wrote:

Try this font configuration:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

   <match target="font">
    <edit name="antialias" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="font">
    <edit name="hinting" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="font">
    <edit name="hintstyle" mode="assign">
      <const>hintslight</const>
    </edit>
  </match>

  <match target="font">
    <edit name="rgba" mode="assign">
      <const>rgb</const>
    </edit>
  </match>

  <match target="font">
    <edit mode="assign" name="lcdfilter">
      <const>lcddefault</const>
    </edit>
  </match>

</fontconfig>

Paste that into '.config/fontconfig/fonts.conf' and restart KDE, you might also want to look at: https://wiki.archlinux.org/index.php/Font_Configuration

Edit: and also make sure the font configuration in the KDE settings manager is the same as above.

Thanks so much, I pasted it into ~/.config/fontconfig/fonts.conf, nothing else was necessary. And I got rid of these ugly fonts. Thanks!

Wonder why the default setting is a totally ugly font? Or with other words, wonder why this is not standard in Arch Linux, or why it is not sufficient/possible to do this in the KDE settings manager->fonts...

Last edited by strawberryfields (2016-01-07 11:28:13)

Offline

#9 2016-04-03 09:13:50

strawberryfields
Member
Registered: 2016-01-07
Posts: 5

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

Fresh install of ArchLinux with Plasma 5.6.

Above method doesn't work anymore. Now do

~/.Xresources

Xft.autohint: 0
Xft.lcdfilter:  lcddefault
Xft.hintstyle:  hintslight
Xft.hinting: 1
Xft.antialias: 1
Xft.rgba: rgb

see also https://wiki.archlinux.org/index.php/Fo … me_systems

Offline

#10 2016-04-03 09:28:48

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,307
Website

Re: [SOLVED] KDE fonts on arch is ugly and poor :(

@strawberryfields,

please open a new thread for your problem. Link back to this thread if necessary.

Nevermind, I see that you managed to solve it. Please don't bump old threads in any case.

https://wiki.archlinux.org/index.php/Fo … bumping.22

Closing.

Online

Board footer

Powered by FluxBB