You are not logged in.

#1 2005-11-08 21:39:19

oscar
Member
From: Linköping, Sweden
Registered: 2004-08-13
Posts: 457

Screwed up the "fixed" font, and X wont start with

Hello everyone.

Somehow, after installing a font package (xserver-terminus-fonts), I somehow deleted the default font in X - "fixed", and now, X wont start.
I've tried to locate the file(s), but I haven't figured out where it is, what name it has, and reinstalling xorg hasn't helped either.

I'm out of ideas right now - how do I fix it? sad


To err is human... to really foul up requires the root password.

Offline

#2 2005-11-08 22:44:19

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: Screwed up the "fixed" font, and X wont start with

Font 'fixed' is an alias that is usually defined in /usr/X11R6/lib/X11/fonts/misc/fonts.alias. I have this line in my fonts.alias:

fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1

You can check that the specified font exists with xfontsel. If it doesn't, you can edit the line to point to an existing font.

It is also possible that the font package you installed has messed up some configuration files...  :?

Offline

#3 2005-11-09 11:52:32

oscar
Member
From: Linköping, Sweden
Registered: 2004-08-13
Posts: 457

Re: Screwed up the "fixed" font, and X wont start with

I've tried using some other font as fixed, but instead of going either into graphical mode or straight back to the console, the screen turns black, and nothing more happens - and I have to reboot, every time sad

I hate computers sad


To err is human... to really foul up requires the root password.

Offline

#4 2005-11-09 16:38:56

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Screwed up the "fixed" font, and X wont start with

 $ pacman -Qo  /usr/X11R6/lib/X11/fonts/misc/fonts.alias 
/usr/X11R6/lib/X11/fonts/misc/fonts.alias is owned by xorg 11R6.8.2-6

So reinstalling xorg could fix it.

Offline

#5 2005-11-09 23:55:35

oscar
Member
From: Linköping, Sweden
Registered: 2004-08-13
Posts: 457

Re: Screwed up the "fixed" font, and X wont start with

Reinstalling xorg seems to have fixed the missing font.
Thanks, everyone! smile


To err is human... to really foul up requires the root password.

Offline

Board footer

Powered by FluxBB